Bug 839123 - rhc-admin-chk doesn't work
rhc-admin-chk doesn't work
Status: CLOSED DUPLICATE of bug 839121
Product: OpenShift Origin
Classification: Red Hat
Component: Pod (Show other bugs)
2.x
Unspecified Unspecified
medium Severity low
: ---
: ---
Assigned To: Dan McPherson
libra bugs
: Regression
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-07-10 23:23 EDT by Meng Bo
Modified: 2015-05-14 22:00 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-07-10 23:34:47 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Meng Bo 2012-07-10 23:23:17 EDT
Description of problem:
run rhc-admin-chk in the instance, will get error message:

[root@ip-10-29-203-248 stickshift]# rhc-admin-chk
/usr/lib/ruby/site_ruby/1.8/mcollective/rpc/ddl.rb:196:in `validate_request': Attempted to call action get_all_gears for stickshift but it's not declared in the DDL (MCollective::DDLValidationError)
	from /usr/lib/ruby/site_ruby/1.8/mcollective/rpc/client.rb:218:in `method_missing'
	from /usr/lib/ruby/gems/1.8/gems/gearchanger-mcollective-plugin-0.0.8/lib/gearchanger-mcollective-plugin/gearchanger/mcollective_application_container_proxy.rb:1405:in `get_all_gears_impl'
	from /usr/lib/ruby/gems/1.8/gems/gearchanger-mcollective-plugin-0.0.8/lib/gearchanger-mcollective-plugin/gearchanger/mcollective_application_container_proxy.rb:874:in `rpc_exec'
	from /usr/lib/ruby/gems/1.8/gems/gearchanger-mcollective-plugin-0.0.8/lib/gearchanger-mcollective-plugin/gearchanger/mcollective_application_container_proxy.rb:1404:in `get_all_gears_impl'
	from /usr/lib/ruby/gems/1.8/gems/stickshift-controller-0.13.12/lib/stickshift-controller/lib/stickshift/application_container_proxy.rb:37:in `get_all_gears'
	from /usr/bin/rhc-admin-chk:45


Version-Release number of selected component (if applicable):
devenv_1884

How reproducible:
always

Steps to Reproduce:
1.login to instance
2.run rhc-admin-chk
3.
  
Actual results:
error message appears and rhc-admin-chk doesnot work

Expected results:
rhc-admin-chk should work fine

Additional info:
Comment 1 Xiaoli Tian 2012-07-10 23:34:47 EDT

*** This bug has been marked as a duplicate of bug 839121 ***

Note You need to log in before you can comment on or make changes to this bug.