This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 839132 - Incorrect error reported for a link target of the form [T:100]
Incorrect error reported for a link target of the form [T:100]
Status: CLOSED CURRENTRELEASE
Product: PressGang CCMS
Classification: Community
Component: CSProcessor (Show other bugs)
1.x
Unspecified Unspecified
low Severity medium
: ---
: ---
Assigned To: Lee Newson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-07-11 01:06 EDT by Joshua Wulf
Modified: 2014-10-19 19:01 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-06-06 21:29:57 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Test case that demonstrates the behaviour (10.94 KB, application/octet-stream)
2012-07-11 01:06 EDT, Joshua Wulf
no flags Details

  None (edit)
Description Joshua Wulf 2012-07-11 01:06:06 EDT
Created attachment 597455 [details]
Test case that demonstrates the behaviour

I figured out what I had done, but the error reporting wasn't clear.

[jwulf@radhe Messaging_Programming_Reference]$ csprocessor push
CSProcessor client version: 0.25.1
Loading configuration from /home/jwulf/.config/csprocessor.ini
Loading project configuration from csprocessor.cfg
Connecting to Skynet server: http://skynet.usersys.redhat.com:8080/TopicIndex/

Starting to parse...
Attempting to download all the latest topics...
Starting to validate...
ERROR: Line 79: Invalid Content Specification! Tag doesn't exist.
       -> The Producer - Consumer Model [8097]
ERROR: Line 80: Invalid Content Specification! Tag doesn't exist.
       -> Consumer-driven messaging [9990]
ERROR: Line 81: Invalid Content Specification! Tag doesn't exist.
       -> Message Producer (Sender) [8143]
ERROR: Line 82: Invalid Content Specification! Tag doesn't exist.
       -> Message [8120]
ERROR: Line 83: Invalid Content Specification! Tag doesn't exist.
       -> Routing Key [8068]
ERROR: Line 84: Invalid Content Specification! Tag doesn't exist.
       -> Message Properties [8070]
ERROR: Line 85: Invalid Content Specification! Tag doesn't exist.
       -> Connection [8107]
ERROR: Line 86: Invalid Content Specification! Tag doesn't exist.
       -> Session [8140]
ERROR: Line 87: Invalid Content Specification! Tag doesn't exist.
       -> Broker [8066]
ERROR: Line 88: Invalid Content Specification! Tag doesn't exist.
       -> Binding [8072]
ERROR: Line 89: Invalid Content Specification! Tag doesn't exist.
       -> Message Queue [8049] [R: T6]
ERROR: Line 90: Invalid Content Specification! Tag doesn't exist.
       -> Transaction [8076]
ERROR: Line 91: Invalid Content Specification! Tag doesn't exist.
       -> Message Consumer (Receiver) [8159]
ERROR: Line 92: Invalid Content Specification! Tag doesn't exist.
       -> Message Delivery Overview [8238]
ERROR: Line 93: Invalid Content Specification! Tag doesn't exist.
       -> Message Acquisition and Acceptance [8241]
ERROR: The Content Specification is not valid.



==============================
Generated Details:

Package: cspclient-0.25.1-1.noarch

OS: Fedora release 16 (Verne)

JAVA: java version "1.7.0"
Java(TM) SE Runtime Environment (build 1.7.0-b147)
Java HotSpot(TM) Client VM (build 21.0-b17, mixed mode, sharing)


CSProcessor client version: 0.25.1
Loading configuration from /home/jwulf/.config/csprocessor.ini
Loading project configuration from csprocessor.cfg
Connecting to Skynet server: http://skynet.usersys.redhat.com:8080/TopicIndex/

Content Specification ID: 8025
Content Specification Revision: 159044
Content Specification Title: Messaging Programming Reference

Starting to calculate the statistics...
Total Number of Topics: 232
Number of Topics with XML: 48
Percentage Complete: 20.69%
Comment 1 Lee Newson 2012-07-11 02:20:36 EDT
Actually it is the right error because that format is used for adding tags with the category defined. eg.

AMQP Model Overview [Technology: Application Server]

or:

AMQP Model Overview [Technology: (Application Server, JAX-RS)]

You could add a check to see if the Category matched one of the keywords but then it removes the possibility to use those keys as actual categories but I don't see that as an issue since in the instances that I can see that would be checked are only single letter keys.
Comment 2 Lee Newson 2012-07-11 21:42:07 EDT
I've got more to do on this but one thing I've changed is that the error will only appear on the line it occurred and not for each topic for variables declared at the Level scope.
Comment 3 Lee Newson 2012-11-23 00:13:09 EST
Since not all elements are single letter fields, I'm rejecting my statement at the end of comment 1 and marking this as done.
Comment 4 Lee Newson 2013-06-06 21:29:57 EDT
Closing and setting as current release as no QA was performed by the original reporter. If there is still an issue with this bug still than please re-open it.

Note You need to log in before you can comment on or make changes to this bug.