Bug 839147 - Brew does not remove docs formats from Navigation TOC when web_formats is specified.
Brew does not remove docs formats from Navigation TOC when web_formats is spe...
Status: CLOSED CURRENTRELEASE
Product: Publican
Classification: Community
Component: publican (Show other bugs)
2.8
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Jeff Fearn
Ruediger Landmann
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-07-11 01:54 EDT by Jared MORGAN
Modified: 2015-08-09 21:22 EDT (History)
2 users (show)

See Also:
Fixed In Version: 3.0.0
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-11-06 21:32:50 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Jared MORGAN 2012-07-11 01:54:45 EDT
Description of problem:

The EPP Reference Guide is not staging because of problems with FOP. I have enabled web_formats= "html,html-single,epub" in publican.cfg, but the PDF option on docs-stage is still present and is a "dead link".

Version-Release number of selected component (if applicable):

publican 2.8

How reproducible:

100%

Steps to Reproduce:

1. Find a small book that you can quickly stage to docs-stage. 
2. Edit the book's publican.cfg file, and specify web_formats as follows
   web_formats: "epub,html,html-single"
3. Brew the book, so it overwrites a previously staged book that had all formats enabled.
4. View the results.
  
Actual results:

The PDF format option still displays on docs-stage. When you click the link, docs-stage returns you to the default docs-stage root page, that lists all platforms.

Expected results:

The PDF option is removed from docs-stage against the newly brewed book.
Comment 1 Jeff Fearn 2012-11-06 21:16:45 EST
Hi Jared, this seems to be working for me in 3.0, can you confirm?
Comment 2 Jared MORGAN 2012-11-06 21:27:15 EST
(In reply to comment #1)
> Hi Jared, this seems to be working for me in 3.0, can you confirm?

Hi Jeff

This was directly related to FOP, Jeff. It turns out that FOP hated the complexity and size of this guide.

When I got a local build of Publican 3 and wkhtmltopdf working, the problem went away. 

Unless you intend to backport any fixes to 2.8, I think you can probably close off this ticket in light of P3 being released.

Cheers

Jared

Note You need to log in before you can comment on or make changes to this bug.