Bug 839159 - Error Message: "Input action does not match validation regex" appears when threaddump for applications
Error Message: "Input action does not match validation regex" appears when th...
Status: CLOSED CURRENTRELEASE
Product: OpenShift Origin
Classification: Red Hat
Component: Command Line Interface (Show other bugs)
2.x
Unspecified Unspecified
medium Severity medium
: ---
: ---
Assigned To: Mrunal Patel
libra bugs
: Regression, Triaged
: 839164 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-07-11 02:35 EDT by Gaoyun Pei
Modified: 2015-05-14 22:00 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-07-13 19:43:17 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Gaoyun Pei 2012-07-11 02:35:03 EDT
Description of problem:
When generating thread dump for an app(ruby-1.9), met with error messages:

bash-3.2$ rhc app threaddump -a app1 
Password: ******

Problem reported from server. Response code was 500.
Re-run with -d for more information.

RESULT:
Input action does not match validation regex ^(app-create|app-destroy|env-var-add|env-var-remove|broker-auth-key-add|broker-auth-key-remove|authorized-ssh-key-add|authorized-ssh-key-remove|app-state-show|cartridge-list|configure|deconfigure|update-namespace|tidy|deploy-httpd-proxy|remove-httpd-proxy|move|pre-move|post-move|info|post-install|post-remove|pre-install|reload|restart|start|status|stop|force-stop|add-alias|remove-alias|expose-port|conceal-port|show-port|system-messages)$


Version-Release number of selected component (if applicable):
devenv_1884
rhc-0.95.12

How reproducible:
always

Steps to Reproduce:
1.create an app 
#rhc app create -a app1 -t ruby-1.9
2.do threaddump
#rhc app threaddump -a app1
3.
  
Actual results:
Error Message appears. Threaddump couldn't be successful. 

Expected results:
user can get the threaddump log by the returned message directly. 

Additional info:
Comment 1 Xiaoli Tian 2012-07-11 07:36:21 EDT
*** Bug 839164 has been marked as a duplicate of this bug. ***
Comment 2 Xiaoli Tian 2012-07-11 07:37:49 EDT
thread dump itself can not be used, not related to cartridge
Comment 3 John (J5) Palmieri 2012-07-11 18:30:08 EDT
This looks like a server validation issue on the command.  Reassigning.
Comment 4 John (J5) Palmieri 2012-07-11 18:35:41 EDT
backtrace from the server

/usr/lib/ruby/site_ruby/1.8/mcollective/rpc/ddl.rb:229:in `validate_request'
/usr/lib/ruby/site_ruby/1.8/mcollective/rpc/ddl.rb:201:in `each'
/usr/lib/ruby/site_ruby/1.8/mcollective/rpc/ddl.rb:201:in `validate_request'
/usr/lib/ruby/site_ruby/1.8/mcollective/rpc/client.rb:275:in `custom_request'
/usr/lib/ruby/gems/1.8/gems/gearchanger-mcollective-plugin-0.0.8/lib/gearchanger-mcollective-plugin/gearchanger/mcollective_application_container_proxy.rb:987:in `execute_direct'
/usr/lib/ruby/gems/1.8/gems/gearchanger-mcollective-plugin-0.0.8/lib/gearchanger-mcollective-plugin/gearchanger/mcollective_application_container_proxy.rb:1128:in `run_cartridge_command_old'

Exit Code: 1
broker_c: ["namespace", "rhlogin", "ssh", "app_uuid", "debug", "alter", "cartridge", "cart_type", "action", "app_name", "api"]
api_c: ["placeholder"]
API version:    1.1.3
Comment 5 Mrunal Patel 2012-07-11 18:56:50 EDT
https://github.com/openshift/crankcase/pull/227
Comment 6 Adam Miller 2012-07-11 20:49:43 EDT
Merged.
Comment 7 Gaoyun Pei 2012-07-12 04:40:36 EDT
Fixed in devenv-stage_223

Note You need to log in before you can comment on or make changes to this bug.