Bug 839164 - Failed to threaddump jbossas/jbosseap/ruby applications
Failed to threaddump jbossas/jbosseap/ruby applications
Status: CLOSED DUPLICATE of bug 839159
Product: OpenShift Origin
Classification: Red Hat
Component: Command Line Interface (Show other bugs)
2.x
Unspecified Unspecified
unspecified Severity medium
: ---
: ---
Assigned To: Clayton Coleman
libra bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-07-11 02:38 EDT by Jianwei Hou
Modified: 2015-05-14 22:00 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-07-11 07:36:21 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jianwei Hou 2012-07-11 02:38:31 EDT
Description of problem:
run 'rhc app threaddump' or 'rhc-ctl-app -c threaddump -a appname' for a jbossas/jbosseap/ruby appliacation, error message was returned.

Version-Release number of selected component (if applicable):
on devenv_1884
CLI: rhc-0.95.12

How reproducible:
always

Steps to Reproduce:
1.create a jbossas/jbosseap/ruby application
2.run 'rhc app threaddump' command
  
Actual results:
[root@F17i386-openshift test]# rhc-ctl-app -c threaddump -a jbossas1 -d
Password: ******

Contacting https://ec2-107-21-160-128.compute-1.amazonaws.com
Problem reported from server. Response code was 500.

DEBUG:
Input action does not match validation regex ^(app-create|app-destroy|env-var-add|env-var-remove|broker-auth-key-add|broker-auth-key-remove|authorized-ssh-key-add|authorized-ssh-key-remove|app-state-show|cartridge-list|configure|deconfigure|update-namespace|tidy|deploy-httpd-proxy|remove-httpd-proxy|move|pre-move|post-move|info|post-install|post-remove|pre-install|reload|restart|start|status|stop|force-stop|add-alias|remove-alias|expose-port|conceal-port|show-port|system-messages)$/usr/lib/ruby/site_ruby/1.8/mcollective/rpc/ddl.rb:229:in `validate_request'
/usr/lib/ruby/site_ruby/1.8/mcollective/rpc/ddl.rb:201:in `each'
/usr/lib/ruby/site_ruby/1.8/mcollective/rpc/ddl.rb:201:in `validate_request'
/usr/lib/ruby/site_ruby/1.8/mcollective/rpc/client.rb:275:in `custom_request'
/usr/lib/ruby/gems/1.8/gems/gearchanger-mcollective-plugin-0.0.8/lib/gearchanger-mcollective-plugin/gearchanger/mcollective_application_container_proxy.rb:987:in `execute_direct'
/usr/lib/ruby/gems/1.8/gems/gearchanger-mcollective-plugin-0.0.8/lib/gearchanger-mcollective-plugin/gearchanger/mcollective_application_container_proxy.rb:1128:in `run_cartridge_command_old'

Exit Code: 1
broker_c: ["namespace", "rhlogin", "ssh", "app_uuid", "debug", "alter", "cartridge", "cart_type", "action", "app_name", "api"]
api_c: ["placeholder"]
API version:    1.1.3

RESULT:
Input action does not match validation regex ^(app-create|app-destroy|env-var-add|env-var-remove|broker-auth-key-add|broker-auth-key-remove|authorized-ssh-key-add|authorized-ssh-key-remove|app-state-show|cartridge-list|configure|deconfigure|update-namespace|tidy|deploy-httpd-proxy|remove-httpd-proxy|move|pre-move|post-move|info|post-install|post-remove|pre-install|reload|restart|start|status|stop|force-stop|add-alias|remove-alias|expose-port|conceal-port|show-port|system-messages)$


Expected results:
command should execute successful

Additional info:
Comment 1 Xiaoli Tian 2012-07-11 07:36:21 EDT

*** This bug has been marked as a duplicate of bug 839159 ***

Note You need to log in before you can comment on or make changes to this bug.