Bug 839177 - ovirt-engine-restapi : There is no option to create Posix compliant FS data center using Rest API
ovirt-engine-restapi : There is no option to create Posix compliant FS data c...
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine-restapi (Show other bugs)
3.1.0
Unspecified Unspecified
unspecified Severity medium
: ---
: 3.1.0
Assigned To: Michael Pasternak
Jakub Libosvar
storage
: TestBlocker
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-07-11 03:13 EDT by Oded Ramraz
Modified: 2016-02-10 11:32 EST (History)
12 users (show)

See Also:
Fixed In Version: SI11
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-12-04 15:02:08 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Storage
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Oded Ramraz 2012-07-11 03:13:49 EDT
Description of problem:

From GUI I have option to create Posix compliant FS. I didn't found a way to do it using Rest API . 
Currently Rest API expose storage types in capabilities ( see Additional Information ) which used to be enough because data center types and storage types were equal. 
Maybe we should add data center types to capabilities as well .



Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:

<storage_types>
<storage_type>iscsi</storage_type
><storage_type>fcp</storage_type>
<storage_type>nfs</storage_type>
<storage_type>localfs</storage_type>
</storage_types>
Comment 1 Ori Liel 2012-07-11 03:48:27 EDT
Creation is possible, the problem is only that 'posix-fs' not exposed in capabilities. 

Patch sent: http://gerrit.ovirt.org/#/c/6132/
Comment 2 Oded Ramraz 2012-07-11 03:53:49 EDT
The bug is about data centers while the patch is regarding storage domains types.
Are the values are equal ? Should we add data center types to capabilities as well ?
Comment 4 Ayal Baron 2012-07-11 05:58:18 EDT
(In reply to comment #2)
> The bug is about data centers while the patch is regarding storage domains
> types.
> Are the values are equal ? Should we add data center types to capabilities
> as well ?

no.
The patch addresses the problem properly.
Once we remove the limitation of having a single storage type in a DC then there will be no data center type anyway and until then storage domain types is the only type for DCs.
Comment 5 Haim 2012-07-29 11:26:03 EDT
verified on SI12.

<storage_types>
<storage_type>iscsi</storage_type>
<storage_type>fcp</storage_type>
<storage_type>nfs</storage_type>
<storage_type>localfs</storage_type>
<storage_type>posixfs</storage_type>
</storage_types>

Note You need to log in before you can comment on or make changes to this bug.