Bug 839187 - Documentation talkes about EAGER locking which is deprecated since infinspan 5.1 and JDG 6
Documentation talkes about EAGER locking which is deprecated since infinspan ...
Status: CLOSED CURRENTRELEASE
Product: JBoss Data Grid 6
Classification: JBoss
Component: Documentation (Show other bugs)
6.0.0
Unspecified Unspecified
unspecified Severity medium
: ---
: 6.0.1
Assigned To: Misha H. Ali
ecs-bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-07-11 03:38 EDT by Thomas Qvarnström
Modified: 2012-09-19 23:47 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Instance Name: Not Defined Build: CSProcessor Builder Version 1.4 Build Filter: null Build Name: Build Date: 15-06-2012 10:17:05
Last Closed: 2012-09-19 23:47:59 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Thomas Qvarnström 2012-07-11 03:38:35 EDT
Description of problem:
The JDG Administration guide in section 7.2 talks about EAGER locking, according to Mircea Markus EAGER locking concept/term is depricated since infinispan 5.1 (JDG 6). See http://docs.redhat.com/docs/en-US/JBoss_Data_Grid/6/html/Administration_and_Configuration_Guide/sect-Distibuted_Locking.html#Distributed_Eager_Locking

Version-Release number of selected component (if applicable):
JDB 6.0.0

How reproducible:

Steps to Reproduce:
1. Open a browser
2. Go to http://docs.redhat.com/docs/en-US/JBoss_Data_Grid/6/html/Administration_and_Configuration_Guide/sect-Distibuted_Locking.html#Distributed_Eager_Locking
3. Read about EAGER locking
  
Actual results:

Expected results:
The documentation shouldn't cover depricated terms since this confuses the user. 

Additional info:
Comment 1 Misha H. Ali 2012-07-11 22:00:18 EDT
Section on distributed eager locking is now removed. Will set this to ON_QA when the results appear on the stage.
Comment 6 Tristan Tarrant 2012-08-01 03:52:41 EDT
Misha, the START attribute has nothing to do with locking policy, but it tells the container whether the service should be started as soon as possible (EAGER) or wait for a request (LAZY).

Note You need to log in before you can comment on or make changes to this bug.