Bug 839253 - [RHEVM] [backend] [Setup Host Networks] cannot add network to bond which was previously created with no network attached
[RHEVM] [backend] [Setup Host Networks] cannot add network to bond which was ...
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: vdsm (Show other bugs)
6.4
x86_64 Linux
high Severity high
: rc
: 6.4
Assigned To: Igor Lvovsky
Haim
network
:
Depends On:
Blocks: 761411
  Show dependency treegraph
 
Reported: 2012-07-11 07:43 EDT by Martin Pavlik
Modified: 2015-04-06 23:09 EDT (History)
10 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-07-13 04:08:54 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
vdsm.log + engine.log (9.08 KB, application/x-gzip)
2012-07-11 07:43 EDT, Martin Pavlik
no flags Details

  None (edit)
Description Martin Pavlik 2012-07-11 07:43:03 EDT
Created attachment 597540 [details]
vdsm.log + engine.log

Description of problem:
It is not possible to add logical network to bond which was previously created with no network attached.

Version-Release number of selected component (if applicable):
oVirt Engine Version: 3.1.0-5.el6ev 
vdsm-4.9.6-17.0.el6.x86_64

How reproducible:
100%

Steps to Reproduce:
you need: host with 3 nics in order to reproduce the issue
          1 logical network created

1. Hosts -> your host -> Setup Host Networks -> create bond with no network attached -> click OK
2. Hosts -> your host -> Setup Host Networks -> attach logical network to bond created in step 1
  
Actual results:
error appears

Expected results:
network should be added to the bond

Additional info:

MainProcess|Thread-4265::ERROR::2012-07-11 13:28:50,237::configNetwork::1129::setupNetworks::(setupNetworks) (21, 'vlan/bonding definition requires nics. got: ()')
Traceback (most recent call last):
  File "/usr/share/vdsm/configNetwork.py", line 1100, in setupNetworks
    addNetwork(network, configWriter=configWriter, **d)
  File "/usr/share/vdsm/configNetwork.py", line 586, in addNetwork
    bridged=bridged)
  File "/usr/share/vdsm/configNetwork.py", line 497, in _addNetworkValidation
    raise ConfigNetworkError(ne.ERR_BAD_PARAMS, 'vlan/bonding definition requires nics. got: %r'%(nics,))
ConfigNetworkError: (21, 'vlan/bonding definition requires nics. got: ()')
MainProcess|Thread-4265::ERROR::2012-07-11 13:28:50,237::supervdsmServer::61::SuperVdsm.ServerCallback::(wrapper) Error in setupNetworks
Traceback (most recent call last):
  File "/usr/share/vdsm/supervdsmServer.py", line 59, in wrapper
    return func(*args, **kwargs)
  File "/usr/share/vdsm/supervdsmServer.py", line 107, in setupNetworks
    return configNetwork.setupNetworks(networks, bondings, **options)
  File "/usr/share/vdsm/configNetwork.py", line 1100, in setupNetworks
    addNetwork(network, configWriter=configWriter, **d)
  File "/usr/share/vdsm/configNetwork.py", line 586, in addNetwork
    bridged=bridged)
  File "/usr/share/vdsm/configNetwork.py", line 497, in _addNetworkValidation
    raise ConfigNetworkError(ne.ERR_BAD_PARAMS, 'vlan/bonding definition requires nics. got: %r'%(nics,))
ConfigNetworkError: (21, 'vlan/bonding definition requires nics. got: ()')
Thread-4265::ERROR::2012-07-11 13:28:50,238::API::1116::vds::(setupNetworks) vlan/bonding definition requires nics. got: ()
Traceback (most recent call last):
  File "/usr/share/vdsm/API.py", line 1114, in setupNetworks
    supervdsm.getProxy().setupNetworks(networks, bondings, options)
  File "/usr/share/vdsm/supervdsm.py", line 59, in __call__
    return callMethod()
  File "/usr/share/vdsm/supervdsm.py", line 57, in <lambda>
    callMethod = lambda : getattr(self._supervdsmProxy._svdsm, self._funcName)(*args, **kwargs)
  File "<string>", line 2, in setupNetworks
  File "/usr/lib64/python2.6/multiprocessing/managers.py", line 740, in _callmethod
    raise convert_to_error(kind, result)
Comment 1 lpeer 2012-07-12 06:37:04 EDT
changing components as this seems like a VDSM bug.
Note - I was not able to reproduce the above on my local settings.
Comment 2 Martin Pavlik 2012-07-13 04:08:54 EDT
Seems to be working in SI10 with vdsm-4.9.6-21.0.el6_3.x86_64. Closing

Note You need to log in before you can comment on or make changes to this bug.