Bug 839268 - Samba4 needs rebuild due to new version of ldb
Samba4 needs rebuild due to new version of ldb
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: samba4 (Show other bugs)
17
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Andreas Schneider
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-07-11 08:24 EDT by Alexey Torkhov
Modified: 2013-02-07 11:55 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-02-07 11:55:27 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Alexey Torkhov 2012-07-11 08:24:21 EDT
Description of problem:
When trying to update samba3 to samba4 domain, I've got the followng error:

ldb: module version mismatch in ../source4/dsdb/samdb/ldb_modules/acl.c : ldb_version=1.1.6 module_version=1.1.4
ldb: failed to initialise module /usr/lib64/samba/ldb/acl.so : Unavailable

Command I was running:
samba-tool domain samba3upgrade --dbdir=. --use-xattrs=yes --realm=example.com smb.conf
(with samba3 tdb and smb.conf in current directory). Probably it'll fail on provisioning from scratch or other actions.

I guess that libldb was updated from 1.1.4 to 1.1.6, but samba4 wasn't rebuilt with new libldb. I've tried to rebuild and it fixes this problem.


Version-Release number of selected component (if applicable):
samba4-4.0.0-57alpha18.fc17.x86_64
libldb-1.1.6-1.fc17.x86_64

Note You need to log in before you can comment on or make changes to this bug.