Bug 839285 - don't remove new problems from abrt-upload directory
don't remove new problems from abrt-upload directory
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: abrt (Show other bugs)
6.4
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Jakub Filak
Lukas Zachar
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-07-11 09:06 EDT by Jiri Moskovcak
Modified: 2016-11-30 19:42 EST (History)
6 users (show)

See Also:
Fixed In Version: abrt-2.0.8-7.el6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-02-21 02:54:01 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jiri Moskovcak 2012-07-11 09:06:58 EDT
Description of problem:
/var/spool/abrt-upload is not writeable by default (please see #836988) so in default configuration ABRT shouldn't try to move the new problem dir from it, because it would cause a selinux denial. The solution is to add a configuration option like DeleteUploaded = no, with comment that if user wants to automatically clean the upload directory he has to tweak the selinux policy.
Comment 2 Jakub Filak 2012-07-16 07:24:03 EDT
commit c43d2e7b890e48fd30e248f2d578f4bde81cc140
Author: Jakub Filak <jfilak@redhat.com>
Date:   Thu Jul 12 14:34:33 2012 +0200

    rhbz#839285 : do not delete an uploaded archive by default
    
    * DeleteUploaded config option was added to abrt.conf
    * the default value of this new option is 'no'
    
    * the option was introduced because /var/spool/abrt-upload is not
      writable by default
    * for more details see rhbz#836988
    
    Signed-off-by: Jakub Filak <jfilak@redhat.com>
Comment 10 errata-xmlrpc 2013-02-21 02:54:01 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-0290.html

Note You need to log in before you can comment on or make changes to this bug.