Bug 839291 - [ORIGIN][RHEL6] jenkins build failed when builder slave app is deployed on another node.
[ORIGIN][RHEL6] jenkins build failed when builder slave app is deployed on an...
Status: CLOSED CURRENTRELEASE
Product: OpenShift Origin
Classification: Red Hat
Component: Containers (Show other bugs)
2.x
Unspecified Unspecified
medium Severity medium
: ---
: ---
Assigned To: mfisher
libra bugs
: FutureFeature, Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-07-11 09:24 EDT by Johnny Liu
Modified: 2015-05-14 18:56 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-07-15 06:27:32 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Johnny Liu 2012-07-11 09:24:48 EDT
Description of problem:
"Host key verification failed." cause jenkins build failed when app and builder app are running on different node

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Following http://libraonprem.etherpad.corp.redhat.com/rhel6-origin-setup? to setup multi node on RHEL6
2. Create app with jenkins embed
3. Do git commit to tigger jenkins build.
  
Actual results:
When app and builder app are running on different node, jenkins build failed.

Jenkins job's console output:
Started by user Jenkins System Builder
Building remotely on jbtestbldr in workspace jbtestbldr/ci/jenkins/workspace/jbtest-build
Checkout:jbtest-build / jbtestbldr/ci/jenkins/workspace/jbtest-build - hudson.remoting.Channel@2c45f9ae:jbtestbldr
Using strategy: Default
Last Built Revision: Revision ade86b8cd290c40a17ac8d67754a8a0e93d65217 (origin/HEAD, origin/master)
Checkout:jbtest-build / jbtestbldr/ci/jenkins/workspace/jbtest-build - hudson.remoting.LocalChannel@595660c3
Cloning the remote Git repository
Cloning repository origin
ERROR: Error cloning remote repo 'origin' : Could not clone ssh://2f093249a84741499d99a06794b87098@jbtest-jialiu.example.com/~/git/jbtest.git/
ERROR: Cause: Error performing command: git clone --progress -o origin ssh://2f093249a84741499d99a06794b87098@jbtest-jialiu.example.com/~/git/jbtest.git/ /var/lib/stickshift/1615df2675ec4672b813e48540378253/jbtestbldr/ci/jenkins/workspace/jbtest-build
Command "git clone --progress -o origin ssh://2f093249a84741499d99a06794b87098@jbtest-jialiu.example.com/~/git/jbtest.git/ /var/lib/stickshift/1615df2675ec4672b813e48540378253/jbtestbldr/ci/jenkins/workspace/jbtest-build" returned status code 128: Initialized empty Git repository in /var/lib/stickshift/1615df2675ec4672b813e48540378253/jbossas-7/ci/jenkins/workspace/jbtest-build/.git/
Host key verification failed.
fatal: The remote end hung up unexpectedly

Trying next repository
ERROR: Could not clone repository
FATAL: Could not clone
hudson.plugins.git.GitException: Could not clone
	at hudson.plugins.git.GitSCM$2.invoke(GitSCM.java:1042)
	at hudson.plugins.git.GitSCM$2.invoke(GitSCM.java:968)
	at hudson.FilePath$FileCallableWrapper.call(FilePath.java:2154)
	at hudson.remoting.UserRequest.perform(UserRequest.java:118)
	at hudson.remoting.UserRequest.perform(UserRequest.java:48)
	at hudson.remoting.Request$2.run(Request.java:287)
	at hudson.remoting.InterceptingExecutorService$1.call(InterceptingExecutorService.java:72)
	at java.util.concurrent.FutureTask$Sync.innerRun(FutureTask.java:334)
	at java.util.concurrent.FutureTask.run(FutureTask.java:166)
	at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1110)
	at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:603)
	at java.lang.Thread.run(Thread.java:679)


Expected results:
Build should succeed.

Additional info:
Comment 1 Mike McGrath 2013-01-02 14:59:25 EST
Assigning to Krishna at his request
Comment 2 Mike McGrath 2013-02-13 14:19:01 EST
This might be because of not having AcceptEnv GIT_SSH set in the sshd_config
Comment 3 Krishna Raman 2013-02-14 02:25:50 EST
Fixed in latest Puppet setup script
Comment 5 Meng Bo 2014-06-23 03:58:08 EDT
Issue has been fixed on Origin 3.0.1.

1. Setup multi-node env on RHEL by following the steps in http://openshift.github.io/documentation/oo_deployment_guide_puppet.html via puppet.
2. Create app with jenkins client added.
3. Do jenkins build.

Counting objects: 3, done.
Delta compression using up to 2 threads.
Compressing objects: 100% (2/2), done.
Writing objects: 100% (2/2), 317 bytes, done.
Total 2 (delta 0), reused 0 (delta 0)
remote: Executing Jenkins build.
remote: 
remote: You can track your build at https://jenkins-dom1.example.com/job/perl1-build
remote: 
remote: Waiting for build to schedule.........................Done
remote: Waiting for job to complete.....................Done
remote: SUCCESS
remote: New build has been deployed.
remote: -------------------------
remote: Git Post-Receive Result: success
remote: Deployment completed with status: success
To ssh://53a7dcd36892df4c5c0000f5@perl1-dom1.example.com/~/git/perl1.git/
   982077d..2f0e404  master -> master


App and slave placed on the different nodes.

# ping perl1-dom1.example.com
PING broker.example.com (172.16.121.23) 56(84) bytes of data.
64 bytes from bmeng-rhel-broker-oso.novalocal (172.16.121.23): icmp_seq=1 ttl=64 time=0.023 ms

# ping perl1bldr-dom1.example.com
PING node.example.com (172.16.121.27) 56(84) bytes of data.
64 bytes from 172.16.121.27: icmp_seq=1 ttl=64 time=0.458 ms

Note You need to log in before you can comment on or make changes to this bug.