Bug 839299 - Execute VM payload
Execute VM payload
Status: CLOSED DUPLICATE of bug 619761
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: RFEs (Show other bugs)
3.0.7
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Andrew Cathrow
yeylon@redhat.com
virt
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-07-11 09:46 EDT by Geert Jansen
Modified: 2016-04-18 02:44 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-12-01 03:37:25 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Geert Jansen 2012-07-11 09:46:49 EDT
We should add a feature to the guest agent to execute a file that is injected into a guest via the VM payload feature.

Two partners need this feature for:

 * network reconfiguration for disaster recovery
 * guest customization after cloning

This also requires RESTapi, engine, and vdsm changes.
Comment 5 Itamar Heim 2013-12-01 03:37:25 EST
payload can be injected per cloud-init which supports file attachment and script launch via cloud-init mechanism

*** This bug has been marked as a duplicate of bug 619761 ***

Note You need to log in before you can comment on or make changes to this bug.