Bug 839314 - Incorrect xml for libvirt command line parameters with native USB
Incorrect xml for libvirt command line parameters with native USB
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine (Show other bugs)
unspecified
Unspecified Unspecified
urgent Severity unspecified
: ---
: ---
Assigned To: Oved Ourfali
Tomas Dosek
virt
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-07-11 10:26 EDT by Tomas Jamrisko
Modified: 2015-09-22 09 EDT (History)
12 users (show)

See Also:
Fixed In Version: si12
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-12-04 15:06:07 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Archive with requested logs (15.77 MB, application/x-tar)
2012-07-12 04:01 EDT, Tomas Jamrisko
no flags Details

  None (edit)
Description Tomas Jamrisko 2012-07-11 10:26:52 EDT
Description of problem:
When trying to start a windows guest on rhev31 with Native USB, the machine won't start because of:  

qemu-kvm: -device piix3-usb-uhci,id=usb,bus=pci.0,addr=0x1.0x2: Duplicate ID 'usb' for device

Multiple definitions of usb: 
 -device ich9-usb-ehci1,id=usb,bus=pci.0,addr=0x5.0x7 -device piix3-usb-uhci,id=usb,bus=pci.0,addr=0x1.0x2 -device ich9-usb-uhci1,masterbus=usb.0,firstport=0,bus=pci.0,multifunction=on,addr=0x5


Version-Release number of selected component (if applicable):
rhevm-3.1.0-5.el6ev.noarch
vdsm-4.9.6-17.0.el6.x86_64
libvirt-0.9.10-21.el6.x86_64

How reproducible:
Always

Steps to Reproduce:
1. Create a windows 7 64bit guest virtual machine
2. Set usb to Native
3. Start
  
Actual results:
Fails after a few seconds

Expected results:
The virtual machine powers up

Additional info: 
According to hansg this shouldn't be there:
 <controller type="usb"> <address  domain="0x0000"  function="0x2"  slot="0x01"  type="pci" bus="0x00"/> </controller>
Comment 1 Andrew Cathrow 2012-07-11 15:41:56 EDT
vdsm logs please.
Comment 2 Tomas Jamrisko 2012-07-12 04:01:25 EDT
Created attachment 597729 [details]
Archive with requested logs

Attaching the requested logs
Comment 3 Oved Ourfali 2012-07-23 07:28:59 EDT
The way I reproduced it:
1. Create a windows 7 64bit guest virtual machine (by default USB will be disabled).
2. Run the VM
3. Stop the VM
2. Set usb to Native
3. Start the VM

Step "2" causes the creation of a default USB controller.
Step "3" causes the creation of proper native-USB controllers.

The fix should be to remove the USB controller created in "2" from the vm_devices table in the database.
Comment 4 Oved Ourfali 2012-07-23 09:30:28 EDT
posted a patch:
http://gerrit.ovirt.org/#/c/6549/

It is already acked. Waiting for qa_ack to merge.
Comment 5 Oved Ourfali 2012-07-23 09:54:29 EDT
Commit: 8bd1dfffe115d92e2ca91d17e02bd1dd86371aa4

http://gerrit.ovirt.org/gitweb?p=ovirt-engine.git;a=commit;h=8bd1dfffe115d92e2ca91d17e02bd1dd86371aa4
Comment 6 Tomas Dosek 2012-07-31 06:10:20 EDT
Verified - si12 - above described scenarios from bug's description and comment #3 no longer reproduce.

Note You need to log in before you can comment on or make changes to this bug.