Bug 839370 - Clash with libdb
Clash with libdb
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: db4 (Show other bugs)
17
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Jan Staněk
Dan Mashal
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-07-11 14:24 EDT by Susi Lehtola
Modified: 2013-04-05 06:27 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-04-05 06:27:07 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Susi Lehtola 2012-07-11 14:24:02 EDT
I ran into

Transaction Check Error:
  file /usr/lib/debug/usr/lib64/libdb.so.debug from install of libdb-debuginfo-5.2.36-5.fc17.x86_64 conflicts with file from package db4-debuginfo-4.8.30-10.fc17.x86_64
  file /usr/lib/debug/usr/lib64/libdb_cxx.so.debug from install of libdb-debuginfo-5.2.36-5.fc17.x86_64 conflicts with file from package db4-debuginfo-4.8.30-10.fc17.x86_64
  file /usr/lib/debug/usr/lib64/libdb_java.so.debug from install of libdb-debuginfo-5.2.36-5.fc17.x86_64 conflicts with file from package db4-debuginfo-4.8.30-10.fc17.x86_64

when trying to install some debuginfo packages. Could the db4 libraries be e.g. suffixed, so that libdb.so -> libdb4.so?
Comment 1 Dan Mashal 2012-10-02 02:37:30 EDT
amitkasha brought this up in #fedora-qa. 

Per our conversation on IRC this is not a bug.

debuginfo packages are not supposed to be installed with yum.

http://fedoraproject.org/wiki/Packaging:Debuginfo
http://linux.die.net/man/1/debuginfo-install

If you are packaging use rpmlint on the main package or the debuginfo package or see the links above.

For amitkasha the following link is relevant:

http://httpd.apache.org/dev/debugging.html
Comment 2 Susi Lehtola 2012-10-02 02:45:47 EDT
(In reply to comment #1)
> amitkasha brought this up in #fedora-qa. 
> 
> Per our conversation on IRC this is not a bug.
> 
> debuginfo packages are not supposed to be installed with yum.

Pray tell - how are you supposed to install them?

To reproduce this bug:

1. # debuginfo-install db4
2. # debuginfo-install libdb

Expected result:

libdb installs correctly.

Actual result:

File clash as above.
Comment 3 Dan Mashal 2012-10-02 02:48:13 EDT
Thanks for your reply.

Could you please give some more info as to exactly what you are trying to do? amitksaha is trying to debug python on apache. 

The reason I ask is that it seems this is causing multiple issues for different uses.
Comment 4 Susi Lehtola 2012-10-02 02:54:16 EDT
Well I don't remember anymore what I was trying to do, since it's almost three months since I reported this. The real issue is what I reported..
Comment 5 Susi Lehtola 2012-10-02 02:56:13 EDT
Well, the debuginfo clash is actually resulting from the file clash in db4-devel and libdb-devel.

Transaction Check Error:
  file /usr/include/db.h from install of libdb-devel-5.2.36-5.fc17.x86_64 conflicts with file from package db4-devel-4.8.30-10.fc17.x86_64
  file /usr/include/db_185.h from install of libdb-devel-5.2.36-5.fc17.x86_64 conflicts with file from package db4-devel-4.8.30-10.fc17.x86_64
  file /usr/include/db_cxx.h from install of libdb-devel-5.2.36-5.fc17.x86_64 conflicts with file from package db4-devel-4.8.30-10.fc17.x86_64
  file /usr/lib64/libdb.so from install of libdb-devel-5.2.36-5.fc17.x86_64 conflicts with file from package db4-devel-4.8.30-10.fc17.x86_64


.. so these packages should have explicit Conflicts set in place.
Comment 6 Dan Mashal 2012-10-02 02:56:57 EDT
Fair enough. Thanks.
Comment 7 Amit Saha 2012-10-02 22:52:38 EDT
# yum remove db4-debuginfo-4.8.30-10.fc17.x86_64 

allowed me to work around the bug, although I reached there using a different trajectory.
Comment 8 Adam Williamson 2012-10-03 00:22:38 EDT
Unless I'm missing something, all that can be done here is an explicit Conflicts: tag in the packages, which would be polite but isn't really a major deal.

Whenever we have multiple versions of the same library packaged in the distro, their -devel and -debuginfo packages will inevitably conflict, this is just how library versioning works. It's only avoidable with an awful lot of mess (putting each package's headers and unversioned .so file in differently-named subdirectories) which is usually not worth the effort and divergence from upstream because there's no case where you actually need to have both versions of the devel or debuginfo packages installed at once. The debuginfo case is slightly annoying, but it's still not worth the trouble of subdirectorying stuff.
Comment 9 Susi Lehtola 2012-10-03 02:45:04 EDT
(In reply to comment #8)
> Unless I'm missing something, all that can be done here is an explicit
> Conflicts: tag in the packages, which would be polite but isn't really a
> major deal.

.. unless you have a look at the Fedora Guidelines

https://fedoraproject.org/wiki/Packaging:Conflicts#Implicit_Conflicts

"Keep in mind that implicit conflicts are NEVER acceptable. If your package conflicts with another package, then you must either resolve the conflict, or mark it with Conflicts:."
Comment 10 Fedora Admin XMLRPC Client 2013-03-26 11:00:00 EDT
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.
Comment 11 Jan Staněk 2013-04-05 06:27:07 EDT
Fixed in F18, both versions -devel and -debuginfo packages installed without problem.

Note You need to log in before you can comment on or make changes to this bug.