Bug 839460 - RFE: xrefstyle on injected links
RFE: xrefstyle on injected links
Status: CLOSED CURRENTRELEASE
Product: PressGang CCMS
Classification: Community
Component: CSProcessor (Show other bugs)
1.x
Unspecified Unspecified
low Severity low
: ---
: ---
Assigned To: Lee Newson
:
Depends On:
Blocks: 842673
  Show dependency treegraph
 
Reported: 2012-07-11 22:32 EDT by Joshua Wulf
Modified: 2014-10-19 19:01 EDT (History)
3 users (show)

See Also:
Fixed In Version: 0.25.2
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-06-06 21:30:04 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Joshua Wulf 2012-07-11 22:32:55 EDT
Can you please have the csprocessor write the xrefs for injected lists like this:

<xref xrefstyle="see-also" linkend="..." />
<xref xrefstyle="prereq" linkend="..." />
<xref xrefstyle="list" linkend="..." />

We can use the xrefstyle attribute of <xref> elements to remove the "Section 1.3.5" in front of links in the "See Also:" lists in html builds.

In cases where no matching style exists in a brand the default behaviour of rendering the Section / Chapter metadata in front of the link target title will continue, but for those who want to, they will be able to modify the output.

There is a workaround at the moment:

Run this on the assembled publican XML:
perl -p -i -e 's/xref linkend=/xref xrefstyle="select:title" linkend=/g' en-US/topics/*.xml

This suppresses all the "Section / Chapter" preamble on xref links. Doing it using named xrefstyles allows us to control the behaviour via the brand, and to use different styles for links that have different purposes ("See Also" vs "Prerequisite", for example).

What would give us the most flexibility is if we have an --override / publican.cfg ability to tell csprocessor to use semantic xrefstyles (which should be the default) or just output the vanilla xrefs that it does atm.


==============================
Generated Details:

Package: cspclient-0.25.1-1.noarch

OS: Fedora release 16 (Verne)

JAVA: java version "1.7.0"
Java(TM) SE Runtime Environment (build 1.7.0-b147)
Java HotSpot(TM) Client VM (build 21.0-b17, mixed mode, sharing)


CSProcessor client version: 0.25.1
Comment 1 Lee Newson 2012-07-11 22:51:56 EDT
I've added those "xrefstyle" attributes the the xref links for 0.25.2.

I'll take a look at command line option at a later stage since it's not very high priority atm.
Comment 2 Lee Newson 2012-07-11 22:57:36 EDT
Oops forgot to mention that the only change i made to the xrefstyle names is to call "link-list" instead of "link"
Comment 3 Lee Newson 2012-07-24 18:09:24 EDT
Moving this back to MODIFIED as it's not complete.
Comment 4 Joshua Wulf 2012-07-24 20:39:02 EDT
Maybe the thing to do with issues like this is to split them into separate sub-features? That way when something gets released, the bug that tracks it changes state.
Comment 5 Lee Newson 2012-07-24 20:44:05 EDT
Just to add to my last comment about what's not complete. I still need to look at the command line option to turn off the xrefstyle injections. However that is a low priority.

Also note that it won't be a publican.cfg option as those variables are for publican. If you want it added to there so that publican removes all the xrefstyles then you'll need to create an RFE in the publican bug queue.
Comment 6 Lee Newson 2012-07-26 07:15:14 EDT
As per your suggestion I'm splitting this into two bugs to mark this one as ON_QA. 

New bug for the switch: Bug #843451
Comment 7 Lee Newson 2013-06-06 21:30:04 EDT
Closing and setting as current release as no QA was performed by the original reporter. If there is still an issue with this bug still than please re-open it.

Note You need to log in before you can comment on or make changes to this bug.