This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 839550 - Netperf with UDP_STREAM testing failed on windows guest over rhel5.9 kvm
Netperf with UDP_STREAM testing failed on windows guest over rhel5.9 kvm
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: kvm (Show other bugs)
5.9
Unspecified Unspecified
unspecified Severity medium
: rc
: ---
Assigned To: Virtualization Maintenance
Virtualization Bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-07-12 05:30 EDT by dawu
Modified: 2013-04-17 11:13 EDT (History)
12 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-04-17 11:13:59 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
netperf_UDP_fail.PNG (20.03 KB, image/png)
2012-07-12 05:38 EDT, dawu
no flags Details

  None (edit)
Description dawu 2012-07-12 05:30:11 EDT
Description of problem:
Netperf with UDP_STREAM testing failed on windows guest on rhel5.9 host.

Version-Release number of selected component (if applicable):
kernel-2.6.18-324.el5
kvm-83-256.el5
virtio-win-1.5.3
virtio-win-1.0.3-52454

How reproducible:
90%

Steps to Reproduce:
1.Start windows guest on rhel5.9 host:
  
  /usr/libexec/qemu-kvm -m 4G -smp 4 -cpu qemu64,+sse2 -drive file=win2k8-R2.qcow2,format=qcow2,media=disk,if=ide,boot=on,cache=none,werror=stop -net nic,model=virtio,vlan=0,macaddr=00:1a:4a:42:10:02 -net tap,vlan=0,script=/etc/qemu-ifup0 -uuid 3659f92c-5dc2-408a-9e85-fad7a1c27959  -monitor unix:/tmp/win2k8-R2,server,nowait -vnc :1 -boot dc -usbdevice tablet -no-hpet -rtc-td-hack -no-kvm-pit-reinjection -startdate now -drive file=virtio-win-1.5.3.iso,if=ide,media=cdrom -monitor stdio -name win2k8-R2

2. Install virtio-nic driver virtio-win-1.5.3

3. Start netserver : 10.66.9.242 (rhel6 host)
   
4. Do netperf test with UDP_STREAM on windows guest as client:
   $ netperf.exe -H 10.66.9.242 -t UDP_STREAM
  
Actual results:
  Test failed with following error:
$ netperf.exe -H 10.66.9.242 -t UDP_STREAM
UDP UNIDIRECTIONAL SEND TEST from 0.0.0.0 (0.0.0.0) port 0 AF_INET to 10.66.9.242 (10.66.9.242) port 0 AF_INET
netperf: receive_response: no response received. errno 4 counter -1

Expected results:
Test with UDP_STREAM should success without any error.

Additional info:
1.This issue happened with both rhel6 and rhel5 driver.
2.On host6, this issue does not reproduce.
3.Please refer to the attached "netperf_UDP_fail.PNG" for details.
Comment 1 dawu 2012-07-12 05:38:38 EDT
Created attachment 597748 [details]
netperf_UDP_fail.PNG
Comment 2 juzhang 2012-07-12 05:59:45 EDT
can hit the same issue with linux guest?
Comment 3 RHEL Product and Program Management 2012-07-12 06:17:33 EDT
This request was evaluated by Red Hat Product Management for inclusion
in a Red Hat Enterprise Linux release.  Product Management has
requested further review of this request by Red Hat Engineering, for
potential inclusion in a Red Hat Enterprise Linux release for currently
deployed products.  This request is not yet committed for inclusion in
a release.
Comment 4 dawu 2012-07-12 21:48:36 EDT
(In reply to comment #2)
> can hit the same issue with linux guest?

Hi juzhang,
According to wenli, there is no such issue with linux guest over rhel5.9 kvm, I will try this with kvm-83-256.el5 again, and update the result.

thanks
Best Regards,
Dawn
Comment 5 dawu 2012-07-12 22:06:01 EDT
(In reply to comment #2)
> can hit the same issue with linux guest?

I have tried again with rhe6.4 guest under the same environment, don't hit this issue.

kernel-2.6.18-324.el5
kvm-83-256.el5

Best Regards,
Dawn
Comment 6 Mike Cao 2012-07-13 05:51:00 EDT
(In reply to comment #5)
> (In reply to comment #2)
> > can hit the same issue with linux guest?
> 
> I have tried again with rhe6.4 guest under the same environment, don't hit
> this issue.
> 
> kernel-2.6.18-324.el5
> kvm-83-256.el5
> 
> Best Regards,
> Dawn

1. Pls try to use e1000 to see whether hit this issue for the same windows guest
2. Pls try to use netkvm driver in virtio-win-1.0.3-1.52454.el5 to see whether can hit this issue .
Comment 7 RHEL Product and Program Management 2012-07-13 05:58:42 EDT
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated in the
current release, Red Hat is unfortunately unable to address this
request at this time. Red Hat invites you to ask your support
representative to propose this request, if appropriate and relevant,
in the next release of Red Hat Enterprise Linux.
Comment 8 dawu 2012-07-13 06:03:22 EDT
(In reply to comment #6)
> (In reply to comment #5)
> > (In reply to comment #2)
> > > can hit the same issue with linux guest?
> > 
> > I have tried again with rhe6.4 guest under the same environment, don't hit
> > this issue.
> > 
> > kernel-2.6.18-324.el5
> > kvm-83-256.el5
> > 
> > Best Regards,
> > Dawn
> 
> 1. Pls try to use e1000 to see whether hit this issue for the same windows
> guest
use e1000 also hit this issue for windows guest.
> 2. Pls try to use netkvm driver in virtio-win-1.0.3-1.52454.el5 to see
> whether can hit this issue .

I have tried before and mentioned in bug description,this issue also happened on windows guest with netkvm driver in virtio-win-1.0.3-1.52454.el5

Thanks
Best Regards,
Dawn
Comment 9 Ronen Hod 2012-07-14 16:16:56 EDT
Postponed to RHEL5.10, as this is not a regression due to the use of 6.3 virtio-win (in RHEL5). Actually, it happens with E1000 too, so it is a host side problem.
Comment 10 Yan Vugenfirer 2012-07-15 04:21:52 EDT
Please try to run the test with iperf in order to check if it is not netperf issue.
Comment 11 Ronen Hod 2012-07-15 12:54:19 EDT
Might be related also to bug#698541 - vhost-net/kvm need optimizations for UDP R from guest to host
Comment 12 dawu 2012-07-16 02:32:37 EDT
(In reply to comment #10)
> Please try to run the test with iperf in order to check if it is not netperf
> issue.

Hi yan,
Tried with iperf, this issue still happened, please refer to the following result for details:

$ iperf.exe  -c 10.66.9.242 -u
------------------------------------------------------------
Client connecting to 10.66.9.242, UDP port 5001
Sending 1470 byte datagrams
UDP buffer size: 64.0 KByte (default)
------------------------------------------------------------
[  3] local 10.66.10.185 port 59744 connected with 10.66.9.242 port
[ ID] Interval       Transfer     Bandwidth
[  3]  0.0-10.0 sec  1.25 MBytes  1.05 Mbits/sec
[  3] Sent 893 datagrams
[  3] WARNING: did not receive ack of last datagram after 10 tries.

$ iperf.exe -c 10.66.9.242
-------------------------------------------------
Client connecting to 10.66.9.242, TCP port 5001
TCP window size: 64.0 KByte (default)
-------------------------------------------------
[  3] local 10.66.10.185 port 49189 connected wit
[ ID] Interval       Transfer     Bandwidth
[  3]  0.0-10.0 sec   550 MBytes   462 Mbits/sec

Best Regards,
Dawn
Comment 13 Yan Vugenfirer 2012-07-16 04:57:37 EDT
Thanks!

Note You need to log in before you can comment on or make changes to this bug.