Bug 839567 - [virt-viewer]in virt-viewer help , spice-smartcard-db should not have "="
[virt-viewer]in virt-viewer help , spice-smartcard-db should not have "="
Status: CLOSED CANTFIX
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: virt-viewer (Show other bugs)
6.4
Unspecified Unspecified
low Severity medium
: rc
: ---
Assigned To: Daniel Berrange
Virtualization Bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-07-12 06:29 EDT by zhe peng
Modified: 2012-07-26 12:58 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-07-26 12:58:49 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description zhe peng 2012-07-12 06:29:42 EDT
Description of problem:
in virt-viewer help ,spice-smartcard-db should not have "="

Version-Release number of selected component (if applicable):
virt-viewer-0.5.2-9.el6.x86_64

How reproducible:
always

Steps to Reproduce:
1: run command:
#virt-viewer --help-all or #virt-viewer --help-spice
#remote-viewer --help-all or #remote-viewer --help-spice

Actual results:
--spice-smartcard-db=<certificate-db>
use this command will couse software smartcart can't worked.

Expected results:
--spice-smartcard-db<certificate-db>

Additional info:
refer bug:https://bugzilla.redhat.com/show_bug.cgi?id=815175
Comment 2 Christophe Fergeau 2012-07-12 07:11:05 EDT
I reread bug #815175 and I think things are more complicated than that. Are you using ~/.netscape, or ~/something as the path to the certificate database? Or are you using a path without '~' in it?
Comment 3 zhe peng 2012-07-12 07:28:54 EDT
according to https://bugzilla.redhat.com/show_bug.cgi?id=815175#c2 
using ~/.netscape/ or /root/.netscape/ all worked well
Comment 4 Christophe Fergeau 2012-07-12 09:49:39 EDT
Yes, they worked well with ' ' instead of '=', but I think using --spice-smartcard-db=/root/.netscape/ would work too and that only --spice-smartcard-db=~/.netscape/ is broken, and that this behaviour is not specific to virt-viewer.
Comment 5 zhe peng 2012-07-13 01:43:39 EDT
Yes, i re-test this part, only --spice-smartcard-db=~/.netscape/ is broken,
--spice-smartcard-db=/root/.netscape and --spice-smartcard-db ~/.netscape/ worked, so ,do you think we should coment this in virt-viewer help? or ignore this in virt-viewer. thanks in advance.
Comment 6 Christophe Fergeau 2012-07-13 05:03:43 EDT
Other commands have exactly the same behaviour:

$ wget --output-file=~/tuseoh.log 'http://redhat.com'
wget: ~/tuseoh.log: No such file or directory
$

$ wget --output-file=/home/teuf/tuseoh.log 'http://redhat.com'
$

so this looks like a standard oddity with shell commands, not an issue specific to virt-viewer. Imo this is not really a bug and we should close this one.
Comment 7 Daniel Berrange 2012-07-26 12:58:49 EDT
Based on the above discussion, this is normal shell expansion behaviour for any app.

Note You need to log in before you can comment on or make changes to this bug.