Bug 839626 - sss_groupshow does not show nested group memberships correctly
sss_groupshow does not show nested group memberships correctly
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: sssd (Show other bugs)
7.0
Unspecified Unspecified
unspecified Severity low
: rc
: 7.1
Assigned To: SSSD Maintainers
Namita Soman
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-07-12 09:02 EDT by Jenny Galipeau
Modified: 2016-02-28 12:25 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-02-28 12:25:31 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jenny Galipeau 2012-07-12 09:02:10 EDT
Description of problem:

Shanks found this issue.

For some reason, sss_groupshow does not show more than 2 levels of membership:

[root@zeppelin ~]# sss_groupadd gr1
[root@zeppelin ~]# sss_groupadd gr2
[root@zeppelin ~]# sss_groupadd gr3
[root@zeppelin ~]# sss_groupmod -a gr1 gr2
[root@zeppelin ~]# sss_groupmod -a gr2 gr3
[root@zeppelin ~]# sss_usermod -a gr3 lcl
[root@zeppelin ~]# sss_groupshow -R gr1
Group: gr1
GID number: 1001
Member users: 
Is a member of: 
Member groups: 

    Group: gr2
    GID number: 1002
    Member users: 
    Is a member of: gr1
    Member groups: 
[root@zeppelin ~]#

The bug really only hits sss_groupshow because the NSS interface returns all groups:

# id lcl
uid=1000(lcl) gid=1000(lcl) groups=1000(lcl),1001(gr1),1002(gr2),1003(gr3)

Shanks discovered that this used to work in RHEL6.0/sssd-1.2, so most likely the bug was introduced during the sysdb rewrite.


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Dmitri Pal 2012-07-12 09:14:58 EDT
Upstream ticket:
https://fedorahosted.org/sssd/ticket/849
Comment 7 Jakub Hrozek 2016-02-28 12:25:31 EST
Thank you taking your time and submitting this request for Red Hat Enterprise
Linux. The request was cloned to the upstream tracker long time ago (see link
to the upstream ticket above), but it was not given a priority neither in the
upstream project, nor in Red Hat Enterprise Linux.

Given that this request is not planned for a close release, it is highly
unlikely it will be fixed in this major version of Red Hat Enterprise Linux. We
are therefore closing the request as WONTFIX.

To request that Red Hat reconsiders the decision, please reopen the Bugzilla
with the help of Red Hat Customer Service and provide additional business
and/or technical details about it's importance to you. Please note that you can
still track this request or even offer help in the referred upstream Trac
ticket to expedite the solution.

Note You need to log in before you can comment on or make changes to this bug.