Bug 839743 - /etc/init.d/gfs2 won't correctly mount GFS2 volumes that are used as source for a bind mount
/etc/init.d/gfs2 won't correctly mount GFS2 volumes that are used as source f...
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: cluster (Show other bugs)
6.3
All Linux
unspecified Severity medium
: rc
: 6.4
Assigned To: Robert Peterson
Cluster QE
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-07-12 13:43 EDT by Vadim Grinco
Modified: 2012-07-16 06:42 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-07-16 06:42:10 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Vadim Grinco 2012-07-12 13:43:57 EDT
Description of problem:
/etc/init.d/gfs2 won't correctly mount GFS2 volumes that are used as source for a bind mount

Version-Release number of selected component (if applicable):
gfs2-utils-3.0.12.1-32.el6.x86_64

How reproducible:
Always

Steps to Reproduce:
1.add the following items to your fstab:
/dev/mapper/gfs-volume     /pub                    gfs2     noquota,noatime,nobarrier 0 0
/pub                     /exports/pub            none     bind,_netdev

2. run /etc/init.d/gfs2 restart

  
Actual results:
gfs2 will call mount /pub which will mount it to /exports/pub, /dev/mapper/gfs-volume will stay unmounted

Expected results:
Mount /dev/mapper/gfs-volume to /pub

A valid workaround would be changing fstab to:
1.add the following items to your fstab:
/dev/mapper/gfs-volume     /pub                    gfs2     noquota,noatime,nobarrier 0 0
/dev/mapper/gfs-volume     /exports/pub                    gfs2     noquota,noatime,nobarrier 0 0
Comment 2 Steve Whitehouse 2012-07-16 06:42:10 EDT
The _netdev tag isn't really intended for use with GFS2, even though some people have used it in the past. You can add a short script, to mount the bind mounts afterwards if required. There are some notes on this in the docs, see this section and the following one, which contains an example script:

http://docs.redhat.com/docs/en-US/Red_Hat_Enterprise_Linux/6/html-single/Global_File_System_2/index.html#s1-manage-pathnames

Let us know if you need any more info, but I don't think this is a bug.

Note You need to log in before you can comment on or make changes to this bug.