Bug 839758 - SPICE-XPI install still has spice-client as dependency.
SPICE-XPI install still has spice-client as dependency.
Status: CLOSED DUPLICATE of bug 830922
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: spice-xpi (Show other bugs)
7.0
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Yuval Kashtan
Desktop QE
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-07-12 14:03 EDT by Bill Sanford
Modified: 2013-08-06 00:14 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-07-12 16:18:59 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bill Sanford 2012-07-12 14:03:26 EDT
Description of problem:
SPICE-XPI install still has spice-client as dependency where this should have virt-viewer and not spice-client.

Version-Release number of selected component (if applicable):
RHEL-7.0-20120709.0

How reproducible:
100%

Steps to Reproduce:
1. 
2.
3.
  
Actual results:
spice-client is a dependency of spice-xpi.

Expected results:
virt-viewer is a dependency of spice-xpi.

Additional info:


yum install spice-xpi
Loaded plugins: langpacks, product-id, refresh-packagekit, security, subscription-manager
This system is not registered to Red Hat Subscription Management. You can use subscription-manager to register.
Resolving Dependencies
--> Running transaction check
---> Package spice-xpi.x86_64 0:2.7-1.el7 will be installed
--> Processing Dependency: spice-client >= 0.4.2-18 for package: spice-xpi-2.7-1.el7.x86_64
--> Processing Dependency: liblog4cpp.so.4()(64bit) for package: spice-xpi-2.7-1.el7.x86_64
--> Running transaction check
---> Package log4cpp.x86_64 0:1.0-9.el7 will be installed
---> Package spice-xpi.x86_64 0:2.7-1.el7 will be installed
--> Processing Dependency: spice-client >= 0.4.2-18 for package: spice-xpi-2.7-1.el7.x86_64
--> Finished Dependency Resolution
Error: Package: spice-xpi-2.7-1.el7.x86_64 (rhel7)
           Requires: spice-client >= 0.4.2-18
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest
Comment 1 Bill Nottingham 2012-07-12 16:18:59 EDT

*** This bug has been marked as a duplicate of bug 830922 ***

Note You need to log in before you can comment on or make changes to this bug.