Bug 839783 - There are 2 "Controller USB" entries in the hardware list that conflict with SPICE GTK VM starting.
There are 2 "Controller USB" entries in the hardware list that conflict with ...
Status: CLOSED INSUFFICIENT_DATA
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: virt-manager (Show other bugs)
7.0
All Linux
medium Severity medium
: beta
: 7.0
Assigned To: Martin Kletzander
Virtualization Bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-07-12 16:09 EDT by Bill Sanford
Modified: 2013-02-05 08:33 EST (History)
10 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-02-05 08:33:24 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bill Sanford 2012-07-12 16:09:23 EDT
Description of problem:
In RHEL 7 - Virt-Manager and using a RHEL 7 VM,

With the VM off, View -> Details and go to Controller USB.


With the Controller Model at "Default" - "Controller USB" in the hardware list, the libvirt XML file has:

    <controller type='usb' index='0'>
      <address type='pci' domain='0x0000' bus='0x00' slot='0x01' function='0x2'/>
    </controller>


When you change the "Controller USB" in the hardware list from "Default" to "2", the libvirt XML file removed the "Default" Controller Model and now has:

    </controller>
    <controller type='usb' index='0' model='ich9-ehci1'>
      <address type='pci' domain='0x0000' bus='0x00' slot='0x07' function='0x0'/>
    </controller>
    <controller type='usb' index='0' model='ich9-uhci1'>
      <master startport='0'/>
      <address type='pci' domain='0x0000' bus='0x00' slot='0x08' function='0x0'/>
    </controller>
    <controller type='usb' index='0' model='ich9-uhci2'>
      <master startport='2'/>
      <address type='pci' domain='0x0000' bus='0x00' slot='0x09' function='0x0'/>
    </controller>
    <controller type='usb' index='0' model='ich9-uhci3'>
      <master startport='4'/>
      <address type='pci' domain='0x0000' bus='0x00' slot='0x0a' function='0x0'/>


Version-Release number of selected component (if applicable):
RHEL-7.0-20120711.2

How reproducible:
100%

Steps to Reproduce:
1. 
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Bill Sanford 2012-07-13 14:32:29 EDT
In RHEL-7.0-20120711.2, when the VM is created, the "Details" of the VM will show you have 2 "Controller USB" entries in the hardware list, one is "Default" and one is "USB 2." The VM will not start a SPICE VM because of the conflict of both entries.

You must remove the "Controller USB" in the hardware list with the value "Default" for the VM to start as a SPICE-GTK VM.
Comment 2 Bill Sanford 2012-07-13 14:36:42 EDT
To clear up, the version in the original post was RHEL-7.0-20120709.
Comment 5 Geyang Kong 2012-11-28 21:39:28 EST
I cannot reproduce this bug on build RHEL-7.0-20121120.1, can you retry this bug on the new build?

My step:
1. Start virt-manager and create a VM
2. Modify the hardware, change USB Controller from default to USB2
3. Check hardware.
4. Start the guest.

Actual result:
1. After step 3, there is only 1 USB controller.
2. After step 4, guest can be started normally.
Comment 6 Martin Kletzander 2012-12-14 06:03:04 EST
Whatever I tried, I wasn't able to create 2 USB controllers using virt-manager.
I tried creating new machine, modifying created machines, both approaches multiple times, and it looks like it might have been problem of an older version.  When possible, could you try to reproduce it on newer build as suggested in comment #5, possibly with '--debug' parameter and in case you'll experience it again, please attach the result here, thanks.
Comment 7 Martin Kletzander 2013-02-05 08:33:24 EST
Nor devel neither QE were able to reproduce this issue with the information provided, so I'm closing this one as INSUFFICIENT_DATA.
Feel free to open the bug if the issue persists or there is any new information.

Note You need to log in before you can comment on or make changes to this bug.