Bug 839848 - [virtio-win][block]Checking block serial number failed on windows guest
[virtio-win][block]Checking block serial number failed on windows guest
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: kvm (Show other bugs)
5.9
Unspecified Unspecified
medium Severity medium
: rc
: ---
Assigned To: Asias He
Virtualization Bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-07-12 23:10 EDT by Min Deng
Modified: 2013-10-31 20:04 EDT (History)
10 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-07-18 03:29:29 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Min Deng 2012-07-12 23:10:25 EDT
Description of problem:
Checking serial number via hddinf.exe failed,the serial number is blank.

Version-Release number of selected component (if applicable):
virtio-win-1.5.3-1.el6_3.noarch.rpm

How reproducible:
on rhel 5,Always

Steps to Reproduce:
1.boot up guest with the following 
  on rhel5
  /usr/libexec/qemu-kvm -m 4G -smp 4 -usbdevice tablet -drive file=/home/win2k8-32.qcow2,if=virtio,boot=on,werror=stop,cache=writeback,format=qcow2,media=disk -net nic,model=virtio,vlan=0 -net tap,script=/etc/qemu-ifup,vlan=0 -uuid `uuidgen` -boot dc -monitor stdio -vnc :11 -fda /home/virtio-win-1.5.3.vfd -drive file=/home/virtio-win-1.5.3.iso,if=ide,index=2,media=cdrom -drive file=/home/en_windows_server_2008_datacenter_enterprise_standard_sp2_x64_dvd_342336.iso,if=ide,index=1,media=cdrom -drive file=/home/disk1.qcow2,if=virtio,werror=stop,cache=writeback,format=qcow2,media=disk,serial=mimimi
2.Make sure install virtio block driver and format the attached disk 
  run hddinf.exe and check the serial number
  eg:
   hddinf.exe e:

3.on rhel 5,no matter what file format (raw and qcow2)you used,user cannot see the serial number from the guest. 
  
Actual results:
The serial number is blank

Expected results:
Can see the serial number

Additional info:
Similar issue can be reproduced on rhel6 but it isn't always
Comment 1 Vadim Rozenfeld 2012-07-12 23:27:05 EDT
(In reply to comment #0)
> Description of problem:
> Checking serial number via hddinf.exe failed,the serial number is blank.
> 
> Version-Release number of selected component (if applicable):
> virtio-win-1.5.3-1.el6_3.noarch.rpm
> 
> How reproducible:
> on rhel 5,Always
> 
> Steps to Reproduce:
> 1.boot up guest with the following 
>   on rhel5
>   /usr/libexec/qemu-kvm -m 4G -smp 4 -usbdevice tablet -drive
> file=/home/win2k8-32.qcow2,if=virtio,boot=on,werror=stop,cache=writeback,
> format=qcow2,media=disk -net nic,model=virtio,vlan=0 -net
> tap,script=/etc/qemu-ifup,vlan=0 -uuid `uuidgen` -boot dc -monitor stdio
> -vnc :11 -fda /home/virtio-win-1.5.3.vfd -drive
> file=/home/virtio-win-1.5.3.iso,if=ide,index=2,media=cdrom -drive
> file=/home/
> en_windows_server_2008_datacenter_enterprise_standard_sp2_x64_dvd_342336.iso,
> if=ide,index=1,media=cdrom -drive
> file=/home/disk1.qcow2,if=virtio,werror=stop,cache=writeback,format=qcow2,
> media=disk,serial=mimimi
> 2.Make sure install virtio block driver and format the attached disk 
>   run hddinf.exe and check the serial number
>   eg:
>    hddinf.exe e:
> 
> 3.on rhel 5,no matter what file format (raw and qcow2)you used,user cannot
> see the serial number from the guest. 
>   
> Actual results:
> The serial number is blank
> 
> Expected results:
> Can see the serial number
> 
> Additional info:
> Similar issue can be reproduced on rhel6 but it isn't always

Hi Min,
I'm not sure whether or not qemu in rhel5 provides serial number. Could you check it with a Linux guest. If it does, please retry Windows with rhel6 viostor driver.

Thank you,
Vadim.
Comment 2 Mike Cao 2012-07-13 02:02:27 EDT
Talked this issue w/ Amit ,he said qemu userspace in rhel5 does not support it ,move component to kvm
Comment 3 Ronen Hod 2012-07-14 12:02:03 EDT
Asias,
If this is also a RHEL6 (host) issue, then it is worth fixing, otherwise I would fix it only if it is a regression.

Min,
Is it a regression? Does it stand in the way for WHQL/HCK? Otherwise, we will probably not fix it for RHEL5.
You said that it can be reproduced on RHEL6, but not always, can you please elaborate?

Ronen.
Comment 4 RHEL Product and Program Management 2012-07-14 12:08:02 EDT
This request was evaluated by Red Hat Product Management for inclusion
in a Red Hat Enterprise Linux release.  Product Management has
requested further review of this request by Red Hat Engineering, for
potential inclusion in a Red Hat Enterprise Linux release for currently
deployed products.  This request is not yet committed for inclusion in
a release.
Comment 5 Asias He 2012-07-14 19:27:04 EDT
(In reply to comment #3)
> Asias,
> If this is also a RHEL6 (host) issue, then it is worth fixing, otherwise I
> would fix it only if it is a regression.
> 
> Min,
> Is it a regression? Does it stand in the way for WHQL/HCK? Otherwise, we
> will probably not fix it for RHEL5.
> You said that it can be reproduced on RHEL6, but not always, can you please
> elaborate?

Serial support in RHEL5 host side is not supported. 

Serial support in RHEL5 kernel side just added in recently. See:
https://bugzilla.redhat.com/show_bug.cgi?id=816863

Can you try the latest RHEL5 kernel on RHEL6 host?
Comment 6 Mike Cao 2012-07-15 02:48:10 EDT
(In reply to comment #3)
> Asias,
> If this is also a RHEL6 (host) issue, then it is worth fixing, otherwise I
> would fix it only if it is a regression.
> 
> Min,
> Is it a regression? Does it stand in the way for WHQL/HCK? Otherwise, we
> will probably not fix it for RHEL5.

This bug does not related to WHQL/WLK/HCK . it belongs to functional test 

Mike
> You said that it can be reproduced on RHEL6, but not always, can you please
> elaborate?
> 
> Ronen.
Comment 7 Min Deng 2012-07-16 22:57:25 EDT
(In reply to comment #3)
> Asias,
> If this is also a RHEL6 (host) issue, then it is worth fixing, otherwise I
> would fix it only if it is a regression.
> 
> Min,
> Is it a regression? Does it stand in the way for WHQL/HCK? Otherwise, we
> will probably not fix it for RHEL5.
> You said that it can be reproduced on RHEL6, but not always, can you please
> elaborate?
> 
> Ronen.

Hi Ronen,

 I do re-test again and tried it on rhel6 and I couldn't reproduce the issue any longer.Even if I couldn't reproduce the issue at this time but I still doubted it.I will re-install a new image and double check the bz.If I can reproduce the bz on rhel6 host I will open a new bug for rhel6

Thanks,
Min
Comment 8 Mike Cao 2012-07-16 23:04:48 EDT
(In reply to comment #7)
> (In reply to comment #3)
> > Asias,
> > If this is also a RHEL6 (host) issue, then it is worth fixing, otherwise I
> > would fix it only if it is a regression.
> > 
> > Min,
> > Is it a regression? Does it stand in the way for WHQL/HCK? Otherwise, we
> > will probably not fix it for RHEL5.
> > You said that it can be reproduced on RHEL6, but not always, can you please
> > elaborate?
> > 
> > Ronen.
> 
> Hi Ronen,
> 
>  I do re-test again and tried it on rhel6 and I couldn't reproduce the issue
> any longer.Even if I couldn't reproduce the issue at this time but I still
> doubted it.I will re-install a new image and double check the bz.If I can
> reproduce the bz on rhel6 host I will open a new bug for rhel6
> 
> Thanks,
> Min

Hi, Min
Pls do not use one bug to track different component issues . If you still can reproduced it on RHEL6 hosts , pls report an new bug agaist RHEL6 qemu-kvm/virtio-win component .

Mike
Comment 9 Ronen Hod 2012-07-18 03:29:29 EDT
Closing.
We will not add the functionality in RHEL5 host.
Probably there is no issue with RHEL6 also, and if there is an issue, open a new bug please.

Thanks.

Note You need to log in before you can comment on or make changes to this bug.