This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 839887 - Got generic message “Error updating system data” for non network host.
Got generic message “Error updating system data” for non network host.
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: subscription-manager (Show other bugs)
5.9
Unspecified Unspecified
medium Severity medium
: beta
: 5.9
Assigned To: Bryan Kearney
Entitlement Bugs
: QA-Closed
Depends On:
Blocks: 771748
  Show dependency treegraph
 
Reported: 2012-07-13 02:58 EDT by spandey
Modified: 2015-04-23 19:57 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-01-07 22:57:02 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description spandey 2012-07-13 02:58:41 EDT
Description of problem:


Version-Release number of selected component (if applicable):


How reproducible:
3/3

Prerequisites : 
Rhel5.9  machine with following subscription-manager rpm 
subscription-manager-gui-1.0.8-1.git.14.dfc8438.el5
subscription-manager-migration-1.0.8-1.git.14.dfc8438.el5
subscription-manager-firstboot-1.0.8-1.git.14.dfc8438.el5
subscription-manager-migration-data-1.11.2.2-1.git.0.2eea155.el5
subscription-manager-1.0.8-1.git.14.dfc8438.el5

Steps to repro : 
Register client to candlepin .
Disable client network.
Update system facts.

Expected Result : 
Proper Network error message should display on console. 

Actual Result : 
Got following unclear message.

"Error updating system data , see /var/log/rhsm/rhsm.log for more details".

testcase : https://tcms.engineering.redhat.com/run/42056/#caserun_1281153
Comment 1 Bryan Kearney 2012-07-17 15:54:06 EDT
expanded the text to be 

Error updating system data on the server

This is a genric error, so we can not provide much more inforation then that.
Comment 2 Bryan Kearney 2012-07-18 11:33:19 EDT
Available in 1.0.10 or later.
Comment 3 RHEL Product and Program Management 2012-07-19 10:38:38 EDT
This request was evaluated by Red Hat Product Management for inclusion
in a Red Hat Enterprise Linux release.  Product Management has
requested further review of this request by Red Hat Engineering, for
potential inclusion in a Red Hat Enterprise Linux release for currently
deployed products.  This request is not yet committed for inclusion in
a release.
Comment 5 spandey 2012-07-24 06:26:54 EDT
Rpm to verified :
subscription-manager-firstboot-1.0.10-1.git.15.2019338.el5
subscription-manager-1.0.10-1.git.15.2019338.el5
subscription-manager-gui-1.0.10-1.git.15.2019338.el5
subscription-manager-migration-data-1.11.2.2-1.git.0.2eea155.el5
subscription-manager-migration-1.0.10-1.git.15.2019338.el5

Working fine

As per comment 1 i am marking this defect verified.
Comment 7 errata-xmlrpc 2013-01-07 22:57:02 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-0033.html

Note You need to log in before you can comment on or make changes to this bug.