Bug 840010 - kvm guest kernel call traces when shutting down "WARNING: at fs/sysfs/group.c:138 sysfs_remove_group+0xfa/0x100()" on AMD host
kvm guest kernel call traces when shutting down "WARNING: at fs/sysfs/group....
Status: CLOSED DUPLICATE of bug 821362
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: qemu-kvm (Show other bugs)
7.0
Unspecified Unspecified
medium Severity medium
: rc
: ---
Assigned To: Virtualization Maintenance
Virtualization Bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-07-13 08:50 EDT by Xiaoqing Wei
Modified: 2012-07-14 09:03 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-07-14 09:03:41 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
guest serial output. (17.59 KB, text/x-log)
2012-07-13 09:39 EDT, Xiaoqing Wei
no flags Details

  None (edit)
Description Xiaoqing Wei 2012-07-13 08:50:01 EDT
Description of problem:
kvm guest kernel call traces when shutting down 
"WARNING: at fs/sysfs/group.c:138 sysfs_remove_group+0xfa/0x100()" on AMD host

Version-Release number of selected component (if applicable):
kernel-3.3.0-0.20.el7.x86_64
qemu-kvm-1.0-17.1.el7.x86_64

How reproducible:
2 / 5

Steps to Reproduce:
1.
/home/autotest-devel/client/tests/kvm/qemu -name 'vm1' -nodefaults -chardev socket,id=human_monitor_id_humanmonitor1,path=/tmp/monitor-humanmonitor1-20120713-162245-j9qs,server,nowait -mon chardev=human_monitor_id_humanmonitor1,mode=readline -chardev socket,id=serial_id_20120713-162245-j9qs,path=/tmp/serial-20120713-162245-j9qs,server,nowait -device isa-serial,chardev=serial_id_20120713-162245-j9qs -device ich9-usb-uhci1,id=usb1,bus=pci.0,addr=0x4 -drive file='/home/autotest-devel/client/tests/kvm/images/RHEL-Server-7.0-64-virtio.qcow2',index=0,if=none,id=drive-virtio-disk1,media=disk,cache=none,boot=off,snapshot=off,format=qcow2,aio=native -device virtio-blk-pci,bus=pci.0,addr=0x5,drive=drive-virtio-disk1,id=virtio-disk1 -device virtio-net-pci,netdev=idWcvwBq,mac=9a:01:6f:29:31:ad,id=ndev00idWcvwBq,bus=pci.0,addr=0x3 -netdev tap,id=idWcvwBq,fd=21 -m 16384 -smp 4,cores=2,threads=1,sockets=2 -cpu 'Opteron_G3' -device usb-tablet,id=usb-tablet1,bus=usb1.0,port=1 -vnc :0 -vga cirrus -rtc base=utc,clock=host,driftfix=slew -M pc-1.0 -boot order=cdn,once=c,menu=off    -no-kvm-pit-reinjection -enable-kvm 
2.
wait for 10 min
3.
reboot/shutdown the guest.
Actual results:
-----snipped
2012-07-13 18:47:04: Unmounted /oldroot.
2012-07-13 18:47:04: [  100.692752] dracut: Disassembling device-mapper devices
2012-07-13 18:47:04: [  100.768917] flush-253:1 used greatest stack depth: 3240 bytes left
2012-07-13 18:47:04: [  100.908456] dracut: Disassembling mdraid devices.
2012-07-13 18:47:04: Powering off.
2012-07-13 18:47:04: [  100.981762] md: stopping all md devices.
2012-07-13 18:47:04: [  100.997305] ACPI: Preparing to enter system sleep state S5
2012-07-13 18:47:04: [  101.008765] Disabling non-boot CPUs ...
2012-07-13 18:47:04: [  101.018993] Unregister pv shared memory for cpu 1
2012-07-13 18:47:04: [  101.027835] ------------[ cut here ]------------
2012-07-13 18:47:04: [  101.033847] WARNING: at fs/sysfs/group.c:138 sysfs_remove_group+0xfa/0x100()
2012-07-13 18:47:04: [  101.042716] Hardware name: Bochs
2012-07-13 18:47:04: [  101.047063] sysfs group ffffffffa00bf130 not found for kobject 'cpu1'
2012-07-13 18:47:04: [  101.054593] Modules linked in: ipt_MASQUERADE nf_conntrack_netbios_ns nf_conntrack_broadcast ip6table_mangle ip6t_REJECT nf_conntrack_ipv6 nf_defrag_ipv6 ip6table_filter bnep ip6_tables bluetooth rfkill iptable_nat nf_nat iptable_mangle ipt_REJECT nf_conntrack_ipv4 nf_defrag_ipv4 xt_conntrack nf_conntrack iptable_filter ip_tables microcode pcspkr i2c_piix4 i2c_core uinput ata_generic pata_acpi ata_piix virtio_net virtio_blk libata floppy dm_mirror dm_region_hash dm_log dm_mod [last unloaded: scsi_wait_scan]
------snipped

Expected results:
reboot/shutdown without any error/call trace.

Additional info:

Host_info:
RAM 32G
CPU:
processor	: 7
vendor_id	: AuthenticAMD
cpu family	: 16
model		: 4
model name	: Quad-Core AMD Opteron(tm) Processor 2376
stepping	: 2
microcode	: 0x10000db
cpu MHz		: 800.000
cache size	: 512 KB
Comment 1 Xiaoqing Wei 2012-07-13 09:39:35 EDT
Created attachment 598074 [details]
guest serial output.
Comment 2 Karen Noel 2012-07-14 09:03:41 EDT

*** This bug has been marked as a duplicate of bug 821362 ***

Note You need to log in before you can comment on or make changes to this bug.