Bug 840027 - kvm guest Kernel panic when shutting down on INTEL host
kvm guest Kernel panic when shutting down on INTEL host
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: dracut (Show other bugs)
7.0
Unspecified Unspecified
medium Severity medium
: rc
: ---
Assigned To: dracut-maint
Virtualization Bugs
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-07-13 09:31 EDT by Xiaoqing Wei
Modified: 2014-06-16 04:18 EDT (History)
5 users (show)

See Also:
Fixed In Version: dracut-024-25.git20130205.el7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-06-16 04:18:05 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
guest serial output. (45.07 KB, text/x-log)
2012-07-13 09:40 EDT, Xiaoqing Wei
no flags Details

  None (edit)
Description Xiaoqing Wei 2012-07-13 09:31:00 EDT
Description of problem:

kvm guest Kernel panic when shutting down on INTEL host
 
 
Version-Release number of selected component (if applicable):
qemu-kvm-1.0-17.1.el7.x86_64
kernel-3.3.0-0.20.el7.x86_64


How reproducible:

3 / 10

Steps to Reproduce:
1.
/home/autotest-devel/client/tests/kvm/qemu -name vm1 -nodefaults -chardev socket,id=human_monitor_id_humanmonitor1,path=/tmp/monitor-humanmonitor1-20120713-162245-j9qs,server,nowait -mon chardev=human_monitor_id_humanmonitor1,mode=readline -chardev socket,id=serial_id_20120713-162245-j9qs,path=/tmp/serial-20120713-162245-j9qs,server,nowait -device isa-serial,chardev=serial_id_20120713-162245-j9qs -device ich9-usb-uhci1,id=usb1,bus=pci.0,addr=0x4 -drive file=/home/autotest-devel/client/tests/kvm/images/RHEL-Server-7.0-64-virtio.qcow2,index=0,if=none,id=drive-virtio-disk1,media=disk,cache=none,boot=off,snapshot=off,format=qcow2,aio=native -device virtio-blk-pci,bus=pci.0,addr=0x5,drive=drive-virtio-disk1,id=virtio-disk1 -device virtio-net-pci,netdev=idTS4cxm,mac=9a:79:ba:f9:21:9e,id=ndev00idTS4cxm,bus=pci.0,addr=0x3 -netdev tap,id=idTS4cxm,fd=21 -m 16384 -smp 4,cores=2,threads=1,sockets=2 -cpu Penryn -device usb-tablet,id=usb-tablet1,bus=usb1.0,port=1 -vnc :0 -vga cirrus -rtc base=utc,clock=host,driftfix=slew -M pc-1.0 -boot order=cdn,once=c,menu=off -no-kvm-pit-reinjection -enable-kvm
2.run some simple test, 
 guest <-scp -> host
3.shutdown guest
  
Actual results:
2012-07-13 18:45:08: [  113.167239] shutdown used greatest stack depth: 2728 bytes left
2012-07-13 18:45:08: [  113.174392] Kernel panic - not syncing: Attempted to kill init!

Expected results:

guest should shutdown w/o error
Additional info:

1) configured kdump in guest, but wont help.

2) Host info:
RAM 32G
cpu:
processor	: 7
vendor_id	: GenuineIntel
cpu family	: 6
model		: 23
model name	: Intel(R) Xeon(R) CPU           E5405  @ 2.00GHz
stepping	: 10
microcode	: 0xa0b
cpu MHz		: 2000.080
cache size	: 6144 KB
Comment 1 Xiaoqing Wei 2012-07-13 09:37:56 EDT
1) tried shutdown on the host, works fine

2) reboot guest, works fine (tried 30 rounds.)
Comment 2 Xiaoqing Wei 2012-07-13 09:40:04 EDT
Created attachment 598075 [details]
guest serial output.
Comment 3 Karen Noel 2012-07-16 07:03:17 EDT
2012-07-13 18:45:08: Successfully changed into root pivot.
2012-07-13 18:45:08: /shutdown: line 12: /lib/dracut-lib.sh: No such file or directory
2012-07-13 18:45:08: [  113.167239] shutdown used greatest stack depth: 2728 bytes left
2012-07-13 18:45:08: [  113.174392] Kernel panic - not syncing: Attempted to kill init!
2012-07-13 18:46:56: (Process terminated with status 0)
Comment 4 Gleb Natapov 2012-07-16 07:26:45 EDT
Nothing virtualization specific here.
Comment 5 Gleb Natapov 2012-07-16 07:34:08 EDT
Looks like this one: https://bugzilla.redhat.com/show_bug.cgi?id=831634
Comment 6 Xiaoqing Wei 2012-07-18 03:45:05 EDT
(In reply to comment #3)
> 2012-07-13 18:45:08: Successfully changed into root pivot.
> 2012-07-13 18:45:08: /shutdown: line 12: /lib/dracut-lib.sh: No such file or
> directory
> 2012-07-13 18:45:08: [  113.167239] shutdown used greatest stack depth: 2728
> bytes left
> 2012-07-13 18:45:08: [  113.174392] Kernel panic - not syncing: Attempted to
> kill init!
> 2012-07-13 18:46:56: (Process terminated with status 0)

Hi Karen,

What info you need ?
Comment 7 Jes Sorensen 2012-07-18 09:17:25 EDT
Looks dracut related - adding Harald
Comment 8 Harald Hoyer 2012-07-19 07:41:53 EDT
(In reply to comment #3)
> 2012-07-13 18:45:08: Successfully changed into root pivot.
> 2012-07-13 18:45:08: /shutdown: line 12: /lib/dracut-lib.sh: No such file or
> directory
> 2012-07-13 18:45:08: [  113.167239] shutdown used greatest stack depth: 2728
> bytes left
> 2012-07-13 18:45:08: [  113.174392] Kernel panic - not syncing: Attempted to
> kill init!
> 2012-07-13 18:46:56: (Process terminated with status 0)

this should already be fixed with latest dracut in F17

https://admin.fedoraproject.org/updates/FEDORA-2012-9847/dracut-018-78.git20120622.fc17

26 days old.
Comment 9 Karen Noel 2012-07-23 07:11:11 EDT
Can you confirm the fix with RHEL7.0 Alpha 2?
Comment 10 Xiaoqing Wei 2012-07-23 07:55:39 EDT
(In reply to comment #9)
> Can you confirm the fix with RHEL7.0 Alpha 2?

Hi Karen,

I was using Alpha2 when reporting this bug

RHEL7.0-20120711.2

Thanks
Xiaoqing.
Comment 13 Harald Hoyer 2013-02-26 04:12:34 EST
fixed with dracut-024-25.git20130205.el7
Comment 14 Ludek Smid 2014-06-16 04:18:05 EDT
This request was resolved in Red Hat Enterprise Linux 7.0.

Contact your manager or support representative in case you have further questions about the request.

Note You need to log in before you can comment on or make changes to this bug.