Bug 840030 - top-level apache blocks access to application files on /icons
top-level apache blocks access to application files on /icons
Status: CLOSED CURRENTRELEASE
Product: OpenShift Origin
Classification: Red Hat
Component: Containers (Show other bugs)
2.x
Unspecified Unspecified
medium Severity medium
: ---
: ---
Assigned To: Ram Ranganathan
libra bugs
: FutureFeature, Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-07-13 09:38 EDT by Nam Duong
Modified: 2015-05-14 18:56 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-08-07 16:42:57 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Nam Duong 2012-07-13 09:38:07 EDT
Description of problem:
Please see https://openshift.redhat.com/community/forums/openshift/accessing-images

I created a new php app called phpplain and the following directories and files:
phpplain/php/foo2.png
phpplain/php/icon/foo2.png
phpplain/php/icons/foo2.png

Then used git to post those changes:
git add .
git commit -a -m "find my screenshot"
git push

Then tried accessing my screenshot:
http://phpplain-macdomain.rhcloud.com/foo2.png
http://phpplain-macdomain.rhcloud.com/icon/foo2.png
http://phpplain-macdomain.rhcloud.com/icons/foo2.png

The last link threw a 404
Comment 1 Rob Millner 2012-07-13 16:43:50 EDT
Moving this request past the stage push for this sprint.  It'll go into the next one.
Comment 2 Ram Ranganathan 2012-07-13 18:00:29 EDT
This is caused by an alias in httpd.conf (which was presumably put in there for the fancy directory indexing bits which we turned off). I'll add it to the 10 bug list.
Comment 3 Ram Ranganathan 2012-07-17 17:42:49 EDT
Fixed w/ pull request 88 merged into li (merge commit a5e192f913e6a0000f7178108bdcc794fa0757dd)  and pull request 242 on crankcase (merge commit ad5b0fdd1819229def4324d679118cbf9c34283e).
Comment 4 Jianwei Hou 2012-07-17 22:22:04 EDT
verified on devenv_1899

steps:
1.Create a php application phpplain
  rhc app create -a phpplain -t php-5.3
2.Add image files under app's repo
  phpplain/php/foo2.png
  phpplain/php/icon/foo2.png
  phpplain/php/icons/foo2.png
3.git add .
  git commit -a -m 'added images'
  git push
4.go to app's URL and check images
http://phpplain-dev1899test.dev.rhcloud.com/
http://phpplain-dev1899test.dev.rhcloud.com/foo2.png
http://phpplain-dev1899test.dev.rhcloud.com/icon/foo2.png
http://phpplain-dev1899test.dev.rhcloud.com/icons/foo2.png


results:
The URLs are accessible and images are displayed.

fixed in devenv_1899

Note You need to log in before you can comment on or make changes to this bug.