Bug 840038 - libvirtd 0.9.11.4 crash connection to VirtualBox-4.1
libvirtd 0.9.11.4 crash connection to VirtualBox-4.1
Status: CLOSED DEFERRED
Product: Virtualization Tools
Classification: Community
Component: libvirt (Show other bugs)
unspecified
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Libvirt Maintainers
abrt_hash:0b1aa5f7c8b154b391d5c288124...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-07-13 10:00 EDT by Cristian Ciupitu
Modified: 2016-04-26 12:59 EDT (History)
12 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-03-23 18:21:53 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: dso_list (7.77 KB, text/plain)
2012-07-13 10:00 EDT, Cristian Ciupitu
no flags Details
File: var_log_messages (14.27 KB, text/plain)
2012-07-13 10:00 EDT, Cristian Ciupitu
no flags Details
File: maps (36.52 KB, text/plain)
2012-07-13 10:00 EDT, Cristian Ciupitu
no flags Details
File: backtrace (34.20 KB, text/plain)
2012-07-13 10:00 EDT, Cristian Ciupitu
no flags Details

  None (edit)
Description Cristian Ciupitu 2012-07-13 10:00:20 EDT
libreport version: 2.0.10
abrt_version:   2.0.10
backtrace_rating: 4
cmdline:        /usr/sbin/libvirtd
crash_function: VBoxNsprPR_NewThreadPrivateIndex
executable:     /usr/sbin/libvirtd
kernel:         3.4.4-5.fc17.x86_64
pid:            4176
pwd:            /
time:           Fri 13 Jul 2012 02:07:38 PM EEST
uid:            1000
username:       root

backtrace:      Text file, 35016 bytes
dso_list:       Text file, 7952 bytes
maps:           Text file, 37400 bytes
var_log_messages: Text file, 14617 bytes

build_ids:
:c4643c86405e20bda6a7ec839bf9f8b4a98b0820
:1269d1e5d9e60a9b0cb72efb4e067e315ced8f0c
:474a230c279e9f4eb29083558aeb95e023331594
:3ed980d92d88122f7c9fd9dea086c6f5b81466bf
:fad2d57f73db1d2b51917a93ac42fb4e1308b141
:9c416df34aef78b429bb43617c68f6d76c29ec6b
:c8f9127ad4a0e9055361cbdcd59b37738c1765dd
:1b7abd5c8129b91c0ca4f0f0812e61660236fd38
:b119294706de2f5a790a2fef751ac31315d52901
:08a22265f9c12341ac07fbf242a8c5315fc3ff30
:6ea05195018eb2e7efb545d3cbdec19ab3680ec4
:ed55b3c8f9bc4daa9c7185ea38dc19fe3a503aea
:a4ec59d7fc9c453fb4287d7ebc5fcf6579792e65
:350920b52e92655cdb258fa5f96fe7004ad07a52
:67792c148d2b8f13f6732c9367e926c26d7376c5
:63651cdc0224824a9c9324c77c3b5887378e871d
:7feb6166463dadfb8c7504ecea68bfad514ad2db
:822e9b3523e8312240f41a25722d539bc77ed436
:4d6188ea4e7fcc259d17377b74ebebfb00a29ac0
:137ce33e99dff4cf33f9835c815b1b6860445a50
:d804f8ee47797da9213a92f00cd095ecada8d79f
:8d646f64cd4a6c19985423dfab9f8668c6af7f80
:ef8b8d492b07f4bb141fc3c32bc3bbf1c4c45275
:13718b5000238cc2421cc0ad9d3ba8a6e6bf8a00
:dc180d4c4e245433416c83c6ad203eafdef956ee
:443520b75b8ac97f1c0525a301b873ced177ea6a
:9bf1995de22c8c408e4199a79ea998de7e1587a8
:b6d75088f555d197be1476cb1c580640826ae029
:8cf5c11adfa4d5efb8d06e5d356eb4b0643e1680
:645806eaf00b66465a27f0986c11f9bd6a73045a
:f1c5764c91642a33bec2d4ba5adbefc196cc8d60
:660447df868950306c58cc99ac7490a24b5fa670
:e99c86eb3485e54972f176ba34d78396596de7af
:58ebb13e248655204723285a12c4b88984bd3e80
:f64b7319b84d426ed547084bdb2577f4f596c18f
:cd6934c7ffdc10b4626f8a94336de83eb989545e
:f968e35315d01815c4c00607cb92a96a25db078a
:27a04c8d90377f0f2de1d1ac476f34511501e92c
:00ab653044d47d504dd49135aff0306483c4c103
:3d60535f052babb998bae4807bc992c5d15df5c4
:535ee166aabdb98e39b6ae2a7a8876780f2b29b5
:c2f5ae8bd64df0fc996cf96b95525a8f8fb28fd2
:1a262290abc47e43b15d179c909c389831958b90
:a749e2d7670ba481f7fbb58625f28507adca10bf
:07d2432f2cea31e902ec19ecdc72dde8df873864
:091927b7a315243a2ff0383dfca1fd2c665405bf
:0c861d4584a090c315010d8e5d9ab13ceb746ae5
:3e50a42f7e85c27f3490c219749dfa2ecc14f6a5
:a2d5b50b07df0fb9c52fcc682c6121d3e7276249
:8f7da8623a3064159b2c5554d6e1e5cbb11a3a7d
:f4f9ce91c43285df84177f9684a3e7f190a0aae1
:cbb8a8e0998ebc35f3394e942b5bf90d19d90fc5
:bffbcd62e7590e0462384693e4d36fe8c6463b4a
:5f038f3fb1b1571769e7c9b79e025fe328052950
:50f16df934d0d9b1235796d014157733fda755c5
:57daf604bef735ab18319f0436edd52ce4488a17
:51a68b4216410217391d460ed77f374d8273fbb3
:a168379f57867576d7bc7148bfb0431a6a4ab125
:1a0c09f270adf8398df4362ce0acfafc1f970982
:7a7fc293ed8816b1c9844ade0dc9f93f26b8e7df
:d32cbeacfd9f41e3cd29b697dd111f44a2d9c127
:d29489f5262f513cfe15d381fff29a18dc759deb
:aaa1236e690a9d2f230ade4b8d4387c22200ba9f
:fffb0e6dd2f8decf1f14d81c35f1ec36182ae915
:a27ad86b60f50e96117f7d55a8605e5e4d3efecc
:07eeab10f84a3b9e35c51acdb3c5737f5544adc4
:dec0de92024bee74c75c04bde4c54c097fe68ae8
:66ff6e23f48b16dd1cd292e31a109a8c98ff70f2
:29908fb451905d998ac6acf85714a93966ea47cd
:175d07c8f14b0ec8f4a3b9fde47ef53081bb984d
:4504beabd434c4e335d484b890a6adf1f8d995f6
:591c7ebbd3f4b573e01caf6e462b01a226faa9cf
:88426ee2dde057368a4d4787e70fdeb65ff479cc
:516204cfc31148538d56b21e2f1b945ed50127d4
:73777e822e00ca152ffca281ab0ace0cb498ec48
:4d09d82785dab5f95c01b69bc0785145a5954d30
:d789c08e9d240290a0a39e4654150029e152929f
:fa09160c1b957635a17cb25d26124f8a9c15205c
:98b5af80be37aa2fc16069cc5c7095e0c4f0f844
:1f5869af8077466bc9968d5d1c6a172002e0a1db
:bb24e56b33c8ddbf1a0475454e5afaf578448db3
:10db86ab9481dc0e2bd0f0c4c987e86a8a1d9a8b
:e3f83e6ed76d65ff9d0d4aa5fcc7bf0c6bfaaadd
:5dd234206476b0387cd251598aa72a2c95c763c5
:75907b4ad79e1610574fc3b86ac3f8266835c1a5
:46eb8c83b266e03b4d2d37c5ac56accdee78c113
:e1873a49cf932ac35b921af66ef93b68471f45e3

cgroup:
:9:perf_event:/
:8:blkio:/
:7:net_cls:/
:6:freezer:/
:5:devices:/
:4:memory:/
:3:cpuacct,cpu:/system/libvirtd.service
:2:cpuset:/
:1:name=systemd:/system/libvirtd.service

core_backtrace:
:ed55b3c8f9bc4daa9c7185ea38dc19fe3a503aea 0xaee44 VBoxNsprPR_NewThreadPrivateIndex VBoxXPCOM.so -
:ed55b3c8f9bc4daa9c7185ea38dc19fe3a503aea 0x951e7 nsIThread::GetIThread(PRThread*, VBoxXPCOM.so -
:ed55b3c8f9bc4daa9c7185ea38dc19fe3a503aea 0x95276 nsIThread::GetCurrent(nsIThread**) VBoxXPCOM.so -
:ed55b3c8f9bc4daa9c7185ea38dc19fe3a503aea 0x952ad nsIThread::SetMainThread() VBoxXPCOM.so -
:ed55b3c8f9bc4daa9c7185ea38dc19fe3a503aea 0xc5621 VBoxNsxpNS_InitXPCOM2 VBoxXPCOM.so -
:ed55b3c8f9bc4daa9c7185ea38dc19fe3a503aea 0x90b15 VBoxNsxpNS_GetServiceManager VBoxXPCOM.so -
:27a04c8d90377f0f2de1d1ac476f34511501e92c 0x2f9a - VBoxXPCOMC.so -
:27a04c8d90377f0f2de1d1ac476f34511501e92c 0x29bf - VBoxXPCOMC.so -
:50f16df934d0d9b1235796d014157733fda755c5 0x1c891b - libvirt.so.0 -
:50f16df934d0d9b1235796d014157733fda755c5 0xd752d - libvirt.so.0 -
:50f16df934d0d9b1235796d014157733fda755c5 0xd8fa4 virConnectOpen libvirt.so.0 -
:443520b75b8ac97f1c0525a301b873ced177ea6a 0x3c1cb - [exe] -
:50f16df934d0d9b1235796d014157733fda755c5 0x12df96 - libvirt.so.0 -
:50f16df934d0d9b1235796d014157733fda755c5 0x129b41 - libvirt.so.0 -
:50f16df934d0d9b1235796d014157733fda755c5 0x676de - libvirt.so.0 -
:50f16df934d0d9b1235796d014157733fda755c5 0x67169 - libvirt.so.0 -
:73777e822e00ca152ffca281ab0ace0cb498ec48 0x7d14 start_thread libpthread.so.0 -
:a4ec59d7fc9c453fb4287d7ebc5fcf6579792e65 0xf199d clone libc.so.6 -

environ:
:SYSFONT=True
:PATH=/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin
:LANG=en_US.UTF-8
:KEYTABLE=us
:BOOT_IMAGE=/vmlinuz-3.4.4-5.fc17.x86_64

limits:
:Limit                     Soft Limit           Hard Limit           Units     
:Max cpu time              unlimited            unlimited            seconds   
:Max file size             unlimited            unlimited            bytes     
:Max data size             unlimited            unlimited            bytes     
:Max stack size            8388608              unlimited            bytes     
:Max core file size        0                    unlimited            bytes     
:Max resident set          unlimited            unlimited            bytes     
:Max processes             30942                30942                processes 
:Max open files            1024                 4096                 files     
:Max locked memory         65536                65536                bytes     
:Max address space         unlimited            unlimited            bytes     
:Max file locks            unlimited            unlimited            locks     
:Max pending signals       30942                30942                signals   
:Max msgqueue size         819200               819200               bytes     
:Max nice priority         0                    0                    
:Max realtime priority     0                    0                    
:Max realtime timeout      unlimited            unlimited            us        

open_fds:
:0:/dev/null
:pos:	0
:flags:	0100000
:1:socket:[40812]
:pos:	0
:flags:	02
:2:socket:[40812]
:pos:	0
:flags:	02
:3:/dev/urandom
:pos:	0
:flags:	02100000
:4:/run/libvirtd.pid
:pos:	4
:flags:	02100001
:5:pipe:[40819]
:pos:	0
:flags:	02004000
:6:pipe:[40819]
:pos:	0
:flags:	02004001
:7:pipe:[40820]
:pos:	0
:flags:	02004000
:8:pipe:[40820]
:pos:	0
:flags:	02004001
:9:socket:[40821]
:pos:	0
:flags:	02000002
:10:socket:[40822]
:pos:	0
:flags:	02004002
:11:socket:[40824]
:pos:	0
:flags:	02004002
:12:/proc/mtrr
:pos:	0
:flags:	02100001
:13:socket:[40826]
:pos:	0
:flags:	04002
:14:socket:[42003]
:pos:	0
:flags:	02004002
:15:anon_inode:inotify
:pos:	0
:flags:	00
:16:socket:[41509]
:pos:	0
:flags:	02004002
:17:socket:[41510]
:pos:	0
:flags:	02004002
:18:pipe:[42299]
:pos:	0
:flags:	02004000
:19:pipe:[42299]
:pos:	0
:flags:	02004001
:20:socket:[42300]
:pos:	0
:flags:	02004002
:21:pipe:[42302]
:pos:	0
:flags:	02004000
:22:pipe:[42302]
:pos:	0
:flags:	02004001
:23:/usr/lib/virtualbox/components
:pos:	0
:flags:	02304000
Comment 1 Cristian Ciupitu 2012-07-13 10:00:26 EDT
Created attachment 598077 [details]
File: dso_list
Comment 2 Cristian Ciupitu 2012-07-13 10:00:29 EDT
Created attachment 598078 [details]
File: var_log_messages
Comment 3 Cristian Ciupitu 2012-07-13 10:00:40 EDT
Created attachment 598079 [details]
File: maps
Comment 4 Cristian Ciupitu 2012-07-13 10:00:43 EDT
Created attachment 598080 [details]
File: backtrace
Comment 5 Cristian Ciupitu 2012-07-13 10:05:19 EDT
It crashed when I started the libvirtd service.

I have both KVM/qemu and VirtualBox (from Oracle's yum repository) on my machine, but I don't use libvirtd with VirtualBox, at least not explicitly. Though `virsh uri` gives me vbox:///system, so I have to specify the qemu URI in an environment variable.

I have qemu-kvm-1.0-17.fc17.x86_64.rpm and VirtualBox-4.1-4.1.18_78361_fedora17-1.x86_64.rpm.
Comment 6 Cole Robinson 2012-10-27 13:24:39 EDT
Moving to upstream tracker since vbox usage isn't very relevant for fedora. If a patch appears upstream though I'll be happy to add it to the next 0.9.11 maint release
Comment 7 Cole Robinson 2016-03-23 18:21:53 EDT
Given the age of this bug, closing as DEFERRED. If this is still reproducible with modern libvirt and virtualbox, please reopen

Note You need to log in before you can comment on or make changes to this bug.