Bug 840086 - candlepin: do not bundle dependencies in candlepin rpms [satellite-6]
candlepin: do not bundle dependencies in candlepin rpms [satellite-6]
Status: CLOSED CURRENTRELEASE
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Subscription Management (Show other bugs)
6.0.1
Unspecified Unspecified
unspecified Severity high (vote)
: Unspecified
: --
Assigned To: Jesus M. Rodriguez
Katello QA List
: Triaged
: 837655 (view as bug list)
Depends On: 837652
Blocks: 837655 869077
  Show dependency treegraph
 
Reported: 2012-07-13 12:10 EDT by Mike McCune
Modified: 2014-09-18 11:31 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 837652
Environment:
Last Closed: 2014-09-11 08:21:34 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Comment 1 Kurt Seifried 2012-10-04 13:18:24 EDT
The candlepin-tomcat6 rpm includes JAR files, but does not use them (it requires system tomcat). The source rpm (candlepin) includes a buildfile script that pulls in all the JARs. I spoke with bkearney, he said that tidying up the buildfile so the jars are not pulled in at all is scheduled for CloudForms 2.0 release (it's not a huge priority as the JARs are not used, so it is just tidying up at this point). For Sthe Sunscription Account Manager (SAM) this should be fixed in SAM 1.3 which is tied to RHEL 7.
Comment 7 Kurt Seifried 2012-12-14 13:51:23 EST
*** Bug 837655 has been marked as a duplicate of this bug. ***
Comment 8 Mike McCune 2013-08-16 14:13:21 EDT
getting rid of 6.0.0 version since that doesn't exist
Comment 11 Bryan Kearney 2014-09-11 08:21:34 EDT
This was delivered with Satellite 6.0 which was released on 10 September 2014.

Note You need to log in before you can comment on or make changes to this bug.