Bug 840092 - Segfaults while updating to selinux-policy-targeted-3.11.0-8.fc18
Segfaults while updating to selinux-policy-targeted-3.11.0-8.fc18
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: selinux-policy-targeted (Show other bugs)
rawhide
x86_64 Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: Miroslav Grepl
Ben Levenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-07-13 13:03 EDT by Michal Jaegermann
Modified: 2012-07-19 13:48 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-07-19 13:48:48 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michal Jaegermann 2012-07-13 13:03:23 EDT
Description of problem:

An update of selinux-policy-targeted results in the following:

  Updating   : selinux-policy-targeted-3.11.0-8.fc18.noarch           1086/2414 
/var/tmp/rpm-tmp.a2JFud: line 10: 10005 Segmentation fault      (core dumped) /usr/sbin/semodule -n -s targeted -r xfs kudzu kerneloops execmem openoffice ada tzdata hal hotplug howl java mono moilscanner gamin audio_entropy audioentropy iscsid polkit_auth polkit rtkit_daemon ModemManager telepathysofiasip ethereal passanger qpidd pyzor razor 2> /dev/null
/var/tmp/rpm-tmp.a2JFud: line 10: 10014 Segmentation fault      (core dumped) /usr/sbin/semodule -B -n -s targeted

That indeed resulted in dumping two cores in /, each 314M in size.
gdb reports "Program terminated with signal 11, Segmentation fault".
abrtd did not catch anything

Version-Release number of selected component (if applicable):
selinux-policy-targeted-3.11.0-8.fc18.noarch

How reproducible:

Running '/usr/sbin/semodule -B -n -s targeted' appears to result in segfaults.


Additional info:
Selinux is actually disabled on a test system.

That seems to be different than bug 810413.
Comment 1 Daniel Walsh 2012-07-19 13:48:48 EDT
I believe this is fixed in the current toolchain.

Note You need to log in before you can comment on or make changes to this bug.