Bug 840115 - guestfish touch problem - case_sensitive_path API expects the file to exist
guestfish touch problem - case_sensitive_path API expects the file to exist
Status: CLOSED UPSTREAM
Product: Virtualization Tools
Classification: Community
Component: libguestfs (Show other bugs)
unspecified
x86_64 Linux
unspecified Severity low
: ---
: ---
Assigned To: Richard W.M. Jones
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-07-13 14:58 EDT by Nux
Modified: 2012-07-17 10:19 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-07-17 10:19:49 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Nux 2012-07-13 14:58:51 EDT
Description of problem:
guestfish will not "touch" new files invoked as "win:c:\blah"
it will fail with error:
guestfish --rw -i -d windowstest touch 'win:c:\blah'
libguestfs: error: case_sensitive_path: blah no file or directory found with this name

At the same time the following works just fine:
guestfish --rw -i -d windowstest touch /blah

Version-Release number of selected component (if applicable):
libguestfs 1.16.19

How reproducible:
always

Steps to Reproduce:
1. invoke guestfish touch with 'win:c:\blah'

  
Actual results:
libguestfs: error: case_sensitive_path: blah no file or directory found with this name

Expected results:
the creation of a file in c:\blah

Additional info:
Comment 1 Richard W.M. Jones 2012-07-16 05:43:38 EDT
Yes, this should really "just work".  Since we probably
cannot change the case-sensitive-path API, we may need to
work around it in guestfish.

Note You need to log in before you can comment on or make changes to this bug.