Bug 840130 - webadmin: CanDoAction failure for HotPlugUnplugVmNic not propagated to UI
webadmin: CanDoAction failure for HotPlugUnplugVmNic not propagated to UI
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine-webadmin-portal (Show other bugs)
3.1.0
Unspecified Unspecified
medium Severity medium
: ---
: ---
Assigned To: Greg Padgett
Martin Pavlik
network
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-07-13 15:34 EDT by Greg Padgett
Modified: 2016-06-12 19:16 EDT (History)
10 users (show)

See Also:
Fixed In Version: si12
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-12-04 15:06:15 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Network
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Greg Padgett 2012-07-13 15:34:33 EDT
Description of problem:
When CanDoAction of HotPlugUnplugVmNic fails, the error appears in the backend log but there is no evidence in the UI that the "Deactivate" button was clicked--no error dialog appears.

Version-Release number of selected component (if applicable):
SI9 (also applicable on latest upstream code)

How reproducible:
AFAIK always, on FF 13 (F17), Chrome 19 (F17), and IE 7 (Win7).

Steps to Reproduce:
1. Create VM of type Windows XP with at least 1 NIC
2. Select VM, Attempt to deactivate NIC
3.
  
Actual results:
Nothing happens

Expected results:
Error dialog should appear

Additional info:
Discovered while fixing bz 826462; cannot reproduce that error nor validate fix without the error dialog.
Comment 3 Greg Padgett 2012-07-17 09:35:25 EDT
Commit (upstream): e7771716f6dcd2056a661e961a5b18d8cc6c35df

http://gerrit.ovirt.org/gitweb?p=ovirt-engine.git;a=commit;h=e7771716f6dcd2056a661e961a5b18d8cc6c35df
Comment 4 Greg Padgett 2012-07-22 22:00:53 EDT
Link to patch, for reference: http://gerrit.ovirt.org/6250
Comment 5 Martin Pavlik 2012-07-27 08:56:41 EDT
Hi Greg,

I was trying to verify this bug, but I suspect that rhevm behavior was changed as described in 

https://bugzilla.redhat.com/show_bug.cgi?id=828854#c16

so there would be no error meessage any more. Can you confirm it please?
Comment 6 Martin Pavlik 2012-07-30 09:42:08 EDT
Verified as per https://bugzilla.redhat.com/show_bug.cgi?id=826462#c6

Note You need to log in before you can comment on or make changes to this bug.