Bug 84015 - up2date reports installed rpm for xpdf still needed
up2date reports installed rpm for xpdf still needed
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: rhn-applet (Show other bugs)
8.0
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Adrian Likins
Fanny Augustin
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-02-10 18:51 EST by Ben Sanchez
Modified: 2007-04-18 12:50 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-09-23 18:19:07 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ben Sanchez 2003-02-10 18:51:07 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2) Gecko/20021202

Description of problem:
I ran up2date today and updated several packages (all available since the new
kernal mod last week, which I ran by itself, then picked up the other rpm that
was available then, and the rest that came out since, including xpdf-1.01-10:1.

up2date and it's circular icon in the bottom right corner of my gnome bar on the
gnome desktop are telling me I need to update xpdf to the version I just installed.

When I run up2date, it checks the web, and finds I am up2date, as it should.
Problem is, the indication on the desktop does not go away, and if I click on
it, I still see up2date's window telling me I need to update the xpdf package.

This seems to be a bug, and I did not see any other reports of it on the web,
not exactly this bug anyway. downloading the new rpm from your support eratta
site and doing 

rpm -Fvh xpdf-1.01-10.i386.rpm

as root produces no output, just returns, so I guess that means it thinks there
was no refresh to do?

Thanks,
Ben Sanchez

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.run up2date, repeat until a package you just updated still says it needs update
2.done, this indication will not change,at least not over the course of a few hours.
3.
    

Additional info:
Comment 1 Daniel Veillard 2003-02-11 04:25:38 EST
So far I have never seen this behaviour.
The steps indocated are not reproctible,
the applet does cache the content list of the rpm database
internally but also check the timestamp of the database
on the filesystem to invalidate the cache. The only way
I could imagine the behaviour indicated to happen is if the
time on the machine went backward at some point or if the
/var partition don't indicate modification time for the
database.
What happen if you restart the applet ?
Daniel 
Comment 2 Todd Warner 2005-09-23 18:19:07 EDT
no reponse in over 2 years. Closing.

Note You need to log in before you can comment on or make changes to this bug.