Bug 840154 - SELinux is preventing /usr/bin/systemd-tmpfiles from 'unlink' accesses on the file xauth-0-_0.
SELinux is preventing /usr/bin/systemd-tmpfiles from 'unlink' accesses on the...
Status: CLOSED CANTFIX
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
17
i686 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Miroslav Grepl
Fedora Extras Quality Assurance
abrt_hash:f31e2eb877dae1e21b9576f17b2...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-07-13 18:25 EDT by Dartagnan
Modified: 2012-07-16 17:11 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-07-16 17:11:12 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dartagnan 2012-07-13 18:25:45 EDT
libreport version: 2.0.10
executable:     /usr/bin/python2.7
hashmarkername: setroubleshoot
kernel:         3.4.4-5.fc17.i686
time:           Fri 13 Jul 2012 09:43:54 AM MDT

description:
:SELinux is preventing /usr/bin/systemd-tmpfiles from 'unlink' accesses on the file xauth-0-_0.
:
:*****  Plugin catchall_labels (83.8 confidence) suggests  ********************
:
:If you want to allow systemd-tmpfiles to have unlink access on the xauth-0-_0 file
:Then you need to change the label on xauth-0-_0
:Do
:# semanage fcontext -a -t FILE_TYPE 'xauth-0-_0'
:where FILE_TYPE is one of the following: sandbox_file_t, faillog_t, httpd_cache_t, etc_runtime_t, user_home_type, rpm_var_lib_t, httpd_sys_rw_content_t, admin_home_t, var_auth_t, file_t, man_t, tmp_t, config_home_t, non_security_file_type, lockfile, pidfile, tmpfile. 
:Then execute: 
:restorecon -v 'xauth-0-_0'
:
:
:*****  Plugin catchall (17.1 confidence) suggests  ***************************
:
:If you believe that systemd-tmpfiles should be allowed unlink access on the xauth-0-_0 file by default.
:Then you should report this as a bug.
:You can generate a local policy module to allow this access.
:Do
:allow this access for now by executing:
:# grep systemd-tmpfile /var/log/audit/audit.log | audit2allow -M mypol
:# semodule -i mypol.pp
:
:Additional Information:
:Source Context                system_u:system_r:systemd_tmpfiles_t:s0
:Target Context                system_u:object_r:unlabeled_t:s0
:Target Objects                xauth-0-_0 [ file ]
:Source                        systemd-tmpfile
:Source Path                   /usr/bin/systemd-tmpfiles
:Port                          <Unknown>
:Host                          (removed)
:Source RPM Packages           systemd-44-17.fc17.i686
:Target RPM Packages           
:Policy RPM                    selinux-policy-3.10.0-137.fc17.noarch
:Selinux Enabled               True
:Policy Type                   targeted
:Enforcing Mode                Enforcing
:Host Name                     (removed)
:Platform                      Linux (removed) 3.4.4-5.fc17.i686 #1 SMP Thu Jul 5
:                              20:17:29 UTC 2012 i686 i686
:Alert Count                   2
:First Seen                    Fri 13 Jul 2012 06:46:27 AM MDT
:Last Seen                     Fri 13 Jul 2012 08:49:34 AM MDT
:Local ID                      54040d78-b553-4095-8c8f-57647819efbf
:
:Raw Audit Messages
:type=AVC msg=audit(1342190974.964:83): avc:  denied  { unlink } for  pid=3296 comm="systemd-tmpfile" name="xauth-0-_0" dev="dm-1" ino=268185 scontext=system_u:system_r:systemd_tmpfiles_t:s0 tcontext=system_u:object_r:unlabeled_t:s0 tclass=file
:
:
:type=SYSCALL msg=audit(1342190974.964:83): arch=i386 syscall=unlinkat success=no exit=EACCES a0=5 a1=9514433 a2=0 a3=bfa5efe0 items=0 ppid=1 pid=3296 auid=4294967295 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0 tty=(none) ses=4294967295 comm=systemd-tmpfile exe=/usr/bin/systemd-tmpfiles subj=system_u:system_r:systemd_tmpfiles_t:s0 key=(null)
:
:Hash: systemd-tmpfile,systemd_tmpfiles_t,unlabeled_t,file,unlink
:
:audit2allowunable to open /sys/fs/selinux/policy:  Permission denied
:
:
:audit2allow -Runable to open /sys/fs/selinux/policy:  Permission denied
:
:
Comment 1 Daniel Walsh 2012-07-16 17:11:12 EDT
Looks like something strange happened and during an upgrade.

find /tmp -context "*:unlabeled_t:*" -delete

Should clean this up.

Note You need to log in before you can comment on or make changes to this bug.