Bug 840159 - kdumpctl takes over .ssh/config file unnecessarily
kdumpctl takes over .ssh/config file unnecessarily
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: kexec-tools (Show other bugs)
18
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Baoquan He
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-07-13 19:25 EDT by joshua
Modified: 2013-06-07 23:24 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-06-07 23:24:37 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description joshua 2012-07-13 19:25:03 EDT
Description of problem:

"kdumpctl propigate" needs to stop being so greedy with its ssh configuation.  I realize that it needs to get kdump to ssh out using ~/.ssh/kdump_id_rsa ... but why must it make the root user on the machine *always* use the kdump_id_rsa identity?

It creates a ~/.ssh/config file with these contents:
IdentityFile ~/.ssh/kdump_id_rsa


Why?  Couldn't kdump, when scp'ing out post-crash, simply use the scp command-line options thus:
scp -i ~/.ssh/kdump_id_rsa

??

Surely this would better than taking over all ssh/scp activity with the kdump key identity!  It should also be simpler to configure:  mkdumpctl need not modify or create ssh config files at all.


Version-Release number of selected component (if applicable):

kexec-tools-2.0.3-38.fc17.x86_64
Comment 1 joshua 2012-10-12 00:27:17 EDT
Please consider this for F18
Comment 2 Fedora Admin XMLRPC Client 2013-02-25 03:06:07 EST
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.
Comment 3 WANG Chao 2013-06-05 05:09:04 EDT
Hi, joshua, I don't see this happens. kdump never creates .ssh/config.
Do you still have this problem?
Comment 4 joshua 2013-06-05 13:15:16 EDT
Yes... it still happens.  "kdumpctl propagate" *always* creates /root/.ssh/config
Comment 5 Baoquan He 2013-06-05 21:47:10 EDT
I tried "kdumpctl propagate" in f19, and didn't find /root/.ssh/config either.

Hi Joshua, which version are you using?
Comment 6 joshua 2013-06-05 22:58:20 EDT
This is mentioned in the opening details of the case
Comment 7 Baoquan He 2013-06-05 23:10:49 EDT
you can check /sbin/kdumpctl, function propagate_ssh_key used to generate/deliver key to ssh server. seems no "/root/.ssh/config" is created, unless ssh utilities did this.
Comment 8 WANG Chao 2013-06-05 23:29:56 EDT
It seems we can't really reproduce this issue. So it'd better if you could at least set -x in /usr/bin/kdumpctl and show us how it goes there.
Comment 9 joshua 2013-06-07 21:49:26 EDT
It seems like kexec-tools-2.0.3-64.fc18.2 doesn't capture the /root/.ssh/config file anymore.  Looking through the package changelog I don't see any mention of this change.
Comment 10 Baoquan He 2013-06-07 23:24:37 EDT
Test was taken on f19, still can't reproduce it. 

Anyway, I will close this bug, it can be reopened if it happens later.

Baoquan
Thanks

Note You need to log in before you can comment on or make changes to this bug.