Bug 840176 - Bond support not working
Bond support not working
Status: CLOSED DUPLICATE of bug 558983
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: NetworkManager (Show other bugs)
6.3
x86_64 Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Dan Williams
Desktop QE
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-07-14 01:23 EDT by German Pulido
Modified: 2012-07-18 12:51 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-07-17 04:57:16 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description German Pulido 2012-07-14 01:23:04 EDT
Description of problem:
The Bond/VLAN support in NetworkManager does not seem to work yet. Here is the relevant information:

Version-Release number of selected component (if applicable):
[gpulido@megatron ~]$ rpm -qa | grep NetworkManager
NetworkManager-gnome-0.8.1-33.el6.x86_64
NetworkManager-glib-0.8.1-33.el6.x86_64
NetworkManager-0.8.1-33.el6.x86_64
 [gpulido@megatron ~]$ cat /etc/sysconfig/network
NETWORKING=yes
HOSTNAME=megatron.cybertron.local
NM_BOND_VLAN_ENABLED=yes
[gpulido@megatron ~]$ cat /etc/sysconfig/network-scripts/ifcfg-br0 
DEVICE=br0
NM_CONTROLLED="yes"
ONBOOT=yes
TYPE=Bridge
BOOTPROTO=none
IPADDR=192.168.0.10
PREFIX=24
GATEWAY=192.168.0.1
DNS1=8.8.8.8
DNS2=8.8.4.4
DEFROUTE=yes
IPV4_FAILURE_FATAL=yes
IPV6INIT=no
NAME="System br0"
DELAY=0
[gpulido@megatron ~]$ cat /etc/sysconfig/network-scripts/ifcfg-eth0 
DEVICE=eth0
NM_CONTROLLED="yes"
ONBOOT=yes
HWADDR=00:1A:A0:61:7F:B5
TYPE=Ethernet
DEFROUTE=yes
IPV4_FAILURE_FATAL=yes
IPV6INIT=no
NAME="System eth0"
BRIDGE=br0
[gpulido@megatron ~]$ 



How reproducible:
Always

Steps to Reproduce:
1. Stop the network service (service netowrk stop)
2. Start NetworkManager (service NetworkManager start)
  
Actual results:
Networking is lost. /etc/resolv.conf is rewritten with no DNS servers on it
If I enable Networkmanager on boot and disable network service, after a reboot the machine has no networking at all.

/var/log/messages shows this: (which seems a contradiction):
...
Jul 13 23:48:52 megatron NetworkManager[2963]: <info> Bonding/VLAN support enabled
Jul 13 23:48:52 megatron NetworkManager[2963]:    ifcfg-rh: Acquired D-Bus service com.redhat.ifcfgrh1
Jul 13 23:48:52 megatron NetworkManager[2963]: <info> Loaded plugin ifcfg-rh: (c) 2007 - 2008 Red Hat, Inc.  To report bugs please use the NetworkManager mailing list.
Jul 13 23:48:52 megatron NetworkManager[2963]:    ifcfg-rh: parsing /etc/sysconfig/network-scripts/ifcfg-lo ...
Jul 13 23:48:52 megatron NetworkManager[2963]:    ifcfg-rh: parsing /etc/sysconfig/network-scripts/ifcfg-br0 ...
Jul 13 23:48:52 megatron NetworkManager[2963]:    ifcfg-rh:     error: Bridge connections are not yet supported
Jul 13 23:48:52 megatron NetworkManager[2963]:    ifcfg-rh: parsing /etc/sysconfig/network-scripts/ifcfg-eth0 ...
Jul 13 23:48:52 megatron NetworkManager[2963]:    ifcfg-rh:     read connection 'System eth0'
Jul 13 23:48:52 megatron NetworkManager[2963]:    ifcfg-rh: Ignoring connection 'System eth0' and its device due to NM_CONTROLLED/BRIDGE/VLAN.
Jul 13 23:48:52 megatron NetworkManager[2963]: <info> WiFi enabled by radio killswitch; enabled by state file
...

if "Bonding/VLAN support enabled", why does it say "error: Bridge connections are not yet supported"?

Expected results:
NetworkManager parses the ifcfg files and enables the eth0 interface with its bond, just like network service does.

Additional info:
This is on a fully patches CentOS 6.3 server.
Comment 2 Jirka Klimes 2012-07-17 04:57:16 EDT
Bridging and bonding are not the same thing:
http://www.linuxfoundation.org/collaborate/workgroups/networking/bridge
http://www.linuxfoundation.org/collaborate/workgroups/networking/bonding

RHEL now supports interface bonding, bridges have not been implemented yet. Bridge support will appear upstream soon, though.

*** This bug has been marked as a duplicate of bug 558983 ***
Comment 3 German Pulido 2012-07-18 12:51:58 EDT
Thanks for the explanation. Silly me :).

Note You need to log in before you can comment on or make changes to this bug.