Bug 840257 - ivtv driver : kernel emits "IRQ 18 might be stuck. Polling" in /var/log/messages
ivtv driver : kernel emits "IRQ 18 might be stuck. Polling" in /var/log/mess...
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
16
x86_64 Linux
unspecified Severity high
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-07-14 23:07 EDT by Bob Arendt
Modified: 2012-07-14 23:19 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-07-14 23:19:55 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bob Arendt 2012-07-14 23:07:00 EDT
Description of problem:
Updating to new F16 kernel kernel-3.4.4-4.fc16.x86_64 resulted in the following log messages:

Jul 15 03:22:06 opus mythbackend[1584]: 2012-07-15 03:22:06.761974 N  AutoExpire: CalcParams(): Max required Free Space: 3.0 GB w/freq: 15 min
Jul 15 03:22:06 opus mythbackend[1584]: 2012-07-15 03:22:06.761987 I  Tuning recording: Bleach: channel 1049 on cardid 1, sourceid 1
Jul 15 03:22:06 opus lircd-0.9.0[1310]: accepted new client on /var/run/lirc/lircd
Jul 15 03:22:07 opus lircd-0.9.0[1310]: removed client
Jul 15 03:22:07 opus lircd-0.9.0[1310]: accepted new client on /var/run/lirc/lircd
Jul 15 03:22:07 opus lircd-0.9.0[1310]: removed client
Jul 15 03:22:07 opus mythbackend[1584]: 2012-07-15 03:22:07.411183 I  Updating status for Bleach on cardid 1 (Tuning => Recording)
Jul 15 03:22:07 opus mythbackend[1584]: 2012-07-15 03:22:07.474043 I  TVRec(1): rec->GetPathname(): '/data/mythtv/1049_20120715032200.mpg'
Jul 15 03:22:08 opus kernel: [   21.148043] IRQ 18 might be stuck.  Polling
Jul 14 19:22:07 opus chronyd[1250]: System clock was stepped by -28801.316 seconds
Jul 14 19:22:22 opus kernel: [   36.252623] IRQ 18 might be stuck.  Polling
Jul 14 19:22:33 opus kernel: [   47.440053] IRQ 18 might be stuck.  Polling

.. and the IRQ message is periodically output, and gdm never comes up.  Re-booted to kernel-3.4.2-1.fc16.x86_64 and all is well.

Looking at /proc/interrupts
# cat /proc/interrupts
           CPU0       CPU1       CPU2       CPU3       
  0:        126          0          0          0   IO-APIC-edge      timer
  1:          1          1          0          1   IO-APIC-edge      i8042
  8:          0          1          0          0   IO-APIC-edge      rtc0
  9:          0          0          0          0   IO-APIC-fasteoi   acpi
 12:          3          0          1          0   IO-APIC-edge      i8042
 16:        759        795          4        647   IO-APIC-fasteoi   ehci_hcd:usb1, nvidia
 17:        196         34          9          9   IO-APIC-fasteoi   snd_hda_intel
 18:          1      54485      26152      62750   IO-APIC-fasteoi   ivtv0
 23:         58         12          7         21   IO-APIC-fasteoi   ehci_hcd:usb2
 40:          0          0          0          0   PCI-MSI-edge      PCIe PME
 41:          0          0          0          0   PCI-MSI-edge      PCIe PME
 42:          0          0          0          0   PCI-MSI-edge      PCIe PME
 43:          0          0          0          0   PCI-MSI-edge      PCIe PME
 44:          0          0          0          0   PCI-MSI-edge      PCIe PME
 45:          0          0          0          0   PCI-MSI-edge      PCIe PME
 46:       5950       1930       1009       2014   PCI-MSI-edge      ahci
 47:      10529       2171       3371       2581   PCI-MSI-edge      ahci
 48:          0          0          0          0   PCI-MSI-edge      xhci_hcd
 49:      10144       9160       6118      11742   PCI-MSI-edge      xhci_hcd
 50:          0          0          0          0   PCI-MSI-edge      xhci_hcd
 51:          0          0          0          0   PCI-MSI-edge      xhci_hcd
 52:          0          0          0          0   PCI-MSI-edge      xhci_hcd
 53:          0          0          0          0   PCI-MSI-edge      xhci_hcd
 55:        370        153        196        209   PCI-MSI-edge      snd_hda_intel
 56:       5087       1577       1188        906   PCI-MSI-edge      p4p1-0
 57:       1020        179        156        160   PCI-MSI-edge      p4p1-1
 58:       1972        537        334        262   PCI-MSI-edge      p4p1-2
 59:       1800        469        329        325   PCI-MSI-edge      p4p1-3
 60:       2075        546        469        377   PCI-MSI-edge      p4p1-4
NMI:         87         81         82         94   Non-maskable interrupts
LOC:     182885     167101     202733     171246   Local timer interrupts
SPU:          0          0          0          0   Spurious interrupts
PMI:         87         81         82         94   Performance monitoring interrupts
IWI:          0          0          0          0   IRQ work interrupts
RTR:          3          0          0          0   APIC ICR read retries
RES:      39287       4181       2582       1659   Rescheduling interrupts
CAL:      15429      15940      15394      10471   Function call interrupts
TLB:      10639      13891      12633      12339   TLB shootdowns
TRM:          0          0          0          0   Thermal event interrupts
THR:          0          0          0          0   Threshold APIC interrupts
MCE:          0          0          0          0   Machine check exceptions
MCP:          8          8          8          8   Machine check polls
ERR:          0
MIS:          0

irq 18 is associated with the ivtv driver.  And the message started up just after mythbackend started the tuner on /dev/video (using the ivtv driver).  It looks like some errors might have been introduced by recent updates in the the ivtv driver and friends (using  a Hauppauge 150 card) 

# lsmod |grep ivtv | grep -v i2c_
ivtv                  162325  0 
cx2341x                27668  1 ivtv
v4l2_common            15133  5 wm8775,tuner,cx25840,ivtv,cx2341x
videodev              106839  6 wm8775,tuner,cx25840,ivtv,cx2341x,v4l2_common
tveeprom               21141  1 ivtv



How reproducible:
Always

Steps to Reproduce:
1. Boot kernel-3.4.4-4.fc16.x86_64
 
Actual results:
"IRQ 18 might be stuck.  Polling" on the consoles and in /var/log/messages.
Machine does not boot to gdm.

Expected results:
Clean boot, working ivtv driver.
Comment 1 Bob Arendt 2012-07-14 23:19:55 EDT
I jumped the gun, I can't get it to repeat now after re-seating cards.  Sorry for the noise.

Note You need to log in before you can comment on or make changes to this bug.