Bug 840265 - errors when opening multiple reports
errors when opening multiple reports
Status: CLOSED CANTFIX
Product: Bugzilla
Classification: Community
Component: Query/Bug List (Show other bugs)
4.2
Unspecified Unspecified
unspecified Severity unspecified (vote)
: ---
: ---
Assigned To: Simon Green
tools-bugs
: Regression, Reopened
: 830545 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-07-15 02:55 EDT by Itamar Heim
Modified: 2014-10-12 18:48 EDT (History)
3 users (show)

See Also:
Fixed In Version: 4.2.4-6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-07-24 21:47:13 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Itamar Heim 2012-07-15 02:55:45 EDT
Description of problem:
I've been doing a weekly report collection for last 3 years.
my problem started since the upgrade (previous one, not the one last weekend - from 3.x to 4.x).
when opening multiple reports in tabs in parallel i get two types of errors.
refreshing the browser on each tab solves the problem.

(error suggest to report to bugzilla-owner, which i did the week post the upgrade in an email dating june 4th 2012)

How reproducible:
allways

Steps to Reproduce:
1. open a set of tabs (20-25) with a report in each
  
Actual results:
some tabs fail with[1]
some tabs fail with [2]

Expected results:
all reports work, like they did prior to upgrade

[1] The page isn't redirecting properly. Firefox has detected that the server is redirecting the request for this address in a way that will never complete.
This problem can sometimes be caused by disabling or refusing to accept
cookies.

[2] Software error:

DBD::mysql::db do failed: Deadlock found when trying to get lock; try restarting transaction [for Statement "DELETE FROM profile_search WHERE user_id = ? AND id <= ?"] at Bugzilla/Search/Recent.pm line 72
	Bugzilla::Search::Recent::create('Bugzilla::Search::Recent', 'HASH(0x75a2760)') called at Bugzilla/Search/Recent.pm line 81
	Bugzilla::Search::Recent::create_placeholder('Bugzilla::Search::Recent') called at Bugzilla/CGI.pm line 449
	Bugzilla::CGI::redirect_search_url('Bugzilla::CGI=HASH(0x6450810)') called at /var/www/html/bugzilla/buglist.cgi line 86

For help, please send mail to the webmaster (bugzilla-owner@redhat.com), giving this error message and the time and date of the error.
Comment 1 Simon Green 2012-09-11 02:13:38 EDT
Can you give us some examples of the report URLs you are trying to access?

And confirm that you are still having issues?
Comment 2 Itamar Heim 2012-09-11 02:52:35 EDT
this is 100% reproducible for me still.
this started only after the upgrade to 4.2 bugzilla btw.
i have a folder of saved queries in firefox.
i click 'open all in tabs'.
this only happens for normal searches. reports don't have this issue.
I'll send you the list of searches i use
Comment 4 Simon Green 2012-10-08 23:53:20 EDT
(In reply to comment #0)
> refreshing the browser on each tab solves the problem.

Based on this statement, I'm closing the bug. It is clear there is no fault with the Bugzilla code itself.

  -- simon
Comment 6 Simon Green 2012-10-09 01:38:32 EDT
*** Bug 830545 has been marked as a duplicate of this bug. ***
Comment 7 Itamar Heim 2012-10-09 15:56:15 EDT
(In reply to comment #4)
> (In reply to comment #0)
> > refreshing the browser on each tab solves the problem.
> 
> Based on this statement, I'm closing the bug. It is clear there is no fault
> with the Bugzilla code itself.
> 
>   -- simon

why is opening the queries in paralell, which worked 100% OK before bugzila upgrade is not an issue with bugzilla?
it is clear the problem is not in the browser as well.
Comment 8 Simon Green 2012-10-09 18:44:20 EDT
> why is opening the queries in paralell, which worked 100% OK before bugzila
> upgrade is not an issue with bugzilla?
> it is clear the problem is not in the browser as well.

Because when you reload the page, it works fine. That means the problem isn't with the Bugzilla code. I also agree it's not a browser problem. See comment #5 for my recommended next step.

  -- simon
Comment 9 Simon Green 2012-10-09 23:44:10 EDT
After further consideration of this issue, we believe we have found the cause of the deadlocking, and it is a change that was introduced in the upgrade to 4.2. We will fix this in the next release.

This won't fix the redirection never completes issue however. I've never seen that happening before. If that happens after we make this change, can you please open a new bug for it, and if it applies to the same URLs all the time.

  -- simon
Comment 14 Itamar Heim 2013-04-11 15:19:24 EDT
getting this again last few weeks in a similar scenario to comment 3:
bugzilla version 4.2.5-8.3

Software error:

DBD::mysql::db do failed: Deadlock found when trying to get lock; try restarting transaction [for Statement "DELETE FROM profile_search WHERE user_id = ? AND id <= ?"] at Bugzilla/Search/Recent.pm line 72
	Bugzilla::Search::Recent::create('Bugzilla::Search::Recent', 'HASH(0x1b82c190)') called at Bugzilla/Search/Recent.pm line 81
	Bugzilla::Search::Recent::create_placeholder('Bugzilla::Search::Recent') called at Bugzilla/CGI.pm line 467
	Bugzilla::CGI::redirect_search_url('Bugzilla::CGI=HASH(0x1a5a7b10)') called at /var/www/html/bugzilla/buglist.cgi line 85

For help, please send mail to the webmaster (bugzilla-owner@redhat.com), giving this error message and the time and date of the error.
Comment 15 Simon Green 2013-04-11 19:20:10 EDT
From what I can see, this should still work for up to 50 queries at the same time. The code has not changed.
Comment 17 Jason McDonald 2013-07-22 01:08:18 EDT
Frankly, I'm not convinced that running 20+ queries in parallel should be a supported use-case for RH Bugzilla.  Given the current system architecture (effectively 32 cores for running parallel database queries) and the well-publicized performance issues the system is experiencing, this behaviour strikes me as being rather inconsiderate to other users.

This kind of heavy-weight report generation would be better directed to an offline data-warehousing system such as teiid.  The queries above do not appear to change any data and therefore do not need to use the production Bugzilla system.  

Until further notice, please either run these queries in series rather than in parallel, or use an offline system (e.g. teiid) instead of the production system.
Comment 18 Jason McDonald 2013-07-24 21:47:13 EDT
Closing, as per my previous comment.

Note You need to log in before you can comment on or make changes to this bug.