Bug 840276 - qperf: static_rate isn't showed in the output because ParName doesn't have entry for it
qperf: static_rate isn't showed in the output because ParName doesn't have en...
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: qperf (Show other bugs)
5.9
All Linux
unspecified Severity medium
: rc
: ---
Assigned To: Doug Ledford
Infiniband QE
:
Depends On: 840275
Blocks:
  Show dependency treegraph
 
Reported: 2012-07-15 05:47 EDT by hali
Modified: 2013-03-07 19:09 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 840275
Environment:
Last Closed: 2012-08-24 16:40:42 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description hali 2012-07-15 05:47:17 EDT
+++ This bug was initially created as a clone of Bug #840275 +++

Description of problem:
When using -v option, qperf will provide more information on the output. Like this:
[root@rdma2 ~]# qperf --access_recv 0 --msg_size 2K --cq_poll 0 --time 2 --cpu_affinity 0 --mtu_size 256 -v 172.31.0.3 ud_bw
ud_bw:
    send_bw        =   869 MB/sec
    recv_bw        =     0 bytes/sec
    msg_size       =     2 KiB (2,048)
    mtu_size       =   256 bytes
    time           =     2 sec
    send_cost      =   225 ms/GB
    loc_cpus_used  =  19.5 % cpus

But it's not true for the --static_rate option, see
[root@rdma2 ~]# qperf --access_recv 0 --msg_size 2K --cq_poll 0 --time 2 --cpu_affinity 0 --mtu_size 256 --static_rate 2.5 -v 172.31.0.3 ud_bw
ud_bw:
    send_bw        =  867 MB/sec
    recv_bw        =    0 bytes/sec
    msg_size       =    2 KiB (2,048)
    mtu_size       =  256 bytes
    time           =    2 sec
    send_cost      =  242 ms/GB
    loc_cpus_used  =   21 % cpus

I checked the codes and found the reason. The variable ParName doesn't have entry for static_rate. I think it's a miss.

Version-Release number of selected component (if applicable):
qperf-0.4.6-6.el6.x86_64

How reproducible:
100%

Expected results:
--static_rate value should be also displayed when used with -v option.

Additional info:
PAR_NAME ParName[] ={
    { "access_recv",    L_ACCESS_RECV,    R_ACCESS_RECV   },
    { "affinity",       L_AFFINITY,       R_AFFINITY      },
    { "alt_port",       L_ALT_PORT,       R_ALT_PORT      },
    { "flip",           L_FLIP,           R_FLIP          },
    { "id",             L_ID,             R_ID            },
    { "msg_size",       L_MSG_SIZE,       R_MSG_SIZE      },
    { "mtu_size",       L_MTU_SIZE,       R_MTU_SIZE      },
    { "no_msgs",        L_NO_MSGS,        R_NO_MSGS       },
    { "poll_mode",      L_POLL_MODE,      R_POLL_MODE     },
    { "port",           L_PORT,           R_PORT          },
    { "rd_atomic",      L_RD_ATOMIC,      R_RD_ATOMIC     },
    { "service_level",  L_SL,             R_SL            },
    { "sock_buf_size",  L_SOCK_BUF_SIZE,  R_SOCK_BUF_SIZE },
    { "src_path_bits",  L_SRC_PATH_BITS,  R_SRC_PATH_BITS },
    { "time",           L_TIME,           R_TIME          },
    { "timeout",        L_TIMEOUT,        R_TIMEOUT       },
    { "use_cm",         L_USE_CM,         R_USE_CM        },
};
As you can see, not entry for static_rate.
Comment 1 RHEL Product and Program Management 2012-08-07 04:48:56 EDT
This request was evaluated by Red Hat Product Management for inclusion
in a Red Hat Enterprise Linux release.  Product Management has
requested further review of this request by Red Hat Engineering, for
potential inclusion in a Red Hat Enterprise Linux release for currently
deployed products.  This request is not yet committed for inclusion in
a release.
Comment 2 Doug Ledford 2012-08-24 16:40:42 EDT
This is a debatable issue.  The ParName list is obviously incomplete.  Upstream selected those items they felt should be in the list, so adding an item is really a matter of convincing upstream that it should be in there.  I'm closing this out as WontFix as we don't really care enough to push upstream to release a new release with this change this late in the game.

Note You need to log in before you can comment on or make changes to this bug.