Bug 840303 - Sometimes cannot type in konsole if multiple konsole windows opened.
Sometimes cannot type in konsole if multiple konsole windows opened.
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: kdebase (Show other bugs)
All Linux
medium Severity medium
: rc
: ---
Assigned To: Ngo Than
Desktop QE
Depends On:
  Show dependency treegraph
Reported: 2012-07-15 11:56 EDT by Gris Ge
Modified: 2012-09-03 10:05 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2012-09-03 09:59:40 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Gris Ge 2012-07-15 11:56:13 EDT
Description of problem:
After upgrade to RHEL 6.3. Chances are: I cannot type in konsole if multiple konsole windows. Only I seek out the first opened konsole windows and press "Ctrl-C", then problem gone.

I have never got this problem before RHEL 6.3. (I use 6.1 and 6.2 since they release or even before release)

The only changes made to RHEL 6.3 konsole is Bug #631481

Version-Release number of selected component (if applicable):
kdebase-4.3.4-5.el6.x86_64 (RHEL 6.3 GA)

How reproducible:
1 out 100

Steps to Reproduce:
1. Try to open 3+ konsole windows.
2. Type in each konsole windows and use "alt+tab" to switch windows.
Actual results:
cannot type, all types goes to first opened windows.

Expected results:
no such issue.

Additional info:
I will try to downgrade to confirm this regression. Will update tag and title later once regression confirmed. Request blocker for RHEL 6.4, please reject if no customer face or other concern.
Comment 1 Gris Ge 2012-07-16 01:06:28 EDT
Still got problem even downgrade kdebase to kdebase-4.3.4-4.el6.x86_64.

Will investigate more.
Comment 2 Ngo Than 2012-07-16 06:03:31 EDT
i tried to reproduce this issue with the above steps, but it's not reproduceable on my test machine with 6.3. I don't think the fix for #631481 can cause the regression.

Could you please try with a fresh new user?  thanks
Comment 3 Gris Ge 2012-08-28 08:28:29 EDT
Ngo Than,

I also hit this problem even in KDE 4.8.3 (other distribution), so I assume this is upstream bug.

In my current RHEL 6.3, I can easily trigger this issue by press 'alt+t' (my shortcut for konsole) 4+ times.

Will try the new user thing and let you know.

Comment 4 Gris Ge 2012-08-28 21:09:20 EDT
Ngo Than,

I tried with new user. Cannot hit this issue.

My konsole is configured to start up with black full screen windows:

1. No app broader.
2. No KDE panel.
3. No menu of konsole.
4. No tab of konsole.
5. Customized both konsole colour theme and kde color theme.

I tried item 1) and 2) in new user, cannot hit the issue.

Will try the rest once my work shift done.

Thanks for your patience.
Comment 5 Gris Ge 2012-09-03 09:59:40 EDT
Ngo Than,

I found the root cause of it:

I have fcitx (A Chinese input method) version 4.x installed and having these env:

After fcitx start. Konsole will stuck when multiple windows started.

I will close this bug as not a bug and investigate on fcitx.
Thanks for keeping with me.
Comment 6 Gris Ge 2012-09-03 10:01:35 EDT

Will fix this problem but lose input method support in qt3 software.
Comment 7 Gris Ge 2012-09-03 10:05:31 EDT
Just heads up: qt3 QT_IM_MODULE=fcitx support fixed by upgrade fcitx to 4.2.5.

Note You need to log in before you can comment on or make changes to this bug.