This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 840433 - [abrt] ibus-1.4.99.20120428-2.fc17: __GI_raise: Process /usr/libexec/ibus-ui-gtk3 was killed by signal 6 (SIGABRT)
[abrt] ibus-1.4.99.20120428-2.fc17: __GI_raise: Process /usr/libexec/ibus-ui-...
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: ibus (Show other bugs)
17
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: fujiwara
Fedora Extras Quality Assurance
abrt_hash:a3d20d62ab9ddae60e30e47f088...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-07-16 07:31 EDT by Scott Tsai
Modified: 2012-08-15 06:12 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-08-15 06:12:45 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
File: backtrace (23.57 KB, text/plain)
2012-07-16 07:31 EDT, Scott Tsai
no flags Details
File: maps (36.89 KB, text/plain)
2012-07-16 07:31 EDT, Scott Tsai
no flags Details
File: dso_list (7.13 KB, text/plain)
2012-07-16 07:31 EDT, Scott Tsai
no flags Details

  None (edit)
Description Scott Tsai 2012-07-16 07:31:02 EDT
libreport version: 2.0.10
abrt_version:   2.0.10
backtrace_rating: 4
cmdline:        /usr/libexec/ibus-ui-gtk3
crash_function: __GI_raise
executable:     /usr/libexec/ibus-ui-gtk3
kernel:         3.4.4-5.fc17.x86_64
pid:            1874
pwd:            /tmp
time:           Mon 16 Jul 2012 07:16:00 PM CST
uid:            1000
username:       scottt
var_log_messages: Jul 16 19:16:00 5220m abrt[11992]: Saved core dump of pid 1874 (/usr/libexec/ibus-ui-gtk3) to /var/spool/abrt/ccpp-2012-07-16-19:16:00-1874 (24715264 bytes)
xsession_errors: 

backtrace:      Text file, 24136 bytes
dso_list:       Text file, 7298 bytes
maps:           Text file, 37775 bytes

build_ids:
:8b33feb27b2125997520fdd21c90c42a65e438f1
:faca16f15d87b83d2947a386e319b02f724dcbb5
:54a5cc118d928470da13565de8592b664a9868e0
:9d49f2f604fdc7a787f63c16cc08353956f2fd41
:4c9c864a7c7b7ed702088955821d58137803462d
:b6d75088f555d197be1476cb1c580640826ae029
:b8bfc491895389962d926fdc99cbfbac571f2cf0
:5b4f3d35b4612be98f2bbb635b3eabf0ee7e437d
:c2f5ae8bd64df0fc996cf96b95525a8f8fb28fd2
:a8efbe1d263ad42afae74bc027eee88eaa754f55
:f534feded388130df4a9e789eec1e38c320bc55b
:79aee4375d1f48c032b56a6a0a9c15b3773b030e
:b277af36744327e3d58eae76bcdaadcca71a28c6
:a553a7e9625a224a8f39286909adc17787ad51bd
:271a2d91cc3308783ff4a7ab45049f31aa42d8b7
:0e1267a4d81de05f053eeed7f2f61fb46cda9e7c
:d804f8ee47797da9213a92f00cd095ecada8d79f
:710b0d8cc36603d66327090defd37c99daa38f28
:0a688bf9160e6e3a2a8f41967f3c75094bca08a7
:617e70e4105dfaa44b8d1f53b914e37eb5886ceb
:234d4eb1aa690c38533ef82f517b390255d3bc4d
:31243d0d107bba586a96433c76c87a26db1e826c
:e2f8ba3db2c86456528fe1f09829c62263d0fdee
:87712be648d2d43ea4cd002fe7a859df636f1e13
:8d098f6bb781c1632177cd60d738076b83e0c0d3
:1ece4eb2f0a1af4529ae9f5bd8b2104601164a51
:3d60535f052babb998bae4807bc992c5d15df5c4
:253afe744466fe7580bbb6040de6183dba9e2b02
:e48810bd9d6ad9358cc2aff3d0c8532485f59b90
:f549a5d6de3e683d432a578595485e0051b7bc15
:f64b7319b84d426ed547084bdb2577f4f596c18f
:99c23b21038c62b0628b93610fb54c5900c40ffd
:dec0de92024bee74c75c04bde4c54c097fe68ae8
:67792c148d2b8f13f6732c9367e926c26d7376c5
:63651cdc0224824a9c9324c77c3b5887378e871d
:71a00c23bc57c7b963209fc43159ed6bfd0995dc
:c4ec0971b2dcee71aaf8374975474054245fea00
:7eb10e81cf49360e21889663eb0672cdfa03bf12
:e3354959e32e471066df83c93f98f33e75198697
:822e9b3523e8312240f41a25722d539bc77ed436
:73777e822e00ca152ffca281ab0ace0cb498ec48
:404cbecd24d186758ed474b345313da28b2990fa
:396fda5abd0de2132396c4a3e94f7a7173bc26e7
:3f0991d9a4679b6bdd8a78ab2d05ecf4cc995651
:a4ec59d7fc9c453fb4287d7ebc5fcf6579792e65
:9dc7d977acebd2e8abf2d55bf2738ea2d89f7480
:6ffd106c467fc2bbbe04c9509d66f7d97d2a751f
:ce246b3297de0d233ac2c5f9e50061e2b13a330c
:6e5d5649c704cd3a34cf145ccd2d08994f1e83ff
:4d09d82785dab5f95c01b69bc0785145a5954d30
:7c35310fc506498c612d5d982ab03becc4b4817c
:48c0fe9b8cd26b4d0b5bf1de0bc76da565bd7d27
:508cf66f72e70054a41215f80ed2385c6bb80030
:e5945f7dae3fc83ad499da1ea5a464bfa0e68202
:c24fd7404668fdbb57aec685a0f63cdd8a289d29
:839c8e3a55bd7f61afdcfebeae52f9dadc3a69fb
:4b044fe80e4c1b69986abc4b160c303048005d4e
:6c08d8c9f6358200131cda5c9b563545d5c806ba
:c61e487cc8906c4f1bd85b39a4d751b414e423a0
:5dd234206476b0387cd251598aa72a2c95c763c5
:3d451d3b4b5df9b97e8a7129d3acf953eb9c3d93
:0eeac854ab0b56d18d126ca7056136b4e63abed7
:8f7c190397d7c1f617e66f18f759714662b60367
:1a0c09f270adf8398df4362ce0acfafc1f970982
:a5cf7008c28585406297cf76ce11e2e554e5a7b4
:5bf8427ddeff24a2bd36962f68e6af6ffe14970f
:1b7abd5c8129b91c0ca4f0f0812e61660236fd38
:247132297f287226a24c12e683292f5c94013066
:5350b5972464f66f404861dc50225a114a2a5e7e

cgroup:
:9:perf_event:/
:8:blkio:/
:7:net_cls:/
:6:freezer:/
:5:devices:/
:4:memory:/
:3:cpuacct,cpu:/
:2:cpuset:/
:1:name=systemd:/user/scottt/2

core_backtrace:
:a4ec59d7fc9c453fb4287d7ebc5fcf6579792e65 0x35965 __GI_raise libc.so.6 -
:a4ec59d7fc9c453fb4287d7ebc5fcf6579792e65 0x37118 __GI_abort libc.so.6 -
:e5945f7dae3fc83ad499da1ea5a464bfa0e68202 0x68867 g_assertion_message libglib-2.0.so.0 -
:e5945f7dae3fc83ad499da1ea5a464bfa0e68202 0x68d84 g_assertion_message_expr libglib-2.0.so.0 -
:71a00c23bc57c7b963209fc43159ed6bfd0995dc 0x16e3b switcher_run [exe] -
:71a00c23bc57c7b963209fc43159ed6bfd0995dc 0x12c37 panel_handle_engine_switch [exe] -

environ:
:SHELL=/bin/bash
:DBUS_STARTER_ADDRESS=unix:abstract=/tmp/dbus-YVkBQbWVnr,guid=d046faf70929b62db928310100000031
:XDG_SESSION_COOKIE=24990a7dcebf36938cb84a9900000005-1342156538.54379-1681281053
:XDG_RUNTIME_DIR=/run/user/scottt
:DISPLAY=:0
:DESKTOP_SESSION=gnome
:WINDOWPATH=1
:PATH=/usr/local/bin:/usr/bin:/bin
:GDMSESSION=gnome
:XDG_VTNR=1
:USERNAME=scottt
:XDG_SESSION_ID=2
:DBUS_SESSION_BUS_ADDRESS=unix:abstract=/tmp/dbus-YVkBQbWVnr,guid=d046faf70929b62db928310100000031
:XDG_SEAT=seat0
:XAUTHORITY=/var/run/gdm/auth-for-scottt-34YkEU/database
:USER=scottt
:DBUS_STARTER_BUS_TYPE=session
:GNOME_KEYRING_PID=1254
:SHLVL=1
:PWD=/home/scottt
:GNOME_KEYRING_CONTROL=/run/user/scottt/keyring-iN1osp
:LANG=en_US.UTF-8
:_=/usr/bin/dbus-launch
:LOGNAME=scottt
:HOME=/home/scottt
:LC_CTYPE=en_US.UTF-8
:GTK_IM_MODULE=ibus
:QT_IM_MODULE=xim
:XMODIFIERS=@im=ibus

limits:
:Limit                     Soft Limit           Hard Limit           Units     
:Max cpu time              unlimited            unlimited            seconds   
:Max file size             unlimited            unlimited            bytes     
:Max data size             unlimited            unlimited            bytes     
:Max stack size            8388608              unlimited            bytes     
:Max core file size        0                    unlimited            bytes     
:Max resident set          unlimited            unlimited            bytes     
:Max processes             1024                 61966                processes 
:Max open files            1024                 4096                 files     
:Max locked memory         65536                65536                bytes     
:Max address space         unlimited            unlimited            bytes     
:Max file locks            unlimited            unlimited            locks     
:Max pending signals       61966                61966                signals   
:Max msgqueue size         819200               819200               bytes     
:Max nice priority         0                    0                    
:Max realtime priority     0                    0                    
:Max realtime timeout      unlimited            unlimited            us        

open_fds:
:0:/dev/null
:pos:	0
:flags:	0100000
:1:/dev/null
:pos:	0
:flags:	0100001
:2:/dev/null
:pos:	0
:flags:	0100001
:3:socket:[26644]
:pos:	0
:flags:	02004002
:4:anon_inode:[eventfd]
:pos:	0
:flags:	02004002
:5:socket:[26649]
:pos:	0
:flags:	02004002
:6:socket:[26653]
:pos:	0
:flags:	02004002
:7:anon_inode:[eventfd]
:pos:	0
:flags:	02004002
:8:anon_inode:inotify
:pos:	0
:flags:	02004000
:9:anon_inode:[eventfd]
:pos:	0
:flags:	02004002
:10:anon_inode:[eventfd]
:pos:	0
:flags:	02004002
:11:socket:[24203]
:pos:	0
:flags:	02004002

smolt_data:
:
:
:General
:=================================
:UUID: 7ba1c065-054d-43b7-9546-c5d6405b8e86
:OS: Fedora release 17 (Beefy Miracle)
:Default run level: Unknown
:Language: en_US.UTF-8
:Platform: x86_64
:BogoMIPS: 5333.41
:CPU Vendor: GenuineIntel
:CPU Model: Intel(R) Core(TM) i5 CPU       M 560  @ 2.67GHz
:CPU Stepping: 5
:CPU Family: 6
:CPU Model Num: 37
:Number of CPUs: 4
:CPU Speed: 2667
:System Memory: 7778
:System Swap: 8191
:Vendor: Hewlett-Packard
:System: HP ProBook 5220m 
:Form factor: Notebook
:Kernel: 3.4.4-5.fc17.x86_64
:SELinux Enabled: 1
:SELinux Policy: targeted
:SELinux Enforce: Enforcing
:MythTV Remote: Unknown
:MythTV Role: Unknown
:MythTV Theme: Unknown
:MythTV Plugin: 
:MythTV Tuner: -1
:
:
:Devices
:=================================
:(32902:11539:32902:32902) pci, None, HOST/PCI, Core Processor Reserved
:(4332:33128:4156:5181) pci, r8169, ETHERNET, RTL8111/8168B PCI Express Gigabit Ethernet controller
:(32902:11521:32902:32902) pci, None, HOST/PCI, Core Processor QuickPath Architecture System Address Decoder
:(32902:11537:32902:32902) pci, None, HOST/PCI, Core Processor QPI Physical 0
:(32902:11538:32902:32902) pci, None, HOST/PCI, Core Processor Reserved
:(5348:18215:4156:5212) pci, bcma-pci-bridge, NETWORK, BCM4313 802.11b/g/n Wireless LAN Controller
:(32902:70:4156:5181) pci, i915, VIDEO, Core Processor Integrated Graphics Controller
:(32902:15176:4156:5181) pci, pcieport, PCI/PCI, 5 Series/3400 Series Chipset PCI Express Root Port 4
:(32902:15170:4156:5181) pci, pcieport, PCI/PCI, 5 Series/3400 Series Chipset PCI Express Root Port 1
:(32902:15115:4156:5181) pci, None, PCI/ISA, Mobile 5 Series Chipset LPC Interface Controller
:(32902:15154:4156:5181) pci, intel ips, NONE, 5 Series/3400 Series Chipset Thermal Subsystem
:(32902:15190:4156:5181) pci, snd_hda_intel, MULTIMEDIA, 5 Series/3400 Series Chipset High Definition Audio
:(32902:11536:32902:32902) pci, None, HOST/PCI, Core Processor QPI Link 0
:(32902:9288:4156:5181) pci, None, PCI/PCI, 82801 Mobile PCI Bridge
:(32902:11362:32902:32902) pci, None, HOST/PCI, Core Processor QuickPath Architecture Generic Non-core Registers
:(32902:15151:4156:5181) pci, ahci, STORAGE, 5 Series/3400 Series Chipset 6 port SATA AHCI Controller
:(32902:15164:4156:5181) pci, ehci_hcd, USB, 5 Series/3400 Series Chipset USB2 Enhanced Host Controller
:(32902:15156:4156:5181) pci, ehci_hcd, USB, 5 Series/3400 Series Chipset USB2 Enhanced Host Controller
:(32902:68:4156:5181) pci, agpgart-intel, HOST/PCI, Core Processor DRAM Controller
:(32902:15204:4156:5181) pci, None, SIMPLE, 5 Series/3400 Series Chipset HECI Controller
:(32902:15180:4156:5181) pci, pcieport, PCI/PCI, 5 Series/3400 Series Chipset PCI Express Root Port 6
:
:
:Filesystem Information
:=================================
:device mtpt type bsize frsize blocks bfree bavail file ffree favail
:-------------------------------------------------------------------
:/dev/sda4 / ext4 4096 4096 70040037 9974977 9274086 17530880 15471601 15471601
:/dev/sda2 /boot ext4 4096 4096 1045492 915944 863516 262144 261854 261854
:
Comment 1 Scott Tsai 2012-07-16 07:31:07 EDT
Created attachment 598424 [details]
File: backtrace
Comment 2 Scott Tsai 2012-07-16 07:31:09 EDT
Created attachment 598425 [details]
File: maps
Comment 3 Scott Tsai 2012-07-16 07:31:11 EDT
Created attachment 598426 [details]
File: dso_list
Comment 4 fujiwara 2012-07-23 22:50:11 EDT
I cannot reproduce the failure of g_assert (_tmp0_ == NULL).
Are you still able to reproduce your problem?

(In reply to comment #1)
> Created attachment 598424 [details]
> File: backtrace

Thread 1 (Thread 0x7fd540254980 (LWP 1874)):
#0  0x00000039a6035965 in __GI_raise (sig=sig@entry=6) at ../nptl/sysdeps/unix/sysv/linux/raise.c:64
        resultvar = 0
        pid = 1874
        selftid = 1874
#1  0x00000039a6037118 in __GI_abort () at abort.c:91
        save_stage = 2
        act = {__sigaction_handler = {sa_handler = 0x4, sa_sigaction = 0x4}, sa_mask = {__val = {140735995810896, 0, 43950864, 0, 247661384383, 75, 7061644218565275795, 5, 21474836528, 43950864, 0, 0, 43950864, 247664337504, 75, 4313329}}, sa_flags = 5, sa_restorer = 0x2770030}
        sigs = {__val = {32, 0 <repeats 15 times>}}
#2  0x00000039a9c68867 in g_assertion_message (domain=domain@entry=0x41a77d "IBUS", file=file@entry=0x41d0f1 "switcher.c", line=line@entry=313, func=func@entry=0x41d1a0 "switcher_run", message=<optimized out>) at gtestutils.c:1861
        lstr = "313\000\377\177\000\000`\224\t\247\377\177\000\000\000\000\000\000\000\000\000\000\342\320A\000\000\000\000"
        s = 0x29ea310 ""
#3  0x00000039a9c68d84 in g_assertion_message_expr (domain=domain@entry=0x41a77d "IBUS", file=file@entry=0x41d0f1 "switcher.c", line=line@entry=313, func=func@entry=0x41d1a0 "switcher_run", expr=expr@entry=0x41d0e2 "_tmp0_ == NULL") at gtestutils.c:1872
        s = <optimized out>
#4  0x0000000000416e3b in switcher_run (self=0x2770030 [Switcher], event=event@entry=0x2719540, engines=<optimized out>, engines_length1=2, index=1, keybindings=0x26e7760 = {...}) at switcher.c:313
Comment 5 fujiwara 2012-08-15 06:12:45 EDT
If you still see the same error, please comment it here.

Note You need to log in before you can comment on or make changes to this bug.