Bug 840443 - [RHEVM] [backend] [Template] there is no message in GUI if user tries to give NIC name which is already used
[RHEVM] [backend] [Template] there is no message in GUI if user tries to give...
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine-webadmin-portal (Show other bugs)
3.1.0
x86_64 Linux
unspecified Severity low
: ---
: ---
Assigned To: Einav Cohen
yeylon@redhat.com
network
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-07-16 07:57 EDT by Martin Pavlik
Modified: 2016-04-18 03:11 EDT (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-07-17 03:18:20 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Network
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Martin Pavlik 2012-07-16 07:57:17 EDT
Description of problem:
There is no message in GUI if user tries to give NIC name which is already used.

Version-Release number of selected component (if applicable):
oVirt Engine Version: '3.1.0-6.el6ev' 

How reproducible:
100%

Steps to Reproduce:
1. Create template
2. Add 2 NICs to the template
3. Edit nic2 and try to rename it to nic1
  
Actual results:
NIC is not renamed with no message in GUI

Expected results:
NIC is not renamed, user is notified why it was not renamed

Additional info:
Following WARN is generated in engine.log if user tries to give NIC name which is already used.

2012-07-16 13:53:53,948 WARN  [org.ovirt.engine.core.bll.UpdateVmTemplateInterfaceCommand] (ajp-/0.0.0.0:8009-7) CanDoAction of action UpdateVmTemplateInterface failed. Reasons:VAR__ACTION__UPDATE,VAR__TYPE__INTERFACE,NETWORK_INTERFACE_NAME_ALREADY_IN_USE
Comment 1 Martin Pavlik 2012-07-17 03:18:20 EDT
This problem was caused by firefox browser, after clearing the cache problem dissapeared.

Note You need to log in before you can comment on or make changes to this bug.