Bug 840510 - JS error when clicking install/update/remove buttons of system group
JS error when clicking install/update/remove buttons of system group
Status: CLOSED CURRENTRELEASE
Product: Red Hat Satellite 6
Classification: Red Hat
Component: WebUI (Show other bugs)
6.0.1
Unspecified Unspecified
unspecified Severity high (vote)
: Unspecified
: --
Assigned To: Brad Buckingham
Og Maciel
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-07-16 10:05 EDT by Hayk Hovsepyan
Modified: 2014-09-18 12:42 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-12-13 14:49:43 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Hayk Hovsepyan 2012-07-16 10:05:54 EDT
Description of problem:
When you want to install/update/remove some packages or package groups from system groups in Katello UI by clicking on that buttons, JS errors are shown in console, and buttons are not working.

Version-Release number of selected component (if applicable):
m2crypto-0.21.1.pulp-7.el6.x86_64
candlepin-0.5.32-1.el6.noarch
qpid-cpp-client-ssl-0.14-14.el6_2.x86_64
katello-glue-pulp-0.2.44-1.git.100.59c634e.el6.noarch
katello-repos-testing-0.2.4-1.el6.noarch
katello-selinux-0.2.6-1.git.0.c9816da.el6.noarch  
katello-qpid-client-key-pair-1.0-1.noarch
katello-agent-1.0.4-1.git.0.4d2cfb2.el6.noarch
katello-certs-tools-1.1.6-1.git.0.4878f30.el6.noarch
qpid-cpp-server-0.14-14.el6_2.x86_64
katello-glue-foreman-0.2.44-1.git.100.59c634e.el6.noarch
pulp-1.1.11-1.el6.noarch
katello-candlepin-cert-key-pair-1.0-1.noarch
python-oauth2-1.5.170-2.pulp.el6.noarch
pulp-common-1.1.11-1.el6.noarch
qpid-cpp-client-0.14-14.el6_2.x86_64
katello-common-0.2.44-1.git.100.59c634e.el6.noarch
pulp-selinux-server-1.1.11-1.el6.noarch
mod_wsgi-3.3-3.pulp.el6.x86_64
python-qpid-0.14-7.el6_2.noarch
qpid-cpp-server-ssl-0.14-14.el6_2.x86_64
katello-glue-candlepin-0.2.44-1.git.100.59c634e.el6.noarch
katello-repos-0.2.4-1.el6.noarch
katello-0.2.44-1.git.100.59c634e.el6.noarch
katello-configure-0.2.29-1.git.86.36cb627.el6.noarch
candlepin-tomcat6-0.5.32-1.el6.noarch
katello-qpid-broker-key-pair-1.0-1.noarch
katello-cli-common-0.2.42-1.git.90.19980f5.el6.noarch
katello-cli-0.2.42-1.git.90.19980f5.el6.noarch


How reproducible:
always

Steps to Reproduce:
1. Make sure you have created:
    provider
    product
    repo
    environment
    changeset
    template

Repo for example can be created from: http://inecas.fedorapeople.org/fakerepos/zoo3/

2. Sync the repo,.
3. Add repo, packages, package groups to template.
4. Add the product and template to changeset and promote it.
5. Subscribe 3 systems by CLI commands:
    subscription-manager register --username admin --password admin --org $orgname --environment $envname --name $systemname
    get the poolID (Id field of result) from katello by CLI: katello -uadmin -padmin org subscriptions --name $orgname
    subscription-manager subscribe --pool $poolID

6. Create a system group.
7. Add subscribed 3 systems to that system group.

8. Now login to Katello UI, go to System Groups, select just created system group and try to install some package. You will see that nothing happens, and in firebug console JS error is thrown.

Actual results:
Package is not installed, JS error is thrown.

Expected results:
Package should be installed or some notification should be shown.

Additional info:
The same for update/remove package/package group buttons as well.
Comment 1 Brad Buckingham 2012-10-04 14:18:15 EDT
I was unable to reproduce the issue described; however, it looks like it would have been solved by the following commit:

https://github.com/Katello/katello/commit/69463e18c8409289a688c1c32a1f25606b88a85a

Changing BZ state so that it can be verified.
Comment 3 Og Maciel 2012-10-05 11:08:36 EDT
Verified using:

* candlepin-0.7.8-1.el6cf.noarch
* candlepin-selinux-0.7.8-1.el6cf.noarch
* candlepin-tomcat6-0.7.8-1.el6cf.noarch
* katello-1.1.12-12.el6cf.noarch
* katello-all-1.1.12-12.el6cf.noarch
* katello-candlepin-cert-key-pair-1.0-1.noarch
* katello-certs-tools-1.1.8-1.el6cf.noarch
* katello-cli-1.1.8-6.el6cf.noarch
* katello-cli-common-1.1.8-6.el6cf.noarch
* katello-common-1.1.12-12.el6cf.noarch
* katello-configure-1.1.9-6.el6cf.noarch
* katello-glue-candlepin-1.1.12-12.el6cf.noarch
* katello-glue-pulp-1.1.12-12.el6cf.noarch
* katello-qpid-broker-key-pair-1.0-1.noarch
* katello-qpid-client-key-pair-1.0-1.noarch
* katello-selinux-1.1.1-1.el6cf.noarch
* pulp-1.1.12-1.el6cf.noarch
* pulp-common-1.1.12-1.el6cf.noarch
* pulp-selinux-server-1.1.12-1.el6cf.noarch
Comment 5 Mike McCune 2013-08-16 14:18:15 EDT
getting rid of 6.0.0 version since that doesn't exist

Note You need to log in before you can comment on or make changes to this bug.