Bug 840546 - No optical drive found
No optical drive found
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: k3b (Show other bugs)
7.0
Unspecified Unspecified
urgent Severity urgent
: beta
: 7.0
Assigned To: Radek Novacek
Desktop QE
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-07-16 10:55 EDT by Martin
Modified: 2016-11-30 19:30 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-06-13 06:51:37 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Martin 2012-07-16 10:55:34 EDT
Description of problem:
K3b starts with System Configuration Problem dialog:

No optical drive found.
K3b did not find any optical device in your system.

Version-Release number of selected component (if applicable):
k3b-2.0.2-12.el7.x86_64
udisks2-1.97.0-3.el7.x86_64

How reproducible:
always

Steps to Reproduce:
Start K3b
  
Actual results:
drive is not recognized

Expected results:
drive is recognized

Additional info:

k3b(5162)/kdeui (kdelibs): Attempt to use QAction "view_projects" with KXMLGUIFactory! 
k3b(5162)/kdeui (kdelibs): Attempt to use QAction "view_dir_tree" with KXMLGUIFactory! 
k3b(5162)/kdeui (kdelibs): Attempt to use QAction "view_contents" with KXMLGUIFactory! 
k3b(5162)/kdeui (kdelibs): Attempt to use QAction "location_bar" with KXMLGUIFactory! 
k3b(5162) KSambaSharePrivate::findSmbConf: KSambaShare: Could not find smb.conf! 

After media insertion:

MEDIA CHANGED in "/org/freedesktop/UDisks2/block_devices/sr0" ; size is: 2048 

After media removal:

"/org/freedesktop/UDisks2/drives/MATSHITADVD_RAM_UJ8A2_HK49_268806" 's interface "org.freedesktop.UDisks2.Drive" changed props: 
         modified: "Media" : QVariant(QString, "") 
         modified: "MediaAvailable" : QVariant(bool, false) 
         modified: "MediaCompatibility" : QVariant(QStringList, ("optical_cd") ) 
         modified: "Optical" : QVariant(bool, false) 
         modified: "OpticalBlank" : QVariant(bool, false) 
         modified: "OpticalNumSessions" : QVariant(uint, 0) 
         modified: "OpticalNumTracks" : QVariant(uint, 0) 
         modified: "Size" : QVariant(qulonglong, 0) 
         modified: "TimeMediaDetected" : QVariant(qulonglong, 0) 
"/org/freedesktop/UDisks2/block_devices/sr0" 's interface "org.freedesktop.UDisks2.Block" changed props: 
         modified: "Size" : QVariant(qulonglong, 0) 
         modified: "Symlinks" : QVariant(QDBusArgument, ) 
MEDIA CHANGED in "/org/freedesktop/UDisks2/block_devices/sr0" ; size is: 0
Comment 3 Radek Novacek 2012-11-19 10:25:51 EST
Thanks for the bug report, can you please post here the result of following command:

solid-hardware list details
Comment 4 Leslie Satenstein 2012-11-20 20:53:25 EST
K3b Version 2.0.2 Using KDE Development Platform 4.9.3

I am registering this fault here.  My environment is 64bit Fedora 17, 4 gigs memory,

I took a blank DVD from the vendor box, put it into the DVD reader/Writer.  Started K3b. I got the BLACK Screen.  
I waited for K3b to go past it. It would not. I could not kill K3B and I could not log out from Fedora 17.

Without removing the DVD blank I rebooted and after logging in got the same problem.

I noted that I had to reboot to clear the number of processes (as each request generated another k3b process.

After 3 reboots, switched to brasario, which told me that the DVD media was flawed. I replaced DVD media, and burned my image with brasario. 

Without the DVD in the reader I could start K3B and I could also burn another DVD image, as the next DVD from the vendor box was not flawed. 

I could say that K3B locked up the system as I could not logout, and I had to switch to an alternate terminal ctl-alt-f2  login as root in order to force reboot.

My view: K3b needs some additional media checking to insure that an invalidly formatted or defective blank DVD does not force a reboot.
Comment 5 Radek Novacek 2012-11-21 02:22:21 EST
Leslie, this is a separate issue. Please file a new bug for k3b in Fedora for it and attach output of following command there:

pstree -alc $(pidof k3b)
Comment 6 Leslie Satenstein 2012-12-29 12:16:05 EST
I will respond after golive with Fedora 18. Perhaps F18 fixes the problem

Please note. QT is upgraded in F18, and the problem may disappear, (or become worse)
Comment 7 Leslie Satenstein 2013-01-31 13:09:34 EST
Problem solved with Fedora 18
Comment 8 Leslie Satenstein 2013-02-07 19:30:20 EST
Please Close. This was solved for Fedora 18 release.
Comment 9 Radek Novacek 2013-02-08 03:09:42 EST
Leslie, this bug is not reported against Fedora 18, so I'll let it open for now.

Martin, it this bug still present? If so, can you post result of following command:

solid-hardware list details
Comment 10 Leslie Satenstein 2013-02-20 09:33:56 EST
Please close, K3b works with F18
Comment 11 Vladimir Benes 2013-02-20 15:42:23 EST
(In reply to comment #10)
> Please close, K3b works with F18

Leslie, stop removing needinfo or I will make this bug private. This was reported to RHEL7 Alpha, not Fedora 18. Packages may differ in those distributions. 

Thank you!

Martin, could you please verify the current version?
Comment 13 Vera Budikova 2014-02-13 08:08:23 EST
Verification:
Package version: k3b-2.0.2-17.el7.x86_64

Steps:
1. Start K3b
2. Check that drive is recognized

Result:
Drive is recognized
Comment 15 Ludek Smid 2014-06-13 06:51:37 EDT
This request was resolved in Red Hat Enterprise Linux 7.0.

Contact your manager or support representative in case you have further questions about the request.

Note You need to log in before you can comment on or make changes to this bug.