Bug 840578 - mtr fails without nameserver entry in resolv.conf
mtr fails without nameserver entry in resolv.conf
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: mtr (Show other bugs)
6.5
Unspecified Unspecified
high Severity high
: rc
: ---
Assigned To: Michal Sekletar
BaseOS QE - Apps
: EasyFix, Patch
Depends On:
Blocks: 835616
  Show dependency treegraph
 
Reported: 2012-07-16 11:45 EDT by Paul Wouters
Modified: 2014-04-02 06:42 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-03-28 13:43:00 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Paul Wouters 2012-07-16 11:45:24 EDT
Description of problem:
mtr 8.8.8.8 or mtr -n 8.8.8.8 aborts when there is no nameserver entry in resolv.conf

Version-Release number of selected component (if applicable):
0.75-5

How reproducible:
always.

Additional info:

The fedora version 0.82 works fine without nameserver entries in resolv.conf
Comment 2 RHEL Product and Program Management 2012-09-07 01:12:40 EDT
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated
in the current release, Red Hat is unable to address this
request at this time.

Red Hat invites you to ask your support representative to
propose this request, if appropriate, in the next release of
Red Hat Enterprise Linux.
Comment 5 Michal Sekletar 2013-09-16 12:03:28 EDT
Fix from comment #4 should solve the issue. It is also included upstream.
Comment 6 Siddharth Nagar 2014-03-28 13:43:00 EDT
Thank you for submitting this request for inclusion in Red Hat Enterprise Linux. We have no plans to update this package for the foreseeable future.

Note You need to log in before you can comment on or make changes to this bug.