Bug 840590 - fresclam segfault with ipv6 nameserver address in /etc/resolv.conf
fresclam segfault with ipv6 nameserver address in /etc/resolv.conf
Status: CLOSED NOTABUG
Product: Fedora EPEL
Classification: Fedora
Component: clamav (Show other bugs)
el6
Unspecified Linux
unspecified Severity high
: ---
: ---
Assigned To: Steven Pritchard
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-07-16 11:58 EDT by Gabriel VLASIU
Modified: 2012-07-17 04:25 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-07-17 04:25:01 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Gabriel VLASIU 2012-07-16 11:58:35 EDT
# cat /etc/resolv.conf | grep -v ^#
search xxx.net. yyy.net.
nameserver 192.168.1.1
nameserver fc00::1

# freshclam
ClamAV update process started at Mon Jul 16 18:56:16 2012
Segmentation fault

# gdb freshclam
....
(gdb) run
Starting program: /usr/bin/freshclam 
[Thread debugging using libthread_db enabled]
ClamAV update process started at Mon Jul 16 18:52:53 2012

Program received signal SIGSEGV, Segmentation fault.
0x00007ffff78a3596 in __libc_res_nsend (statp=0x7ffff76783a0, buf=0x7fffffffd750 "\211C\001", buflen=40, buf2=0x0, buflen2=0, ans=0x7fffffffd990 "", 
    anssiz=512, ansp=0x0, ansp2=0x0, nansp2=0x0, resplen2=0x0) at res_send.c:445
445                                     memset (mempcpy(EXT(statp).nsaddrs[n],
(gdb) backtrace 
#0  0x00007ffff78a3596 in __libc_res_nsend (statp=0x7ffff76783a0, buf=0x7fffffffd750 "\211C\001", buflen=40, buf2=0x0, buflen2=0, ans=0x7fffffffd990 "", 
    anssiz=512, ansp=0x0, ansp2=0x0, nansp2=0x0, resplen2=0x0) at res_send.c:445
#1  0x00007ffff789f76a in __libc_res_nquery (statp=0x7ffff76783a0, name=0x6261d0 "current.cvd.clamav.net", class=1, type=16, answer=0x7fffffffd990 "", 
    anslen=512, answerp=0x0, answerp2=0x0, nanswerp2=0x0, resplen2=0x0) at res_query.c:225
#2  0x00007ffff789fe4c in __res_nquery (statp=<value optimized out>, name=<value optimized out>, class=<value optimized out>, type=<value optimized out>, 
    answer=<value optimized out>, anslen=<value optimized out>) at res_query.c:318
#3  0x00000000004105ff in dnsquery (domain=0x6261d0 "current.cvd.clamav.net", qtype=16, ttl=0x7fffffffde08) at dns.c:62
#4  0x000000000040f295 in downloadmanager (opts=0x625390, hostname=<value optimized out>, logerr=0) at manager.c:2200
#5  0x00000000004091ec in download (opts=0x625390, cfgfile=0x625450 "/etc/freshclam.conf") at freshclam.c:185
#6  0x0000000000409e86 in main (argc=<value optimized out>, argv=<value optimized out>) at freshclam.c:536
(gdb) 

# cat /etc/resolv.conf | grep -v ^#
search xxx.net. yyy.net.
nameserver 192.168.1.1

# freshclam
ClamAV update process started at Mon Jul 16 18:55:21 2012
main.cvd is up to date (version: 54, sigs: 1044387, f-level: 60, builder: sven)
daily.cld is up to date (version: 15139, sigs: 231408, f-level: 63, builder: jesler)
bytecode.cld is up to date (version: 188, sigs: 38, f-level: 63, builder: neo)


clamav-0.97.5-1.el6.x86_64
CentOS 6.3 / kernel 2.6.32-279.1.1.el6.x86_64
Comment 1 Gabriel VLASIU 2012-07-17 04:25:01 EDT
The bug seems to be in glibc not in freshclam: libresolv dumps core when IPv6 address in resolv.conf ( https://bugzilla.redhat.com/show_bug.cgi?id=835090 ).

Note You need to log in before you can comment on or make changes to this bug.