Bug 840605 - Kernel cannot update due kmod-wl installed component
Kernel cannot update due kmod-wl installed component
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: kmod (Show other bugs)
16
All Linux
unspecified Severity urgent
: ---
: ---
Assigned To: kmod development team
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-07-16 12:59 EDT by fabianoaas
Modified: 2012-07-16 13:31 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-07-16 13:31:56 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description fabianoaas 2012-07-16 12:59:15 EDT
Description of problem:

Cannot update and install new kernel packages due kmod-wl component dependency.


Version-Release number of selected component (if applicable):


How reproducible:

Just set a system packages update and  face this bug.


Steps to Reproduce:
1. yum update
2. OR rpm -ivh "new-kernel"

  
Actual results:

kernel-3.4.4-4.fc16.x86_64.rpm                                                                                                        |  27 MB     00:41     
Executando Verificação da Transação
ERROR with transaction check vs depsolve:
kernel-uname-r = 2.6.40.6-0.fc15.x86_64 is needed by (installed) kmod-wl-2.6.40.6-0.fc15.x86_64-5.60.48.36-2.fc15.9.x86_64
kernel-uname-r = 2.6.41.1-1.fc15.x86_64 is needed by (installed) kmod-wl-2.6.41.1-1.fc15.x86_64-5.100.82.38-1.fc15.2.x86_64
kernel-uname-r = 2.6.41.4-1.fc15.x86_64 is needed by (installed) kmod-wl-2.6.41.4-1.fc15.x86_64-5.100.82.38-1.fc15.4.x86_64
Por favor, relate esse erro em https://bugzilla.redhat.com/enter_bug.cgi?product=Fedora&version=rawhide&component=yum
** Encontrado(s) 3 problema(s) pré-existente(s) do rpmdb, saída do  'yum check' a seguir:
kmod-wl-2.6.40.6-0.fc15.x86_64-5.60.48.36-2.fc15.9.x86_64 tem exigências faltando do kernel-uname-r = ('0', '2.6.40.6', '0.fc15.x86_64')
kmod-wl-2.6.41.1-1.fc15.x86_64-5.100.82.38-1.fc15.2.x86_64 tem exigências faltando do kernel-uname-r = ('0', '2.6.41.1', '1.fc15.x86_64')
kmod-wl-2.6.41.4-1.fc15.x86_64-5.100.82.38-1.fc15.4.x86_64 tem exigências faltando do kernel-uname-r = ('0', '2.6.41.4', '1.fc15.x86_64')


Expected results:

normal update
Comment 1 Josh Boyer 2012-07-16 13:31:56 EDT
This has nothing to do with kmod the package (replacement for module-init-tools).  Kmod in this context is "kernel module package" which Fedora doesn't provide.  As such nothing will be done from a Fedora perspective.  You might want to ask whichever repo you got the kmod-wl package from to look at providing an update.

Thank you for filing a bug report.

Note You need to log in before you can comment on or make changes to this bug.