Bug 840639 - Inconsistent casing of titles
Inconsistent casing of titles
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: Documentation (Show other bugs)
3.1.0
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Stephen Gordon
ecs-bugs
: Documentation
Depends On:
Blocks: 815463
  Show dependency treegraph
 
Reported: 2012-07-16 15:08 EDT by Stephen Gordon
Modified: 2014-03-25 03:09 EDT (History)
5 users (show)

See Also:
Fixed In Version: Red_Hat_Enterprise_Virtualization-Installation_Guide-3.1-Beta-web-en-US-3.1.0-7.el6eng
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-12-04 12:26:21 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Stephen Gordon 2012-07-16 15:08:14 EDT
Description of problem:

As part of the rewrite of the Administration Guide many topics are currently having their titles changed to sentence casing (from title case). This is line with the recently adopted IBM Style Guide although the (brief) title case provision does currently still exist in the ECS Style Guide for now.

Many of these topics are also used in the Installation Guide which, at this point, still largely uses title case. Given this we need to decide whether we wish to:

1) Switch the entire Installation Guide to sentence case, ensuring that existing po files for translation are also renamed to match the update titles.

2) Ignore the issue for now, resulting in mixed casing of titles in this guide. 

Version-Release number of selected component (if applicable):

3.1.0
Comment 1 Stephen Gordon 2012-07-16 15:29:04 EDT
Obviously I've missed "3) change all Admin Guide topics to title-case" because I am not sure how feasible this is given the number of topics involved (at least for the 3.1 betas that are fast approaching).
Comment 2 David Ryan 2012-07-18 01:46:36 EDT
Are you using Skynet/Pressgang CCMS? If so, you could run the script that mcasperson ran when the original ruling was made. We were, up until that point, using sentence case too. Maybe ping Matt and see if that's an option.
Comment 3 Stephen Gordon 2012-07-31 11:04:24 EDT
(In reply to comment #2)
> Are you using Skynet/Pressgang CCMS? If so, you could run the script that
> mcasperson ran when the original ruling was made. We were, up until that
> point, using sentence case too. Maybe ping Matt and see if that's an option.

I think Tim checked in on this and the script only handles updating the fixed URLs once the titles had already been updated, makes sense to me because even in sentence case proper nouns remain capitalized which would make scripting such a change difficult (though I guess still not impossible if you are willing to accept some percentage of mistakes).

From an Installation Guide point of view I have gone with option 2 as the guide is being translated for the beta and had to be delivered as is.
Comment 4 Stephen Gordon 2012-09-06 10:45:37 EDT
Content Specification ID: 8983
Revision: 244600

All part/chapter/section titles should now be in title case.

Note You need to log in before you can comment on or make changes to this bug.