Bug 840644 - [OPTIONS] in Subscription-manager --help not translated
[OPTIONS] in Subscription-manager --help not translated
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: subscription-manager (Show other bugs)
5.9
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Adrian Likins
Entitlement Bugs
: i18n, Translation
Depends On:
Blocks: 771748
  Show dependency treegraph
 
Reported: 2012-07-16 15:32 EDT by Sharath Dwaral
Modified: 2015-03-22 21:14 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-01-07 22:57:18 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Sharath Dwaral 2012-07-16 15:32:07 EDT
Description of problem:
Subscriptions manager --help option; keyword "OPTIONS" in zh_TW locale is not translated

Version-Release number of selected component (if applicable):
# rpm -qa | egrep "subscription-manager|python-rhsm"
subscription-manager-1.0.9-1.git.22.35b5155.el5
python-rhsm-1.0.3-1.git.2.47dc8f4.el5
subscription-manager-migration-data-1.11.2.2-1.git.0.2eea155.el5
subscription-manager-migration-1.0.9-1.git.22.35b5155.el5
subscription-manager-gui-1.0.9-1.git.22.35b5155.el5
subscription-manager-firstboot-1.0.9-1.git.22.35b5155.el5

How reproducible:
Always

Steps to Reproduce:
# LANG=zh_TW.UTF8 subscription-manager clean --help
使用用法:使用方法:subscription-manager clean [OPTIONS]

移除所有本地消耗者與訂閱資料,而不影響伺服器。

options:
  -h, --help  顯示此協助訊息並退出

Actual results:
As shown above

Expected results:
使用用法:使用方法:subscription-manager list [OPTIONS]
[OPTIONS] -> to be translated in native language

Similarly, not translated in Indian Languages
hi_IN
ta_IN
te_IN
kn_IN
bn_IN
pa_IN
mr_IN
ml_IN
gu_IN
Comment 1 RHEL Product and Program Management 2012-07-16 15:53:19 EDT
This request was evaluated by Red Hat Product Management for inclusion
in a Red Hat Enterprise Linux release.  Product Management has
requested further review of this request by Red Hat Engineering, for
potential inclusion in a Red Hat Enterprise Linux release for currently
deployed products.  This request is not yet committed for inclusion in
a release.
Comment 2 Sharath Dwaral 2012-07-16 17:26:25 EDT
Additional information:

# msgunfmt --no-wrap /usr/share/locale/zh_TW/LC_MESSAGES/rhsm.mo -o /usr/share/locale/zh_TW/LC_MESSAGES/rhsm.po
# grep -A 1 options /usr/share/locale/zh_TW/LC_MESSAGES/rhsm.po

msgid "%prog [options]"
msgstr "%prog [options]"

--
msgid "Error: --list should not be used with any other options for setting or removing configurations."
msgstr "錯誤:--list 不應該在設定或移除配置時使用。"

---------------------------------------------------------------

# msgunfmt --no-wrap /usr/share/locale/hi/LC_MESSAGES/rhsm.mo -o /usr/share/locale/hi/LC_MESSAGES/rhsm.po
# grep -A 1 options /usr/share/locale/hi/LC_MESSAGES/rhsm.po
msgid "%prog [options]"
msgstr "%prog [options]"

--
msgid "Error: --list should not be used with any other options for setting or removing configurations."
msgstr "त्रुटि: --list को किसी विकल्प के साथ प्रयोग नहीं किया जाना चाहिए विन्यास के सेटिंग या हटाए जाने के लिए."

----------------------------------------------------------------

# msgunfmt --no-wrap /usr/share/locale/as/LC_MESSAGES/rhsm.mo -o /usr/share/locale/as/LC_MESSAGES/rhsm.po
# grep -A 1 options /usr/share/locale/as/LC_MESSAGES/rhsm.po
msgid "%prog [options]"
msgstr "%prog [বিকল্পসমূহ]"

------------------------------------------------------------------


# msgunfmt --no-wrap /usr/share/locale/ta_IN/LC_MESSAGES/rhsm.mo -o /usr/share/locale/ta_IN/LC_MESSAGES/rhsm.po
# grep -A 1 options /usr/share/locale/ta_IN/LC_MESSAGES/rhsm.po
msgid "%prog [options]"
msgstr "%prog [options]"

--
msgid "Error: --list should not be used with any other options for setting or removing configurations."
msgstr "பிழை: --list ஆனது அமைவிற்கான மற்ற ஏதாவது விருப்பத்துடன் அல்லது கட்டமைப்புகளை நீக்குதல் போன்றவற்றிற்கு பயன்படுத்தப்படாது."

-----------------------------------------------------------------

# msgunfmt --no-wrap /usr/share/locale/te/LC_MESSAGES/rhsm.mo -o /usr/share/locale/te/LC_MESSAGES/rhsm.po
# grep -A 1 options /usr/share/locale/te/LC_MESSAGES/rhsm.po
msgid "%prog [options]"
msgstr "%prog [ఐచ్చికాలు]"

------------------------------------------------------------------

# msgunfmt --no-wrap /usr/share/locale/te/LC_MESSAGES/rhsm.mo -o /usr/share/locale/te/LC_MESSAGES/rhsm.po
# grep -A 1 options /usr/share/locale/kn/LC_MESSAGES/rhsm.po
msgid "%prog [options]"
msgstr "%prog [ಆಯ್ಕೆಗಳು]"

-----------------------------------------------------------------

# msgunfmt --no-wrap /usr/share/locale/bn/LC_MESSAGES/rhsm.mo -o /usr/share/locale/bn/LC_MESSAGES/rhsm.po
# grep -A 1 options /usr/share/locale/bn/LC_MESSAGES/rhsm.po
msgid "%prog [options]"
msgstr "%prog [বিকল্প]"

-----------------------------------------------------------------

# msgunfmt --no-wrap /usr/share/locale/gu/LC_MESSAGES/rhsm.mo -o /usr/share/locale/gu/LC_MESSAGES/rhsm.po
# grep -A 1 options /usr/share/locale/bn/LC_MESSAGES/rhsm.po
msgid "%prog [options]"
msgstr "%prog [বিকল্প]"

-----------------------------------------------------------------

# msgunfmt --no-wrap /usr/share/locale/ml/LC_MESSAGES/rhsm.mo -o /usr/share/locale/ml/LC_MESSAGES/rhsm.po
# grep -A 1 options /usr/share/locale/ml/LC_MESSAGES/rhsm.po
msgid "%prog [options]"
msgstr "%prog [options]"

--
msgid "Error: --list should not be used with any other options for setting or removing configurations."
msgstr "പിശക്: ക്രമീകരണങ്ങള്‍ സജ്ജമാക്കുന്നതിനോ നീക്കം ചെയ്യുന്നതിനോ ഒരു ഐച്ഛികങ്ങള്‍ക്കൊപ്പവും --list ഉപയോഗിയ്ക്കുവാന്‍ പാടില്ല."

----------------------------------------------------------------


# msgunfmt --no-wrap /usr/share/locale/mr/LC_MESSAGES/rhsm.mo -o /usr/share/locale/mr/LC_MESSAGES/rhsm.po
# grep -A 1 options /usr/share/locale/mr/LC_MESSAGES/rhsm.po
msgid "%prog [options]"
msgstr "%prog [पर्याय]"

-------------------------------------------------------------------


As shown in each, the word "options" has been translated atleast once but it does not appear translated in the output of
# LANG=locale_LOCALE.UTF8 subscription-manager [OPTION] --help
Comment 3 Adrian Likins 2012-08-02 13:45:15 EDT
Couple of things here, we have some inconsistency on how we use [OPTIONS] vs
[options].

Both are in the string catalog, but so far, no one has translation [OPTIONS] and
[options] is a mix bag of translated or not. Going on the assumption that the "[options]" are translated as the translators choose, best change might be to
just make sure we use "[options]" everywhere.
Comment 4 Adrian Likins 2012-10-03 13:49:31 EDT
All of the translations have the "OPTIONS" string, and translated as translated see fit, so this can be considered closed.
Comment 5 John Sefler 2012-10-07 16:50:16 EDT
Moving to VERIFIED based on https://bugzilla.redhat.com/show_bug.cgi?id=845304#c5

"[options]" and "[OPTIONS]" are translated (or not) as the translators choose.  Automated tests have now been updated to tolerate either.
Comment 7 errata-xmlrpc 2013-01-07 22:57:18 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-0033.html

Note You need to log in before you can comment on or make changes to this bug.