Bug 840689 - package gui separately
package gui separately
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: gssdp (Show other bugs)
17
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Peter Robinson
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-07-16 19:05 EDT by Simon Peeters
Modified: 2012-07-19 11:52 EDT (History)
2 users (show)

See Also:
Fixed In Version: gssdp-0.12.1-4.fc18
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-07-19 11:52:14 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Simon Peeters 2012-07-16 19:05:42 EDT
it is kind of annoying that one has to install the gssdp gui and all its dependencies (notably gtk2/cairo/pango stuff) if one only needs libgssdp.
Comment 1 Peter Robinson 2012-07-17 06:00:09 EDT
(In reply to comment #0)
> it is kind of annoying that one has to install the gssdp gui and all its
> dependencies (notably gtk2/cairo/pango stuff) if one only needs libgssdp.

certainly happy to do this, up until now I'm not aware of any thing that uses it that doesn't need the rest so that' why I've never bothered. Got any details of such packages?
Comment 2 Simon Peeters 2012-07-18 11:11:52 EDT
(In reply to comment #1)
> (In reply to comment #0)
> > it is kind of annoying that one has to install the gssdp gui and all its
> > dependencies (notably gtk2/cairo/pango stuff) if one only needs libgssdp.
> 
> certainly happy to do this, up until now I'm not aware of any thing that
> uses it that doesn't need the rest so that' why I've never bothered. Got any
> details of such packages?

well, the most important dependency i want to lose is gtk2 since almost all software i use is now using gtk3, but i can imagine software using different toolkits or maybe even headless setups use functions provided by the library. (but i don't really know any examples)
Comment 3 Peter Robinson 2012-07-19 11:52:14 EDT
fixed. utils split out into a gssdp-utils sub package

Note You need to log in before you can comment on or make changes to this bug.