Bug 840715 - fail to install win7 guest with virtio-win-1.5.2 on rhel5.8 host
fail to install win7 guest with virtio-win-1.5.2 on rhel5.8 host
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: virtio-win (Show other bugs)
5.8
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Vadim Rozenfeld
Virtualization Bugs
:
: 849819 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-07-16 23:31 EDT by xu
Modified: 2013-01-09 07:05 EST (History)
13 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-08-15 02:20:33 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
screen-shot got by kvm-autotest about make system partatiom fail (29.86 KB, image/jpeg)
2012-07-16 23:31 EDT, xu
no flags Details

  None (edit)
Description xu 2012-07-16 23:31:27 EDT
Created attachment 598544 [details]
screen-shot got by kvm-autotest about make system partatiom fail

Description of problem:
win7 installer reported create or locate system partation fail when use virtio-win-1.5.2 dirver on rhel5.8 host, see screen shot in attachment;

 


Version-Release number of selected component (if applicable):
virtio-win-1.5.2.iso

How reproducible:


Steps to Reproduce:

1. create 24 image file referece to below cmd:
qemu-img create -f qcow2 /usr/local/staf/test/RHEV/kvm/autotest-devel/client/tests/kvm/images/storage.qcow2 30G'

2. start qemu with below command:
qemu-kvm -name 'vm1' -monitor unix:'/tmp/monitor-humanmonitor1-20120716-103235-1woz',server,nowait -serial unix:'/tmp/serial-20120716-103235-1woz',server,nowait -drive file='/usr/local/staf/test/RHEV/kvm/autotest-devel/client/tests/kvm/images/win7-32-virtio-error.qcow2',if=virtio,media=disk,cache=none,boot=on,snapshot=off,format=qcow2 -drive file='/usr/local/staf/test/RHEV/kvm/autotest-devel/client/tests/kvm/images/storage.qcow2',if=virtio,media=disk,cache=none,boot=off,snapshot=off,format=qcow2 -drive file='/usr/local/staf/test/RHEV/kvm/autotest-devel/client/tests/kvm/images/storage2.qcow2',if=virtio,media=disk,cache=none,boot=off,snapshot=off,format=qcow2 -drive file='/usr/local/staf/test/RHEV/kvm/autotest-devel/client/tests/kvm/images/storage3.qcow2',if=virtio,media=disk,cache=none,boot=off,snapshot=off,format=qcow2 -drive file='/usr/local/staf/test/RHEV/kvm/autotest-devel/client/tests/kvm/images/storage4.qcow2',if=virtio,media=disk,cache=none,boot=off,snapshot=off,format=qcow2 -drive file='/usr/local/staf/test/RHEV/kvm/autotest-devel/client/tests/kvm/images/storage5.qcow2',if=virtio,media=disk,cache=none,boot=off,snapshot=off,format=qcow2 -drive file='/usr/local/staf/test/RHEV/kvm/autotest-devel/client/tests/kvm/images/storage6.qcow2',if=virtio,media=disk,cache=none,boot=off,snapshot=off,format=qcow2 -drive file='/usr/local/staf/test/RHEV/kvm/autotest-devel/client/tests/kvm/images/storage7.qcow2',if=virtio,media=disk,cache=none,boot=off,snapshot=off,format=qcow2 -drive file='/usr/local/staf/test/RHEV/kvm/autotest-devel/client/tests/kvm/images/storage8.qcow2',if=virtio,media=disk,cache=none,boot=off,snapshot=off,format=qcow2 -drive file='/usr/local/staf/test/RHEV/kvm/autotest-devel/client/tests/kvm/images/storage9.qcow2',if=virtio,media=disk,cache=none,boot=off,snapshot=off,format=qcow2 -drive file='/usr/local/staf/test/RHEV/kvm/autotest-devel/client/tests/kvm/images/storage10.qcow2',if=virtio,media=disk,cache=none,boot=off,snapshot=off,format=qcow2 -drive file='/usr/local/staf/test/RHEV/kvm/autotest-devel/client/tests/kvm/images/storage11.qcow2',if=virtio,media=disk,cache=none,boot=off,snapshot=off,format=qcow2 -drive file='/usr/local/staf/test/RHEV/kvm/autotest-devel/client/tests/kvm/images/storage12.qcow2',if=virtio,media=disk,cache=none,boot=off,snapshot=off,format=qcow2 -drive file='/usr/local/staf/test/RHEV/kvm/autotest-devel/client/tests/kvm/images/storage13.qcow2',if=virtio,media=disk,cache=none,boot=off,snapshot=off,format=qcow2 -drive file='/usr/local/staf/test/RHEV/kvm/autotest-devel/client/tests/kvm/images/storage14.qcow2',if=virtio,media=disk,cache=none,boot=off,snapshot=off,format=qcow2 -drive file='/usr/local/staf/test/RHEV/kvm/autotest-devel/client/tests/kvm/images/storage15.qcow2',if=virtio,media=disk,cache=none,boot=off,snapshot=off,format=qcow2 -drive file='/usr/local/staf/test/RHEV/kvm/autotest-devel/client/tests/kvm/images/storage16.qcow2',if=virtio,media=disk,cache=none,boot=off,snapshot=off,format=qcow2 -drive file='/usr/local/staf/test/RHEV/kvm/autotest-devel/client/tests/kvm/images/storage17.qcow2',if=virtio,media=disk,cache=none,boot=off,snapshot=off,format=qcow2 -drive file='/usr/local/staf/test/RHEV/kvm/autotest-devel/client/tests/kvm/images/storage18.qcow2',if=virtio,media=disk,cache=none,boot=off,snapshot=off,format=qcow2 -drive file='/usr/local/staf/test/RHEV/kvm/autotest-devel/client/tests/kvm/images/storage19.qcow2',if=virtio,media=disk,cache=none,boot=off,snapshot=off,format=qcow2 -drive file='/usr/local/staf/test/RHEV/kvm/autotest-devel/client/tests/kvm/images/storage20.qcow2',if=virtio,media=disk,cache=none,boot=off,snapshot=off,format=qcow2 -drive file='/usr/local/staf/test/RHEV/kvm/autotest-devel/client/tests/kvm/images/storage21.qcow2',if=virtio,media=disk,cache=none,boot=off,snapshot=off,format=qcow2 -drive file='/usr/local/staf/test/RHEV/kvm/autotest-devel/client/tests/kvm/images/storage22.qcow2',if=virtio,media=disk,cache=none,boot=off,snapshot=off,format=qcow2 -drive file='/usr/local/staf/test/RHEV/kvm/autotest-devel/client/tests/kvm/images/storage23.qcow2',if=virtio,media=disk,cache=none,boot=off,snapshot=off,format=qcow2 -drive file='/usr/local/staf/test/RHEV/kvm/autotest-devel/client/tests/kvm/images/storage24.qcow2',if=virtio,media=disk,cache=none,boot=off,snapshot=off,format=qcow2 -net nic,vlan=0,model=virtio,macaddr='9a:11:43:00:f0:b5' -net tap,vlan=0,fd=22 -m 2048 -smp 2,cores=1,threads=1,sockets=2 -cpu 'qemu64' -drive file='/usr/local/staf/test/RHEV/kvm/autotest-devel/client/tests/kvm/isos/ISO/Windows7/en_windows_7_ultimate_with_sp1_x86_dvd_619077.iso',media=cdrom -drive file='/usr/local/staf/test/RHEV/kvm/autotest-devel/client/tests/kvm/isos/windows/winutils.iso',media=cdrom -drive file='/usr/local/staf/test/RHEV/kvm/autotest-devel/client/tests/kvm/isos/windows/virtio-win.iso',media=cdrom -soundhw ac97 -fda '/usr/local/staf/test/RHEV/kvm/autotest-devel/client/tests/kvm/images/win7-32/answer.vfd' -redir tcp:5000::10023 -vnc :0 -vga std -rtc-td-hack -M rhel5.6.0 -boot c   -usbdevice tablet

  
Actual results:

fail to create system paration

Expected results:

system install normally

Additional info:
this defeat happend when run "virtio_blk.virtio_net.Win7.32.unattended_install.cdrom.multi_disk_install.aio_threads" test case with kvm-autotest tool;
host kernel version:kernel-2.6.18-322.el5
Comment 1 xu 2012-07-17 01:38:41 EDT
Repeat 4 times just reporduce once;

Thanks,
Xu
Comment 2 Ronen Hod 2012-07-19 03:28:08 EDT
There are 3 related bugs (possibly identical)
Bug 804888, Bug 835023.
These are difficult to debug, because they happen during installation.
We suspect that the drivers are not to blame, because they work well with RHEL6, and/or Raw, and/or aio_threads
Can you please test older versions of RHEL5 to see if the issue is a regression, and when it started. Bisect rhel5.

Thanks, Ronen.
Comment 3 Paolo Bonzini 2012-07-19 03:35:12 EDT
Bug 804888 comment 26 mentions it only happens with aio=native, while this test is for aio=threads?
Comment 4 xu 2012-07-19 04:32:20 EDT
(In reply to comment #3)
> Bug 804888 comment 26 mentions it only happens with aio=native, while this
> test is for aio=threads?

happends with aio=threads when run virtio_blk.virtio_net.Win7.32.unattended_install.cdrom.multi_disk_install.aio_thread test;

Thanks.
Comment 5 RHEL Product and Program Management 2012-07-24 07:58:45 EDT
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated in the
current release, Red Hat is unfortunately unable to address this
request at this time. Red Hat invites you to ask your support
representative to propose this request, if appropriate and relevant,
in the next release of Red Hat Enterprise Linux.
Comment 6 xu 2012-07-25 05:21:04 EDT
(In reply to comment #3)
> Bug 804888 comment 26 mentions it only happens with aio=native, while this
> test is for aio=threads?

Parameter aio=native is support in command line of rhel5 host;

Thanks,
Xu
Comment 7 Suqin Huang 2012-07-25 05:59:56 EDT
(In reply to comment #6)
> (In reply to comment #3)
> > Bug 804888 comment 26 mentions it only happens with aio=native, while this
> > test is for aio=threads?
> 
> Parameter aio=native is support in command line of rhel5 host;
> 
> Thanks,
> Xu

Hi Paolo,
The params aio=native/thread is not supported in rhel5,
as I know, the default for rhel5 kvm is aio=thread.

Comment0 is tested with multi disks, seems the disks is not ordered in windows,
which cause this issue.
Comment 8 Miya Chen 2012-07-25 06:53:43 EDT
Post the same bug here:
Bug 723759 - multi disks indexes in a random order when installing win2008r2
Comment 9 Ronen Hod 2012-08-15 02:20:33 EDT
Regarding bug 835023, bug 840715, and bug 804888

We are late in RHEL5, and we also do not want to put too many resources into RHEL5 bugs, so I am closing these bugs.
- These bugs are difficult to reproduce, both Vadim and Kevin failed to reproduce them, for days.
- These bugs are related to the initial installation, so no real harm done.
- Reproducing it requires a cycle of installation, that takes a minimum of 1/2 an hour, and even more if we want to try it during high load.
- This is not a regression.
- They were not reported by customers, which probably means that customers rarely install Windows guests on RHEL5.9. They probably install once and use a template (if at all). Since we are talking about RHEL5 host, this probably will not change.
- A simple workaround is usually to simply retry. Other workarounds are to use raw file (instead of QCOW), or to add virtio-stor driver only after the initial installation

Once any of these bugs is reported by a customer, we will reconsider. In most cases the customer should be able to retry and forget about it.

With uncomfortable feelings, Ronen.
Comment 10 Mike Cao 2012-08-20 23:27:34 EDT
*** Bug 849819 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.